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1. ESET Endpoint Security 7
ESET Endpoint Security 7 represents a new approach to truly integrated computer security. The most recent version
of the ThreatSense® scanning engine, combined with our custom Firewall and Antispam module, utilizes speed and
precision to keep your computer safe. The result is an intelligent system that is constantly on alert for attacks and
malicious software endangering your computer.

ESET Endpoint Security 7 is a complete security solution produced from our long-term effort to combine maximum
protection and a minimal system footprint. The advanced technologies, based on artificial intelligence, are capable
of proactively eliminating infiltration by viruses, spyware, trojan horses, worms, adware, rootkits, and other
Internet-borne attacks without hindering system performance or disrupting your computer.

ESET Endpoint Security 7 is primarily designed for use on workstations in a small business environment. Using ESET
Endpoint Security with ESET Security Management Center in an enterprise environment allows you to easily manage
any number of client workstations, apply policies and rules, monitor detections and remotely configure clients from
any networked computer.

1.1   What's new in version 7

ESET Endpoint Security 7 has been released and is available to download. For more information about what's new in
ESET Endpoint Security 7, see the following improvements or new features:

· New design of graphical user interface.

· Drag and drop files scan – You can scan a file or folder manually just by moving the file or folder to the marked
area.

· New type of logging – Advanced type of logging is now available.

· Network attack protection is now available in ESET Endpoint Antivirus.

· In Protection status, quick action link can be disabled by ESMC policy.

· Device control rules and Web control rules can be applied now for a certain time period. For more information,
see Time slots.

1.2   System requirements

For seamless operation of ESET Endpoint Security, the system should meet the following hardware and software
requirements (default product settings):

Processors Supported:

· 32-bit (x86) or 64-bit (x64) processor, 1 GHz or higher

Operating Systems:

Microsoft ® Windows ® 10/8.1/8/7/Vista

· An operating system and the required service pack supported by the chosen ESET product version installed

· System requirements of the operating system and other software installed on the computer are fulfilled

· 0.3 GB of free system memory (see Note 1)

· 1 GB of free disk space(see Note 2)

· Minimum display resolution 1024x768

· Internet connection or a local area network connection to a source (see Note 3) of product updates

Although it might be possible to install and run the product on systems that do not meet these requirements, we
recommend prior usability testing to be done based on performance requirements.



9

Note

(1): The product might use more memory if the memory would be otherwise unused on a heavily
infected computer or when huge lists of data are being imported into the product (e.g. URL white
lists).
(2): The disk space needed to download the installer, install the product and to keep a copy of the
installation package in program data as well as backups of product updates to support the rollback
feature. The product might use more disk space under different settings (e.g. when more product
update backup versions are stored, memory dumps or huge amounts of log records are kept) or on
an infected computer (e.g. due to the quarantine feature). We recommend to keep enough free disk
space to support the updates of the operating system and for ESET product updates.
(3): Although not recommended, the product might be updated manually from a removable media.

1.3   Prevention

When you work with your computer, and especially when you browse the Internet, please keep in mind that no
antivirus system in the world can completely eliminate the risk of infiltrations and attacks. To provide maximum
protection and convenience, it is essential that you use your antivirus solution correctly and adhere to several
useful rules:

Update regularly

According to statistics from ESET LiveGrid®, thousands of new, unique infiltrations are created each day in order to
bypass existing security measures and bring profit to their authors – all at the expense of other users. The specialists
at the ESET Virus Lab analyze these threats on a daily basis and prepare and release updates in order to continually
improve the level of protection for our users. To ensure the maximum effectiveness of these updates it is important
that updates are configured properly on your system. For more information on how to configure updates, see the
Update setup chapter.

Download security patches

The authors of malicious software often exploit various system vulnerabilities in order to increase the effectiveness
of spreading malicious code. With this in mind, software companies watch closely for any vulnerabilities in their
applications to appear and release security updates to eliminate potential threats on a regular basis. It is important
to download these security updates as they are released. Microsoft Windows and web browsers such as Internet
Explorer are two examples of programs for which security updates are released on a regular schedule.

Back up important data

Malware writers usually do not care about user’s needs, and the activity of malicious programs often leads to total
malfunction of an operating system and the loss of of important data. It is important to regularly back up your
important and sensitive data to an external source such as a DVD or external hard drive. This will make it far easier
and faster to recover your data in the event of system failure.

Regularly scan your computer for viruses

Detection of more known and unknown viruses, worms, trojans and rootkits are handled by the Real-time file
system protection module. This means that every time you access or open a file, it is scanned for a malware activity.
We recommend that you run a full Computer scan at least once a month because malware signatures may vary and
the detection engine updates itself each day.

Follow basic security rules

This is the most useful and most effective rule of all – always be cautious. Today, many infiltrations require user
intervention in order to be executed and distributed. If you are cautious when opening new files, you will save
considerable time and effort that would otherwise be spent cleaning infiltrations. Here are some useful guidelines:
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· Do not visit suspicious websites with multiple pop-ups and flashing advertisements.

· Be careful when installing freeware programs, codec packs, etc. Only use safe programs and only visit safe
Internet websites.

· Be cautious when opening email attachments, particularly those from mass-mailed messages and messages
from unknown senders.

· Don't use an Administrator account for everyday work on your computer.
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2. Documentation for users connected via ESET Security Management
Center
ESET Security Management Center (ESMC) is a new generation of remote management system that differs
significantly from previous versions of ESET Security Management Center. Since the architecture is completely
different, ESET Security Management Center 7 is only partially compatible with ERA 6 and there is no backward
compatibility with ERA 5. However, compatibility with previous versions of ESET security products remains.

Together with new ESET Security Management Center, ESET has developed a new generation of security products
with a new licensing system.

To perform a complete deployment of the ESET security solutions portfolio, the following components must be
installed (Windows and Linux platforms):

· ESMC Server

· ESMC Web Console

· ESET Management Agent

The following supporting components are optional, we recommend that you install them for best performance of
the application on the network:

· Proxy

· RD Sensor

· Apache HTTP Proxy

· Mobile Device Connector

More information

For more information please see the ESET Security Management Center Online help.

2.1   Introduction to ESET Security Management Center

Welcome to ESET Security Management Center (ESMC) version 7.0. ESET Security Management Center allows you to
manage ESET products on workstations, servers and mobile devices in a networked environment from one central
location. Using the ESET Security Management Center Web Console (ESMC Web Console), you can deploy ESET
solutions, manage tasks, enforce security policies, monitor system status and quickly respond to problems or
threats on remote computers. ESMC is made up of the following components:

· ESMC Server - ESMC Server can be installed on Windows as well as Linux servers and also comes as a Virtual
Appliance. It handles communication with Agents, and collects and stores application data in the database.

· ESMC Web Console - ESMC Web Console replaces ERA Console in older (v5) versions, and is the primary
interface that allows you to manage client computers in your environment. It displays an overview of the
status of clients on your network and allows you to deploy ESET solutions to unmanaged computers remotely.
After you install ESET Security Management Center Server (ESMC Server), you can access the Web Console
using your web browser. If you choose to make the web server available via the Internet, you can use ESMC
from any place and/or device with an Internet connection.

· ESET Management Agent - The ESET Management Agent facilitates communication between the ESMC Server
and client computers. The Agent must be installed on client computer to establish communication between
that computer and the ESMC Server. Because it is located on the client computer and can store multiple
security scenarios, use of the ESET Management Agent significantly lowers reaction time to new threats. Using
ESMC Web Console, you can deploy the ESET Management Agent to unmanaged computers identified by
Active Directory or ESET RD Sensor. You can also manually install the ESET Management Agent on client
computers if necessary.

https://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=supported_products
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=arch_server
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=arch_webconsole
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=arch_agent
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=arch_proxy
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=arch_rd_sensor
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=apache_http_proxy
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=mdm_core
http://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=arch_server
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=arch_webconsole
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=arch_agent
https://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=deployment_scenarios
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=arch_rd_sensor
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=installation
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· Rogue Detection Sensor - ESMC Rogue Detection Sensor detects unmanaged computers present on your
network and sends their information to the ESMC Server. This allows you to easily add new client computers to
your secured network. RD Sensor remembers computers that have been discovered and will not send the same
information twice.

· Apache HTTP Proxy - Is a service that can be used in combination with ESET Security Management Center to:

o distribute updates to client computers and installation packages to the ESET Management Agent.
o forward communication with ESET Management Agents to the ESMC Server.

· Mobile Device Connector - Is a component that allows for Mobile Device Management with ESET Security
Management Center, permitting you to manage mobile devices (Android and iOS) and administer ESET
Endpoint Security for Android.

· ESMC Virtual Appliance - The ESMC VA is intended for users who want to run ESET Security Management Center
(ESMC) in a virtualized environment.

· ESET Security Management Center Virtual Agent Host - A component of the ESET Security Management Center
that virtualizes agent entities to allow for the management of agent-less virtual machines. This solution
enables  automation, dynamic group utilization and the same level of task management as ESET Management
Agent on physical computers. The Virtual Agent collects information from virtual machines and sends it to the
ESMC Server.

· Mirror Tool - The mirror tool is necessary for offline modules updates. If your client computers do not have an
internet connection, you can use the Mirror Tool to download update files from ESET update servers and store
them locally.

· Migration Assistant - Migration assistant is designed to help you migrate from ERA 5 to ESMC 7. The Assistant is
a standalone application that uses a wizard to provide straightforward migration of ERA 5.x data into an
intermediate database that can then be imported into ESMC 7.

· Deployment Tool - This tool serves to deploy All-in-one packages created in the ESMC Web Console. It is a
convenient way to distribute ESET Management Agent with an ESET product on computers over a network.

· ESET Business Account - The new licensing portal for ESET business products allows you to manage licenses.
See the ESET Business Account section of this document for instructions to activate your product, or see the
ESET Business Account User Guide for more information about using the ESET Business Account. If you already
have an ESET-issued Username and Password that you want to convert to a License Key, see the Convert legacy
license credentials section.

· ESET Enterprise Inspector - A comprehensive Endpoint Detection and Response system that includes features
such as: incident detection, incident management and response, data collection, indicators of compromise
detection, anomaly detection, behavior detection and policy violations.

https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=arch_rd_sensor
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=apache_http_proxy
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=mdm_core
http://help.eset.com/getHelp?product=esmc_deploy_va&version=latest&lang=en-US
http://help.eset.com/getHelp?product=evs_nsx&version=latest&lang=en-US&topic=how_vah_works
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=mirror_tool_windows
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=migration_assistant
https://help.eset.com/getHelp?product=esmc_install&version=latest&lang=en-US&topic=deployment_tool
https://help.eset.com/eba/en-US/
https://help.eset.com/eba/en-US/
https://help.eset.com/getHelp?product=ela&lang=en-US&topic=convert
https://help.eset.com/getHelp?product=ela&lang=en-US&topic=convert
https://help.eset.com/getHelp?product=eei&version=latest&lang=en-US
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2.2   Password protected settings

To provide maximum security for your system, ESET Endpoint Security needs to be configured correctly. Any
unqualified change or setting may result in lowering the client security and level of protection. To limit user access
to advanced settings, an administrator can password protect the settings.

The administrator can create a policy to password protect the settings for ESET Endpoint Security on connected
client computers. To create a new policy:

1. In the ESMC web console, click Policies in the left-hand main menu.
2. Click New Policy.
3. Name your new policy and optionally, give it a short description. Click the Continue button.
4. From the list of products, select ESET Endpoint for Windows.
5. Click User interface in the Endpoint settings list and expand Access setup.
6. According to a version of ESET Endpoint Security, click the slider bar to enable Password to protect settings.

Note that Endpoint version 7 offers enhanced protection. If you have both version 7 and version 6 of Endpoint
products in the network, set a different password for each. Setting the password only in the field for version 6
is discouraged since doing so will lower the security on endpoints with version 7.

7. In the pop-up window, create a new password, confirm it and click OK. Click Continue.
8. The new policy needs to be assigned to clients. Click Assign and select the computers or groups of computers

to password protect. Click OK to confirm.
9. Check that all desired client computers are in the target list and click Continue.
10.Review the policy settings in the summary and click Finish to save your new policy.
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2.3   What are policies and how flags works

2.3.1   Policies

Policies are used to push specific configurations to ESET products running on client computers. This allows the
administrator to configure the ESET product on each client computer remotely. Policies can be targeted to individual
computers or groups of computers at a time. The administrator can assign multiple policies to a computer or a
group. 

A user must have the following permissions to create a new policy: Read permission to read the list of policies, Use
permission to assign policies to target computers and Write permission to create, modify or edit policies.

Policies are applied in the order that Static Groups are arranged. This is not true for Dynamic Groups, where policies
are applied to child Dynamic Groups first. This allows you to apply policies with greater impact to the top of the
Group tree and apply more specific policies to subgroups. Using flags, an ESET Endpoint Security user with access to
groups located higher in the tree can override the policies of lower groups. The algorithm is explained in ESMC
Online Help. 

Assign more generic policies

We recommend that you assign more generic policies (for example, the update server policy) to
groups that are higher within the group tree. More specific policies (for example, device control
settings) should be assigned deeper in the group tree. The lower policy usually overrides the
settings of the upper policies when merged (unless defined otherwise using policy flags).

2.3.2   Flags

The administrator can push specific configurations to ESET products running on client computers using policies from
the ESMC Web Console. A policy can be applied directly to individual computers as well as to groups of computers.
You can also assign multiple policies to a computer or to a group.

The policy that is applied to a client computer is usually the result of multiple policies being merged into one final
policy. When merging policies, you can adjust the expected behavior of the final policy, due to the order of applied
policies, by using policy flags. Flags define how the policy will handle a specific setting.

For each setting, you can select one of the following flags:

 Not apply - Any setting with this flag is not set by the policy. Since the setting is not set by the policy, it can be
changed by other policies applied later.

 Apply - Settings with the Apply flag will be applied to the client computer. However, when merging policies, it
can be overwritten by other policies applied later. When a policy is sent to a client computer containing settings
marked with this flag, those settings will change the local configuration of the client computer. Since the setting is
not forced, it can still be changed by other policies applied later. 

 Force - Settings with the Force flag have priority and cannot be overwritten by any policy applied later (even if it
also has a Force flag). This assures that other policies applied later won't be able to change this setting during
merging. When a policy is sent to a client computer containing settings marked with this flag, those settings will
change the local configuration of the client computer.

EXAMPLE: Allow users to see all policies

Scenario: The Administrator wants to allow user John to create or edit policies in his home group and see all policies created by the Administrator including Policies that have  Force flags. The Administrator wants John to be able to see all policies, but not edit existing policies created by Administrator. John can only create or edit policies within his Home Group, San Diego.

https://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_pol_how_policies_are_applied
https://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_pol_how_policies_are_applied
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Solution: Administrator has to follow these steps:
Create custom static groups and permission sets

1. Create a new Static Group called San Diego.

2. Create a new Permission set called Policy - All John with access to the Static Group All and with
Read permission for Policies. 

3. Create a new Permission set called Policy John with access to Static Group San Diego, with
functionality access Write permission for Group & Computers and Policies. This permission set
allows John to create or edit policies in his Home Group San Diego.

4. Create new user John and in the Permission Sets section select Policy - All John and Policy John.

Create policies

5. Create new policy All- Enable Firewall, expand the Settings section, select ESET Endpoint for

Windows, navigate to Personal Firewall > Basic and apply all settings by   Force flag. Expand
the Assign section and select the Static Group All.

6. Create new policy John Group- Enable Firewall, expand the Setting section, select ESET

Endpoint for Windows, navigate to Personal Firewall > Basic and apply all settings by  Apply
 flag. Expand the Assign section and select Static Group San Diego.

Result

The Policies created by Administrator will be applied first since  Force flags were applied to the
policy settings. Settings with the Force flag applied have priority and cannot be overwritten by
another policy applied later. The policies that are created by user John will be applied after the
policies created by the Administrator.

To see the final policy order, navigate to More > Groups > San Diego. Select the computer and
select Show details. In the Configuration section, click Applied policies.

2.3.3   Merging policies

A policy applied to a client is usually the result of multiple policies being merged into one final policy. Policies are
merged one by one. When merging policies, the general rule is that the later policy always replaces the settings set
by the former one. To change this behavior, you can use policy flags (Available for each setting). 

When creating policies, you will notice that some settings have an additional rule (replace/append/prepend) that
you can configure.

· Replace - the whole list is replaced, adds new values and removes all previous one.

· Append - items are added to the bottom of the currently applied list (must be another policy, the local list is
always overwritten).

· Prepend - items are added to the top of the list (the local list is overwritten).

ESET Endpoint Security supports merging of local settings with the remote policies in a new way. If the setting is a
list (for example a list of blocked websites) and remote policy conflicts with an existing local setting, the remote
policy overwrites it. You can choose how to combine local and remote lists by selecting the different merging rules
for:

·  Merging settings for remote policies.

·  Merging of remote and local policies - local settings with the resulting remote policy.

To learn more about merging policies, follow the ESMC online help and see the example.

https://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_create_new_static_subgroup
https://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_ar_permissions_sets
https://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_ar_permissions_sets
https://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_ar_create_native_user
https://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_pol_policies_wizard
https://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_pol_policies_wizard
https://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_pol_merging
https://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_pol_merging_example
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3. Using ESET Endpoint Security by itself
This section of this User Guide is intended for users who are using ESET Endpoint Security without ESET Security
Management Center. All features and functionalities of ESET Endpoint Security are fully accessible depending on a
user's account rights.

3.1   Installation with ESET AV Remover

Before you continue with the installation process, it is important that you uninstall any existing security application
on the computer. Select the check box next to I want to uninstall unwanted antivirus applications using ESET AV
Remover to have ESET AV Remover scan your system and remove any supported security applications. Leave the
check box deselected and click Continue to install ESET Endpoint Security without running ESET AV Remover.

http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN3527


17

3.1.1   ESET AV Remover

The ESET AV Remover tool will help you to remove almost any antivirus software previously installed on your
system. Follow the instructions below to remove an existing antivirus program using ESET AV Remover:

1. To view a list of antivirus software that ESET AV Remover can remove, visit ESET Knowledgebase article.

2. Read the End-User License Agreement and click Accept to acknowledge your acceptance. Clicking Decline will
continue to installation of ESET Endpoint Security without removal of existing security application on the
computer.

3. ESET AV Remover will begin searching your system for antivirus software.

http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN3527
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4. Select any listed antivirus applications and click Remove. Removal may take a moment.

5. When removal is successful, click Continue.
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6. Restart your computer to apply changes and continue with installation of ESET Endpoint Security. If uninstallation
is unsuccessful, see the Uninstallation with ESET AV Remover ended with an error section of this guide.

3.1.2   Uninstallation using ESET AV Remover ended with error

If you are not able to remove an antivirus program using ESET AV Remover, you will receive a notification that the
application you are trying to remove might not be supported by ESET AV Remover. Visit the list of supported
products or uninstallers for common Windows antivirus software on ESET Knowledgebase to see if this specific
program can be removed.

When the uninstallation of the security product was unsuccessful or some of its component was uninstalled
partially, you are prompted to Restart and rescan. Confirm UAC after startup and continue with the scanning and
uninstallation process.

If necessary, contact ESET Customer Care to open a support request and have the AppRemover.log file available to
assist ESET Technicians. The AppRemover.log file is located in the eset folder. Browse to %TEMP% in Windows
Explorer to access this folder. ESET Customer Care will respond as quickly as possible to help resolve your issue.

http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN3527
http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN3527
http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN146
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3.2   Installation

Once you launch the installer, the installation wizard will guide you through the installation process.

Important

Make sure that no other antivirus programs are installed on your computer. If two or more antivirus
solutions are installed on a single computer, they may conflict with each other. We recommend that
you uninstall any other antivirus programs on your system. See our knowledgebase article for a list
of uninstaller tools for common antivirus software (available in English and several other
languages).

http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN146
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In the next step, the End-User License Agreement will be displayed. Please read and click I Accept to acknowledge
your acceptance of the End-User License Agreement. Click Next after you accept the terms to continue with
installation.

After you select I Accept and click Next, you will be prompted to enable ESET LiveGrid® feedback system. ESET
LiveGrid® helps ensure that ESET is immediately and continuously informed about new infiltrations, which allows us
to better protect our customers. The system allows you to submit new threats to the ESET Virus Lab, where they are
analyzed, processed and added to the detection engine.
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The next step in the installation process is to configure detection of Potentially unwanted applications which are
not necessarily malicious, but can often negatively affect the behavior of your operating system. See the Potentially
unwanted applications chapter for more details. You can install your ESET product in a specific folder by clicking
Change installation folder.

The final step is to confirm installation by clicking Install.

3.2.1   Change installation folder

After selecting your preference for detection of potentially unwanted applications and clicking Change installation
folder, you will be prompted to select a location for the installation Product folder. By default, the program installs
to the following directory:

C:\Program Files\ESET\ESET Endpoint Security\

You can specify a location for program modules and data. By default, they are installed to the following directories,
respectfully:

C:\Program Files\ESET\ESET Endpoint Security\
C:\ProgramData\ESET\ESET Endpoint Security\

Click Browse to change these locations (not recommended).

Click Continue and then Install to start installation.
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3.3   Product installation via ESMC (command line)

The following settings are intended for use only with the reduced, basic and none level of the user interface. See
documentation for the msiexec version used for the appropriate command line switches.

Supported parameters:

APPDIR=<path>
o path - Valid directory path
o Application installation directory.
o For example: ees_nt64_ENU.msi /qn APPDIR=C:\ESET\ ADDLOCAL=DocumentProtection

APPDATADIR=<path>
o path - Valid directory path
o Application Data installation directory.

MODULEDIR=<path>
o path - Valid directory path
o Module installation directory.

ADDLOCAL=<list>
o Component installation - list of non-mandatory features to be installed locally.
o Usage with ESET .msi packages: ees_nt64_ENU.msi /qn ADDLOCAL=<list> 
o For more information about the ADDLOCAL property see http://msdn.microsoft.com/en-us/library/aa367536%

28v=vs.85%29.aspx

Rules

o The ADDLOCAL list is a comma separated list of all feature names to be installed.
o When selecting a feature to install, the whole path (all parent features) must be explicitly included in the

list.
o See additional rules for correct usage.

Feature Presence

o Mandatory - the feature will be always installed
o Optional - the feature may be deselected for install 
o Invisible - logical feature mandatory for other features to work properly
o Placeholder - feature with no effect on the product, but must be listed with sub-features

Feature tree of Endpoint 6.1 is following:

Feature tree Feature Name Feature Presence

Computer Computer Mandatory

Computer / Antivirus and antispyware Antivirus Mandatory

Computer / Antivirus and antispyware > Real-time
file system protection

RealtimeProtection Mandatory

Computer / Antivirus and antispyware > Computer
scan

Scan Mandatory

Computer / Antivirus and antispyware > Document
protection

Document protection Optional

Computer / Device control DeviceControl Optional

Network Network Placeholder

Network / Firewall Firewall Optional

Web and e-mail WebAndEmail Placeholder

Web and e-mail ProtocolFiltering ProtocolFiltering Invisible

Web and e-mail / Web access protection WebAccessProtection Optional

Web and e-mail / E-mail client protection EmailClientProtection Optional

http://msdn.microsoft.com/en-us/library/aa367536%28v=vs.85%29.aspx
http://msdn.microsoft.com/en-us/library/aa367536%28v=vs.85%29.aspx
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Web and e-mail / E-mail client protection /
MailPlugins

MailPlugins Invisible

Web and e-mail / E-mail client protection / Antispam
protection

Antispam Optional

Web and e-mail  / Web control WebControl Optional

Update mirror UpdateMirror Optional

Additional rules

o If any of the WebAndEmail feature/s is selected to be installed, the invisible ProtocolFiltering feature must
be explicitly included in the list.

o If any of the EmailClientProtection sub-features/s is selected to be installed, the invisible MailPlugins
feature must be explicitly included in the list

Examples:

ees_nt64_ENU.msi /qn ADDLOCAL=WebAndEmail,WebAccessProtection,ProtocolFiltering

ees_nt64_ENU.msi /qn ADDLOCAL=WebAndEmail,EmailClientProtection,Antispam,MailPlugins

List of CFG_ properties:

CFG_POTENTIALLYUNWANTED_ENABLED=1/0
• 0 - Disabled, 1 - Enabled
• PUA

CFG_LIVEGRID_ENABLED=1/0
• 0 - Disabled, 1 - Enabled
• LiveGrid

CFG_EPFW_MODE=0/1/2/3
• 0 - Automatic, 1 - Interactive, 2 - Policy, 3 - Learning

CFG_PROXY_ENABLED=0/1
• 0 - Disabled, 1 - Enabled

CFG_PROXY_ADDRESS=<ip>
• Proxy IP address.

CFG_PROXY_PORT=<port>
• Proxy port number.

CFG_PROXY_USERNAME=<user>
• User name for authentication.

CFG_PROXY_PASSWORD=<pass>
• Password for authentication.

Installation via SCCM, disable activation dialog :

ACTIVATION_DLG_SUPPRESS=1
• 1 - Enabled (activation dialog is not shown)
• 0 - Disabled (activation dialog is shown)
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3.4   Product activation

After installation is complete, you will be prompted to activate your product.

Select one of the available methods to activate ESET Endpoint Security. See How to activate ESET Endpoint Security
for more information.

3.5   Computer scan

We recommend that you perform regular computer scans, or schedule a regular scan, to check for threats. In the
main program window, click Computer scan and then click Smart scan. For more information about computer scans,
see Computer scan.

3.6   Upgrading to a more recent version

New versions of ESET Endpoint Security are issued to provide improvements or fix issues that cannot be resolved by
automatic updates to program modules. Upgrading to a more recent version can be accomplished in several ways:

1. Automatically, by means of a program update.
Since the program upgrade is distributed to all users and may impact certain system configurations, it is
issued after a long testing period to function with all possible system configurations. If you need to upgrade
to a newer version immediately after its release, use one of the methods below.

2. Manually, by downloading and installing a more recent version over the previous one.
3. Manually, via automatic deployment in a network environment via ESET Security Management Center.
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3.7   Beginner's guide

This chapter provides an initial overview of ESET Endpoint Security and its basic settings.

3.7.1   The user interface

The main program window of ESET Endpoint Security is divided into two main sections. The primary window on the
right displays information that corresponds to the option selected from the main menu on the left.

The following is a description of options within the main menu:

Protection status – Provides information about the protection status of ESET Endpoint Security.

Computer scan – This option allows you to configure and launch of Smart scan, Custom scan, or Removable media
scan. You can also repeat the last scan that was run.

Update – Displays information about the detection engine.

Setup – Select this option to adjust your Computer, Network or Web and Email security settings.

Tools – Provides access to Log files, Protection statistics, Watch activity, Running processes, Scheduler, Quarantine,
Network connections, ESET SysInspector and ESET SysRescue to create a rescue CD. You can also submit a sample for
analysis.

Help and support – Provides access to help files, ESET Knowledgebase and the ESET company website. Also available
are links to open a Customer Care support request, support tools, and information about product activation.

The Protection status screen informs you about the security and current protection level of your computer. The
green Maximum protection status indicates that maximum protection is ensured.

The status window also displays quick links to frequently used features in ESET Endpoint Security and information
about the last update.

http://go.eset.eu/knowledgebase?lng=1033&segment=business
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What to do if the program doesn't work properly?

A green check mark will be displayed next to all program modules that are fully functional. A red exclamation point
or orange notification icon is displayed if a module needs attention. Additional information about the module,
including our recommendation about how to restore full functionality is shown in the upper part of the window. To
change a module's status, click Setup in the main menu and then click the desired module.
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The red exclamation point  (!)  icon indicates that maximum protection of your computer is not ensured. You
may encounter this type of notification in the following scenarios:

· Antivirus and antispyware protection is paused – Click Start all antivirus and antispyware protection modules to
re-enable antivirus and antispyware protection in Protection status pane or Enable Antivirus and antispyware
protection in Setup pane in the main program window.

· Antivirus protection is non-functional – Virus scanner initialization failed. Most ESET Endpoint Security modules
will not function properly.

· Anti-Phishing protection is non-functional – This feature is not functional because other required program
modules are not active.

· The ESET Firewall is disabled – This problem is indicated by a red icon and a security notification next to the
Network item. Click Enable filtering mode to re-enable network protection.

· Firewall initialization failed – The firewall is disabled due to system integration issues. Restart your computer as
soon as possible.

· Detection engine is out of date – You are using an outdated detection engine. Update the detection engine.

· Product is not activated or License expired – This is indicated by the Protection status icon turning red. The
program is not able to update after the license expires. We recommend that you follow the instructions in the
alert window to renew your license.

· Host Intrusion Prevention System (HIPS) is disabled – This problem is indicated when HIPS disabled from
Advanced setup. Your computer is not protected against some types of threats and protection should be re-
enabled immediately by clicking Enable HIPS.

· ESET LiveGrid® is disabled – This problem is indicated when ESET LiveGrid® disabled in Advanced setup.

· No regular updates scheduled – ESET Endpoint Security will not check for or receive important updates unless you
schedule update task.

· Anti-Stealth is disabled – Click Enable Anti-Stealth to re-enable this functionality.

· Real-time file system protection is paused – Real-time protection was disabled by the user. Your computer is not
protected against threats. Click Enable Real-time protection re-enable this functionality.

The orange "i" indicates that your ESET product requires attention for a non-critical problem. Possible
reasons include:

· Web access protection is disabled – Click on the security notification to re-enable Web access protection and
then click Enable Web access protection.

· Your license will expire soon – This is indicated by the protection status icon displaying an exclamation point.
After your license expires, the program will not be able to update and the Protection status icon will turn red.

· Botnet protection is paused –  Click Enable Botnet protection to re-enable this feature.

· Network attack protection (IDS) is paused – Click Enable Network attack protection (IDS) to re-enable this
feature.

· Antispam protection is paused – Click Enable Antispam protection to re-enable this feature.

· Web control is paused – Click Enable Web control to re-enable this feature.

· Policy override active – The configuration set by the policy is temporarily overridden, possibly until
troubleshooting is complete. Only authorized user can override the policy settings. For more information see
How to use Override mode.

· Device control is paused – Click Enable Device control to re-enable this feature.

If you are unable to solve a problem using the suggested solutions, click Help and support to access the help files or
search the ESET Knowledgebase. If you still need assistance, you can submit an ESET Customer Care support request.
ESET Customer Care will respond quickly to your questions and help find a resolution.

Note

If a status belongs to a feature that is blocked by ERA policy, the link will not be clickable.

http://go.eset.eu/knowledgebase?lng=1033&segment=business
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3.7.2   Update setup

Updating modules is an important part of maintaining complete protection against malicious code. Please pay
careful attention to update configuration and operation. From the main menu, select Update > Update now to check
for a newer module update.

If your License Key is not entered yet, you will be unable to receive new updates and will be prompted to activate
your product.
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The Advanced setup window (click Setup > Advanced setup from the main menu, or press F5 on your keyboard)
contains additional update options. To configure advanced update options such as update mode, proxy server
access, LAN connections and detection engine copy creation settings, click Update in the Advanced setup tree. If
you experience problems with an update, click Clear to clear the temporary update cache. The Update server menu
is set to AUTOSELECT by default. When using an ESET server, we recommend that you leave the Choose
automatically option selected. If you do not want the system tray notification at the bottom right corner of the
screen to appear, select Disable display notification about successful update.

For optimal functionality, it is important that the program is automatically updated. This is only possible if the
correct License key is entered in Help and support > Activate Product.

If you did not enter your License key after installation, you can do so at any time. For more detailed information
about activation see How to activate ESET Endpoint Security and enter the credentials you received with your ESET
security product in License details window.
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3.7.3   Zones setup

It is necessary to configure Trusted zones to protect your computer in a network environment. You can allow other
users to access your computer by configuring a Trusted zone to allow sharing. Click Advanced Setup (F5) > Firewall >
Zones to access settings for Trusted zones.

Trusted zone detection occurs after ESET Endpoint Security installation and whenever your computer connects to a
new network. Therefore, there is usually no need to define the Trusted zone. By default, a dialog window is
displayed upon detection of a new zone which allows you to set the protection level for that zone.

Important

An incorrect trusted zone configuration may pose a security risk to your computer.

Note

By default, workstations from a Trusted zone are granted access to shared files and printers, have
incoming RPC communication enabled and have remote desktop sharing available.

3.7.4   Web control tools

If you have already enabled Web control in ESET Endpoint Security, you must also configure Web control for your
desired user accounts in order for Web control to function properly. Please refer to the Web control chapter for
instructions on how to create specific restrictions for your client workstations to protect them from potentially
offensive material.
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3.8   Common Questions

This chapter covers some of the most frequently asked questions and problems encountered. Click a topic title to
find out how to solve your problem:

How to update ESET Endpoint Security 
How to activate ESET Endpoint Security
How to use current credentials to activate a new product
How to remove a virus from my PC
How to allow communication for a certain application
How to create a new task in Scheduler
How to schedule a scan task (every 24 hours)
How to connect my product to ESET Security Management Center
How to configure a mirror

If your problem is not included in the help pages listed above, try searching by keyword or phrase describing your
problem in the ESET Endpoint Security Help pages.

If you cannot find the solution to your problem/question in the Help pages, visit the ESET Knowledgebase where
answers to common questions and issues are available.

How do I remove Sirefef (ZeroAccess) trojan?
Update Mirror troubleshooting checklist
What addresses and ports on my third-party firewall should I open to allow full functionality for my ESET product?

If necessary, you can contact our online technical support center with your questions or problems. The link to our
online contact form can be found in the Help and Support pane in the main program window.

3.8.1   How to update ESET Endpoint Security

Updating ESET Endpoint Security can be performed either manually or automatically. To trigger the update, click
Update now in the Update section in main menu.

The default installation settings create an automatic update task which is performed on an hourly basis. To change
the interval, navigate to Tools > Scheduler (for more information on Scheduler, click here).

3.8.2   How to activate ESET Endpoint Security

After installation is complete, you will be prompted to activate your product.

There are several methods for activating your product. Availability of a particular activation scenario in the
activation window may vary depending on the country, as well as the means of distribution (CD/DVD, ESET web
page, etc.).

To activate your copy of ESET Endpoint Security directly from the program, click the system tray icon  and select
Activate product license from the menu. You can also activate your product from the main menu under Help and
support > Activate product or Protection status > Activate product.

You can use any of the following methods to activate ESET Endpoint Security:

· License Key – A unique string in the format XXXX-XXXX-XXXX-XXXX-XXXX which is used for identification of the
license owner and for activation of the license.

· Security Admin – An account created on the ESET License Administrator portal with credentials (email address +
password). This method allows you to manage multiple licenses from one location.

· Offline License – An automatically generated file that will be transferred to the ESET product to provide license
information. If a license allows you to download an offline license file (.lf) that file can be used to perform
offline activation. The number of offline licenses will be subtracted from the total number of available
licenses. For more details about generation of an offline file see the ESET License Administrator User Guide.

http://go.eset.eu/knowledgebase?lng=1033&segment=bussines
http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN2895
http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN3281
http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN332
https://ela.eset.com/
http://help.eset.com/getHelp?product=ela&lang=en-US&topic=downloading_offline_legacy_licenses
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Click Activate later if your computer is a member of managed network and your administrator will perform remote
activation via ESET Security Management Center. You can also use this option if you would like to activate this client
at a later time.

If you have a Username and Password and do not know how to activate ESET Endpoint Security click I have a
Username and Password, what do I do. You will be redirected to ESET License Administrator, where you can convert
your credentials into a License key.

You can change your product license at any time. To do so, click Help and support > Manage license in the main
program window. You will see the public license ID used to identify your license to ESET Support. The Username
under which your computer is registered is stored in the About section, which you can view by right-clicking the

system tray icon .

Note

ESET Security Management Center can activate client computers silently using licenses made
available by the administrator. For instructions to do so, see the ESET Security Management Center
Online help.

3.8.3   How to use current credentials to activate a new product

If you already have your Username and Password and would like to receive a License Key, visit the ESET License
Administrator portal, where you can convert your credentials to a new License Key.

3.8.4   How to remove a virus from my PC

If your computer is showing symptoms of malware infection, for example it is slower, often freezes, we recommend
that you do the following:

1. In the main program window, click Computer scan.

2. Click Smart scan to begin scanning your system.

3. After the scan has finished, review the log with the number of scanned, infected and cleaned files.

4. If you want to only scan a certain part of your disk click Custom scan and select targets to be scanned for viruses.

For additional information please see our regularly updated ESET Knowledgebase article.

http://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=client_tasks_product_activation
http://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=client_tasks_product_activation
https://ela.eset.com/
https://ela.eset.com/
http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN2505
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3.8.5   How to allow communication for a certain application

If a new connection is detected in interactive mode and if there is no matching rule, you will be prompted to allow
or deny the connection. If you want ESET Endpoint Security to perform the same action every time the application
attempts to establish a connection, select the Remember action (create rule) check box.

You can create new firewall rules for applications before they are detected by ESET Endpoint Security in the firewall
setup window, located under Advanced setup > Firewall > Basic > Rules by clicking Edit.

Click Add to add the rule. In the General tab, enter the name, direction and communication protocol for the rule.
This window allows you to define the action to be taken when the rule is applied.

Enter the path to the application's executable and the local communication port in the Local tab. Click the Remote
tab to enter the remote address and port (if applicable). The newly-created rule will be applied as soon as the
application tries to communicate again.

3.8.6   How to create a new task in Scheduler

To create a new task in Tools > Scheduler, click Add task or right-click and select Add... from the context menu. Five
types of scheduled tasks are available:

· Run external application – Schedules the execution of an external application.

· Log maintenance - Log files also contains leftovers from deleted records. This task optimizes records in log files
on a regular basis to work effectively.

· System startup file check – Checks files that are allowed to run at system startup or logon.

· Create a computer status snapshot – Creates an ESET SysInspector computer snapshot – gathers detailed
information about system components (for example, drivers, applications) and assesses the risk level of each
component.

· On-demand computer scan – Performs a computer scan of files and folders on your computer.

· Update – Schedules an Update task by updating modules.

Since Update is one of the most frequently used scheduled tasks, we will explain how to add a new update task
below: 
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From the Scheduled task drop-down menu, select Update. Enter the name of the task into the Task name field and 
click Next. Select the frequency of the task. The following options are available: Once, Repeatedly, Daily, Weekly
and Event triggered. Select Skip task when running on battery power to minimize system resources while a laptop is
running on battery power. The task will be run on the specified date and time in Task execution fields. Next, define
the action to take if the task cannot be performed or completed at the scheduled time. The following options are
available:

· At the next scheduled time

· As soon as possible

· Immediately, if time since last exceeds a specified value (the interval can be defined using the Time since last
run scroll box)

In the next step, a summary window with information about the current scheduled task is displayed. Click Finish
when you are finished making changes.

A dialog window will appear, allowing you to select the profiles to be used for the scheduled task. Here you can set
the primary and alternative profile. The alternative profile is used if the task cannot be completed using the primary
profile. Confirm by clicking Finish and the new scheduled task will be added to the list of currently scheduled tasks.

3.8.7   How to schedule a scan task (every 24 hours)

To schedule a regular task, open the main program window and click Tools > Scheduler. Below, you can find a short
guide on how to schedule a task that will scan your local drives every 24 hours.

To schedule a scan task:

1. Click Add in the main Scheduler screen.

2. Select On-demand computer scan from the drop-down menu.

3. Enter a name for the task and select Repeatedly.

4. Choose to run the task every 24 hours.

5. Select an action to perform if the scheduled task execution fails for any reason.

6. Review the summary of the scheduled task and click Finish.

7. From the Targets drop-down menu, select Local drives.

8. Click Finish to apply the task.

3.8.8   How to connect ESET Endpoint Security to ESET Security Management Center

When you have installed ESET Endpoint Security on your computer and you want to connect via ESET Security
Management Center, make sure that you have also installed ERA Agent on your client workstation. ERA Agent is an
essential part of every client solution that communicates with ERA Server. ESET Security Management Center uses
the RD Sensor tool to search for computers on the network. Every computer on your network that is detected by RD
Sensor is displayed in the Web Console.

Once the Agent is deployed, you can perform remote installation of ESET security products on your client computer.
The exact steps for remote installation are described in the ESET Security Management Center User Guide.

http://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=fs_product_installation
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3.8.9   How to configure a mirror

ESET Endpoint Security can be configured to store copies of detection engine update files and distribute updates to
other workstations that are running ESET Endpoint Security or ESET Endpoint Antivirus.

Configuring ESET Endpoint Security as a Mirror server to provide updates via an internal HTTP server

Press F5 to access Advanced setup and expand Update > Basic. Make sure the Update server is set to AUTOSELECT.
Select Create update mirror and Provide update files via internal HTTP server from Advanced setup > Basic > Mirror.

Configuring a Mirror server to provide updates via a shared network folder

Create a shared folder on a local or network device. This folder must be readable by all users running ESET security
solutions and writable from the local SYSTEM account. Activate Create update mirror under Advanced setup > Basic >
Mirror. Browse and select the created shared folder.

Note

If you do not want to update via internal HTTP server disengage Provide update files via internal
HTTP server.

3.8.10   How do I upgrade to Windows 10 with ESET Endpoint Security

Warning

We highly recommend that you upgrade to the latest version of your ESET product, then download
the latest module updates, before upgrading to Windows 10. This will ensure maximum protection
and preserve your program settings and license information during the upgrade to Windows 10.

Version 7.x:

Click the appropriate link below to download and install the latest version to prepare for your upgrade to Microsoft
Windows 10:

Download ESET Endpoint Security 7 32-bit    Download ESET Endpoint Antivirus 7 32-bit

Download ESET Endpoint Security 7 64-bit    Download ESET Endpoint Antivirus 7 64-bit

Version 5.x:

Click the appropriate link below to download and install the latest version to prepare for your upgrade to Microsoft
Windows 10:

Download ESET Endpoint Security 5 32-bit    Download ESET Endpoint Antivirus 5 32-bit

Download ESET Endpoint Security 5 64-bit    Download ESET Endpoint Antivirus 5 64-bit

Other language versions:

If you are looking for another language version of your ESET endpoint product, please visit our download page.

Note

More information about compatibility of ESET business products with Windows 10.

https://download.eset.com/com/eset/apps/business/ees/windows/latest/ees_nt32_enu.msi
https://download.eset.com/com/eset/apps/business/eea/windows/latest/eea_nt32_enu.msi
https://download.eset.com/com/eset/apps/business/ees/windows/latest/ees_nt64_enu.msi
https://download.eset.com/com/eset/apps/business/eea/windows/latest/eea_nt64_enu.msi
https://download.eset.com/com/eset/apps/business/ees/windows/v5/latest/ees_nt32_enu.msi
https://download.eset.com/com/eset/apps/business/eea/windows/v5/latest/eea_nt32_enu.msi
https://download.eset.com/com/eset/apps/business/ees/windows/v5/latest/ees_nt64_enu.msi
https://download.eset.com/com/eset/apps/business/eea/windows/v5/latest/eea_nt64_enu.msi
https://www.eset.com/int/download-business/
http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN3749
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3.8.11   How to use Override mode

Users with ESET Endpoint products (version 6.5 and above) for Windows installed on their machine can use the
Override feature. Override mode allows users on the client-computer level to change settings in the installed ESET
product, even if there is a policy applied over these settings. Override mode can be enabled for certain AD users, or
it can be password-protected. The function can not be enabled for more than four hours at once.

Warning

Override mode can not be stopped from the ERA  Web Console once it is enabled. Override is
disabled only after the time of override expires, or after it is turned off on the client itself.

To set the Override mode:

1. Navigate to Admin > Polices > New Policy.

2. In the  Basic section, type in a Name and Description for this policy.

3. In the  Settings section, select ESET Endpoint for Windows.

4. Click Override mode and configure rules for override mode.

5. In the  Assign section, select the computer or group of computers on which this policy will be applied.

6. Review the settings in the  Summary section and click Finish to apply the policy.

After the override policy is applied from ERA Server to ERA Agent, there will appear a button in the Advanced
settings (of Endpoint on the client) Override policy.

1. Click Override policy.

2. Set time and click Apply.

3. Allow elevated rights for the ESET application.



38

4. Enter the password determined by the policy (or no password if Active Directory user was set in the policy).

5. Allow elevated rights for the ESET application.

6. Now the Override mode is on.

7. To end this, click End override.

Example

If John has a problem with his endpoint settings blocking some important functionality or web
access on his machine, the Administrator can allow John to override his existing endpoint policy and
tweak the settings manually on his machine. Afterward, these new settings can be requested by ERA
so the Administrator can create a new policy out of them. 

To do so, follow the steps below:

1. Navigate to Admin > Polices > New Policy.
2. Complete the Name and Description fields. In the Settings section, select ESET Endpoint for

Windows.
3. Click Override mode, enable the override mode for one hour and select John as the AD user.
4. Assign the policy to John's computer and click Finish to save the policy.
5. John has to enable the Override mode on his ESET endpoint and change the settings manually on

his machine.
6. On the ERA Web Console, navigate to Computers, select John's computer and click Show Details.
7. In the Configuration section, click Request configuration to schedule a client task to get the

configuration from the client ASAP.
8. After short time, the new configuration will appear. Click on the product which settings you want

to save and then click Open Configuration.
9. You can review settings and then click Convert to policy.
10.Complete the Name and Description fields.
11.In the Settings section, you can modify the settings if needed.
12.In the Assign section, you can assign this policy to John's computer (or others).
13.Click Finish to save the settings.
14.Do not forget to remove the override policy once it is no longer needed.
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3.8.12   How to activate Remote monitoring and management

Remote Monitoring and Management (RMM) is the process of supervising and controlling software systems (such as
those on desktops, servers and mobile devices) using a locally installed agent that can be accessed by a
management service provider.

By default, ESET RMM is disabled. To enable ESET RMM, press F5 to access Advanced setup, click Tools, expand ESET
RMM and turn on the switch next to Enable RMM.

Working mode – Select the working mode of RMM from the drop-down menu. Two options are available: Safe
operations only and All operations.

Authorization method – Set the RMM authorization method. To use authorization, select Application path from the
drop-down menu, otherwise select None.

Warning

RMM should always use authorization to prevent malicious software from disabling or
circumventing ESET Endpoint protection.

Application paths – If you have selected Application path as an authorization method, click Edit to open the Allowed
RMM application paths configuration window.
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Add – Create a new allowed RMM application path. Enter the path or click the … button to select an executable.
Edit – Modify an existing allowed path. Use Edit if the location of the executable has changed to another folder.

Delete – Delete an existing allowed path.

Default ESET Endpoint Security installation contains file ermm.exe located in Endpoint application directory (default
path c:\Program Files\ESET\ESET Security ). ermm.exe exchange data with RMM Plugin, which communicates with
RMM Agent, linked to a RMM Server.

· ermm.exe – command line utility developed by ESET that allows managing of Endpoint products and
communication with any RMM Plugin.

· RMM Plugin is a third party application running locally on Endpoint Windows system. The plugin was designed
to communicate with specific RMM Agent (e.g. Kaseya only) and with ermm.exe.

· RMM Agent is a third party application (e.g. from Kaseya) running locally on Endpoint Windows system. Agent
communicates with RMM Plugin and with RMM Server.

· RMM Server is running as a service on a third party server. Supported RMM systems are by Kaseya, Labtech,
Autotask, Max Focus and Solarwinds N-able.
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3.8.13   How to block the download of specific file types from the Internet

If you do not want to allow downloading of specific file types (f.e. exe, pdf or zip) from the internet, use URL
Address management with a combination of wildcards. Press the F5 key to access Advanced setup. Click Web and
Email > Web access protection and expand URL Address Management. Click Edit next to Address list.

In the Address list window, select List of blocked addresses and click Edit, or click Add to create a new list. A new
window opens. If you are creating a new list, select Blocked from the Address list type drop-down menu and name
the list. If you want to be notified when accessing a file type from the current list, enable the Notify when applying
slider bar. Select the Logging severity from the drop-down menu. Remote Administrator can collect records with
Warning verbosity.

Click Add to enter a mask that specifies file types you want to block from downloading. Enter the full URL if you
want to block the download of a specific file from a specific website, for example, http://example.com/f ile.exe . You
can use wildcards to cover a group of files. A question mark (?) represents a single variable character whereas an
asterisk (*) represents a variable string of zero or more characters. For example, the mask */*.zip blocks all zip
compressed files to be downloaded.
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3.9   Work with ESET Endpoint Security

The ESET Endpoint Security setup options allow you to adjust the level of protection for your computer, web, email
and network.

Note

When creating a policy from ESET Security Management Center Web Console you can select the flag
for each setting. Settings with the Force flag have priority and cannot be overwritten by a later
policy (even if the later policy has a Force flag). This assures that this setting will not be changed
(e.g. by user or by later policies during merging). For more information see Flags in ESMC Online
help.

http://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_pol_flags
http://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_pol_flags
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The Setup menu contains the following sections:

· Computer

· Network

· Web and Email

Computer protection setup allows you to enable or disable the following components:

· Real-time file system protection – All files are scanned for malicious code when they are opened, created or
run on your computer.

· Document protection – The document protection feature scans Microsoft Office documents before they are
opened, as well as files downloaded automatically by Internet Explorer, such as Microsoft ActiveX elements.

· HIPS – The HIPS system monitors events that occur within the operating system and reacts to them according to
a customized set of rules.

· Presentation mode – A feature for users that demand uninterrupted usage of their software, do not want to be
disturbed by pop-up windows, and want to minimize CPU usage. You will receive a warning message (potential
security risk) and the main program window will turn orange after enabling Presentation mode.

· Anti-Stealth protection – Provides detection of dangerous programs, such as rootkits, which are able to hide
themselves from the operating system. This means it is not possible to detect them using ordinary testing
techniques.

The Network section allows you to enable or disable the Firewall, Network attack protection and Botnet protection.

Web and email protection setup allows you to enable or disable the following components:

· Web control – Blocks web pages that may contain potentially offensive material. In addition, system
administrators can specify access preferences for 27 pre-defined website categories.

· Web access protection – If enabled, all traffic through HTTP or HTTPS is scanned for malicious software.

· Email client protection – Monitors communication received through the POP3 and IMAP protocol.

· Antispam protection – Scans unsolicited email or spam.

· Anti-Phishing protection – Protects you from attempts to acquire passwords, banking data and other sensitive
information by illegitimate websites disguised as legitimate ones.

To temporarily disable individual modules, click the green switch  next to the desired module. Note that this
may decrease the protection level of your computer.

To re-enable the protection of a disabled security component, click the red switch  to return a component to its
enabled state.

When ERA policy is applied, you will see the lock icon  next to a specific component. The policy applied by ESET
Security Management Center can be overridden locally after authentication by logged user (e.g. administrator). For
more information see the ESMC Online help.

Note

All protective measures disabled this way will be re-enabled after a computer restart.

To access detailed settings for a particular security component, click the gear wheel  next to any component.

There are additional options at the bottom of the setup window. To load setup parameters using an .xml
configuration file, or to save the current setup parameters to a configuration file, use Import/Export settings. Please
see Import/Export settings for more detailed information.

For more detailed options, click Advanced Setup or press F5.

http://help.eset.com/getHelp?product=esmc_admin&version=latest&lang=en-US&topic=admin_pol_override
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3.9.1   Computer

The Computer module can be found under Setup > Computer. It displays an overview of the protection modules
described in the previous chapter. In this section, the following settings are available:

Click the gear wheel  next to Real-time file system protection and click Edit exclusions to open the Exclusion
setup window, which allows you to exclude files and folders from scanning.

Note

Document protection status may not be available until you enable it in Advanced setup (F5) >
Antivirus > Document protection. After you enable it, you need to restart your computer from Setup
pane > Computer by clicking Restart under Device control or you can do it from Protection status
pane by clicking Restart computer.

Pause Antivirus and antispyware protection – Any time that you temporarily disable Antivirus and antispyware
protection, you can select the period of time for which you want the selected component to be disabled using the
drop-down menu and then click Apply to disable the security component. To re-enable protection, click Enable
Antivirus and antispyware protection.

Computer scan setup... – Click to adjust the parameters of the computer scan (manually executed scan).

3.9.1.1   Detection engine

Antivirus protection guards against malicious system attacks by controlling file, email and Internet communication.
If a threat is detected, the Antivirus module can eliminate it by first blocking it and then cleaning, deleting or
moving it to quarantine.

To configure Antivirus module settings in detail, click Advanced Setup or press F5.

Scanner options for all protection modules (for example Real-time file system protection, Web access
protection, ...) allows you to enable or disable detection of the following:

· Potentially unwanted applications (PUAs) are not necessarily intended to be malicious, but may affect the
performance of your computer in a negative way.
Read more about these types of applications in the glossary.

· Potentially unsafe applications refers to legitimate commercial software that has the potential to be misused for
malicious purposes. Examples of potentially unsafe applications include remote access tools, password-cracking
applications, and keyloggers (programs recording each keystroke typed by a user). This option is disabled by
default.
Read more about these types of applications in the glossary.

· Suspicious applications include programs compressed with packers or protectors. These types of protectors are
often exploited by malware authors to evade detection.

Anti-Stealth technology is a sophisticated system that provides the detection of dangerous programs such as
rootkits, which are able to hide themselves from the operating system. This means it is not possible to detect them
using ordinary testing techniques.

Exclusions enable you to exclude files and folders from scanning. To ensure that all objects are scanned for threats,
we recommend only creating exclusions when it is absolutely necessary. Situations where you may need to exclude
an object might include scanning large database entries that would slow your computer during a scan or software
that conflicts with the scan. To exclude an object from scanning see Exclusions.

Enable advanced scanning via AMSI – Microsoft Antimalware Scan Interface tool that allows application developers
new malware defenses (Windows 10 only).
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3.9.1.1.1   An infiltration is detected

Infiltrations can reach the system from various entry points such as webpages, shared folders, via email or from
removable devices (USB, external disks, CDs, DVDs, diskettes, etc.).

Standard behavior

As a general example of how infiltrations are handled by ESET Endpoint Security, infiltrations can be detected using:

· Real-time file system protection

· Web access protection

· Email client protection

· On-demand computer scan

Each uses the standard cleaning level and will attempt to clean the file and move it to Quarantine or terminate the
connection. A notification window is displayed in the notification area at the bottom right corner of the screen. For
more information about cleaning levels and behavior, see Cleaning.
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Cleaning and deleting

If there is no predefined action to take for Real-time file system protection, you will be prompted to select an
option in the alert window. Usually the options Clean, Delete and No action are available. Selecting No action is not
recommended, as this will leave infected files uncleaned. The exception to this is when you are sure that a file is
harmless and has been detected by mistake.

Apply cleaning if a file has been attacked by a virus that has attached malicious code to the file. If this is the case,
first attempt to clean the infected file in order to restore it to its original state. If the file consists exclusively of
malicious code, it will be deleted.

If an infected file is “locked“ or in use by a system process, it will usually only be deleted after it is released
(normally after a system restart).

Multiple threats

If any infected files were not cleaned during Computer scan (or the Cleaning level was set to No Cleaning), an alert
window prompting you to select action for those files is displayed.

Deleting files in archives

In Default cleaning mode, the entire archive will be deleted only if it contains infected files and no clean files. In
other words, archives are not deleted if they also contain harmless clean files. Use caution when performing a Strict
cleaning scan, with Strict cleaning enabled an archive will be deleted if it contains at least one infected file
regardless of the status of other files in the archive.

If your computer is showing signs of a malware infection, for example, it is slower, often freezes, etc., we
recommend that you do the following:

· Open ESET Endpoint Security and click Computer scan

· Click Smart scan (for more information, see Computer scan)

· After the scan has finished, review the log for the number of scanned, infected and cleaned files

If you only want to scan a certain part of your disk, click Custom scan and select targets to be scanned for viruses.
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3.9.1.2   Shared local cache

Shared local cache will boost performance in virtualized environments by eliminating duplicate scanning in the
network. This ensures that each file will be scanned only once and stored in the shared cache. Turn on the Caching
option switch to save information about scans of files and folders on your network to the local cache. If you perform
a new scan, ESET Endpoint Security will search for scanned files in the cache. If files match, they will be excluded
from scanning.

The setup of Cache server contains the following:

· Hostname – Name or IP address of the computer where the cache is located.

· Port – Number of port used for communication (same as was set in Shared local cache).

· Password – Specify the ESET Shared local cache password if required.

3.9.1.3   Real-time file system protection

Real-time file system protection controls all antivirus-related events in the system. All files are scanned for
malicious code when they are opened, created, or run on your computer. Real-time file system protection is
launched at system startup.

By default, Real-time file system protection launches at system start-up and provides uninterrupted scanning. In
special cases (for example, if there is a conflict with another real-time scanner), real-time protection can be
disabled by disengaging Enable Real-time file system protection in Advanced setup under Real-time file system
protection > Basic.

Media to scan

By default, all types of media are scanned for potential threats:

Local drives – Controls all system hard drives.
Removable media – Controls CD/DVDs, USB storage, Bluetooth devices, etc.

Network drives – Scans all mapped drives.
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We recommend that you use default settings and only modify them in specific cases, such as when scanning certain
media significantly slows data transfers.

Scan on

By default, all files are scanned upon opening, creation, or execution. We recommend that you keep these default
settings, as they provide the maximum level of real-time protection for your computer:

· File open – Enables or disables scanning when files are opened.

· File creation – Enables or disables scanning when files are created.

· File execution – Enables or disables scanning when files are run.

· Removable media access – Enables or disables scanning triggered by accessing particular removable media
with storage space.

Real-time file system protection checks all types of media and is triggered by various system events such as
accessing a file. Using ThreatSense technology detection methods (as described in the ThreatSense engine
parameter setup section), Real-time file system protection can be configured to treat newly created files differently
than existing files. For example, you can configure Real-time file system protection to more closely monitor newly
created files.

To ensure a minimal system footprint when using real-time protection, files that have already been scanned are not
scanned repeatedly (unless they have been modified). Files are scanned again immediately after each update of
the detection engine. This behavior is controlled using Smart optimization. If this Smart optimization is disabled, all
files are scanned each time they are accessed. To modify this setting, press F5 to open Advanced setup and expand
Detection engine > Real-time file system protection. Click ThreatSense parameters > Other and select or deselect
Enable Smart optimization.

3.9.1.3.1   Additional ThreatSense parameters

Additional ThreatSense parameters for newly created and modified files – The probability of infection in newly-
created or modified files is comparatively higher than in existing files. For this reason, the program checks these
files with additional scanning parameters. Along with common signature-based scanning methods, advanced
heuristics, which can detect new threats before the detection engine update is released, are also used. In addition
to newly-created files, scanning is performed on self-extracting files (.sfx) and runtime packers (internally
compressed executable files). By default, archives are scanned up to the 10th nesting level and are checked
regardless of their actual size. To modify archive scan settings, disable Default archive scan settings.

To learn more about Runtime packers, Self-extracting archives and Advanced heuristics see ThreatSense engine
parameters setup.

Additional ThreatSense parameters for executed files – By default, Advanced heuristics is used when files are
executed. When enabled, we strongly recommend keeping Smart optimization and ESET LiveGrid® enabled to
mitigate impact on system performance.

3.9.1.3.2   Cleaning levels

Real-time protection has three cleaning levels (to access cleaning level settings, click ThreatSense engine
parameter setup in the Real-time file system protection section and then click Cleaning).

No cleaning – Infected files will not be cleaned automatically. The program will display a warning window and allow
the user to choose an action. This level is designed for more advanced users who know which steps to take in the
event of an infiltration.

Normal cleaning – The program will attempt to automatically clean or delete an infected file based on a predefined
action (depending on the type of infiltration). Detection and deletion of an infected file is signaled by a notification
the bottom-right corner of the screen. If it is not possible to select the correct action automatically, the program
provides other follow-up actions. The same happens when a predefined action cannot be completed.

Strict cleaning – The program will clean or delete all infected files. The only exceptions are the system files. If it is
not possible to clean them, the user is prompted to select an action by a warning window.
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Warning

If an archive contains a file or files which are infected, there are two options for dealing with the
archive. In standard mode (Standard cleaning), the whole archive would be deleted if all the files it
contains are infected files. In Strict cleaning mode, the archive would be deleted if it contains at
least one infected file, regardless of the status of the other files in the archive.

3.9.1.3.3   Checking real-time protection

To verify that real-time protection is working and detecting viruses, use a test file from eicar.com. This test file is a
harmless file detectable by all antivirus programs. The file was created by the EICAR company (European Institute
for Computer Antivirus Research) to test the functionality of antivirus programs. The file is available for download at
http://www.eicar.org/download/eicar.com

Note

Before performing a real-time protection check, it is necessary to disable the firewall. If the firewall
is enabled, it will detect the file and prevent test files from downloading. Make sure that you re-
enable the firewall immediately following your check of real-time file system protection.

3.9.1.3.4   When to modify real-time protection configuration

Real-time file system protection is the most essential component for maintaining a secure system. Always be
careful when modifying its parameters. We recommend that you only modify its parameters in specific cases.

After installing ESET Endpoint Security, all settings are optimized to provide the maximum level of system security

for users. To restore default settings, click  next to each tab in the window (Advanced setup > Detection engine >
Real-time file system protection).

3.9.1.3.5   What to do if real-time protection does not work

In this chapter, we describe problems that may arise when using real-time protection and how to troubleshoot
them.

Real-time protection is disabled

If real-time protection was inadvertently disabled by a user, it needs to be reactivated. To reactivate real-time
protection, navigate to Setup in the main program window and click Real-time file system protection.

If real-time protection is not initiated at system startup, it is usually because Start Real-time file system protection
automatically is deselected. To enable this option, navigate to Advanced setup (F5) and click Detection engine >
Real-time file system protection > Basic. Make sure that the Start Real-time file system protection automatically
switch is turned on.

If Real-time protection does not detect and clean infiltrations

Make sure that no other antivirus programs are installed on your computer. If two real-time protection shields are
enabled at the same time, they may conflict with each other. We recommend that you uninstall any other antivirus
programs on your system before installing ESET.

Real-time protection does not start

If real-time protection is not initiated at system startup (and Enable Real-time file system protection is enabled), it
may be due to conflicts with other programs. For assistance resolving this issue, please contact ESET Customer Care.

http://www.eicar.org/download/eicar.com
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3.9.1.4   Computer scan

The on-demand scanner is an important part of ESET Endpoint Security. It is used to perform scans of files and
folders on your computer. From a security point of view, it is essential that computer scans are not just run when an
infection is suspected, but regularly as part of routine security measures. We recommend that you perform regular
(for example once a month) in-depth scans of your system to detect viruses not detected by  Real-time file system
protection. This can happen if Real-time file system protection was disabled at the time, if the detection engine was
obsolete or if the file was not detected as a virus when it was saved to the disk.

Two types of Computer scan are available. Smart scan quickly scans the system with no need for further
configuration of the scan parameters. Custom scan allows you to select any of the predefined scan profiles and
define specific scan targets.

See Scan progress for more information about the scanning process.

Scan your computer

Smart scan allows you to quickly launch a computer scan and clean infected files with no need for user intervention.
The advantage of Smart scan is that it is easy to operate and does not require detailed scanning configuration. Smart
scan checks all files on local drives and automatically cleans or deletes detected infiltrations. The cleaning level is
automatically set to the default value. For more detailed information on types of cleaning, see Cleaning.

Custom scan

Custom scan is an optimal solution if you want to specify scanning parameters such as scan targets and scanning
methods. The advantage of Custom scan is the ability to configure the parameters in detail. Configurations can be
saved to user-defined scan profiles, which can be useful if scanning is repeatedly performed using the same
parameters.

To select scan targets, select Computer scan > Custom scan and select an option from the Scan targets drop-down
menu, or select specific targets from the tree structure. A scan target can also be specified by entering the path of
the folder or file(s) you want to include. If you are only interested in scanning the system without additional
cleaning actions, select Scan without cleaning. When performing a scan, you can choose from three cleaning levels
by clicking Setup... > ThreatSense parameters > Cleaning.

Performing computer scans with Custom scan is suitable for advanced users with previous experience using
antivirus programs.

You can also use the Drag and drop scan feature to scan a file or folder manually by clicking the file or folder, moving
the mouse pointer to the marked area while keeping the mouse button pressed, and then releasing it. After that,
the application is moved to the foreground.

Removable media scan

Similar to Smart scan – quickly launch a scan of removable media (such as CD/DVD/USB) that are currently connected
to the computer. This may be useful when you connect a USB flash drive to a computer and want to scan its content
for malware and other potential threats.

This type of scan can be also initiated by clicking Custom scan and then selecting Removable media from the Scan
targets drop-down menu and clicking Scan.

You can use the Action after scan drop-down menu to choose the action (No action, Shut down and Reboot) to be
performed after scanning.

Enable shutdown after scan – Enables a scheduled shutdown when the on-demand computer scan finishes. A
shutdown confirmation dialog window will display a 60-second countdown. Click Cancel to deactivate the requested
shutdown.

Note
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We recommend that you run a computer scan at least once a month. Scanning can be configured as a
scheduled task from Tools > Scheduler.

3.9.1.4.1   Custom scan launcher

If only want to scan a specific target, you can use the Custom scan tool by clicking Computer scan > Custom scan and
selecting an option from the Scan targets drop-down menu or selecting specific targets from the folder (tree)
structure.

The scan targets window allows you to define which objects (memory, drives, sectors, files and folders) are scanned
for infiltrations. Select targets from the tree structure, which lists all devices available on the computer. The Scan
targets drop-down menu allows you to select predefined scan targets.

· By profile settings – Selects targets set in the selected scan profile.

· Removable media – Selects diskettes, USB storage devices, CD/DVD.

· Local drives – Selects all system hard drives.

· Network drives – Selects all mapped network drives.

· No selection – Cancels all selections.

To quickly navigate to a scan target or add a target folder or file(s), enter the target directory in the blank field
below the folder list. This is only possible if no targets were selected in the tree structure and the Scan targets
menu is set to No selection.

Infected items are not cleaned automatically. Scanning without cleaning can be used to obtain an overview of the
current protection status. Furthermore, you can choose from three cleaning levels by clicking Advanced setup >
Detection engine > On-demand scan > ThreatSense parameters > Cleaning. If you are only interested in scanning the
system without additional cleaning actions, select Scan without cleaning. Scan history is saved to the scan log.

When Ignore exclusions is selected, files with extensions that were previously excluded from scanning will be
scanned with no exception.

You can choose a profile from the Scan profile drop-down menu to be used for scanning chosen targets. The default
profile is Smart scan. There are two more pre-defined scan profiles called In-depth scan and Context menu scan.
These scan profiles use different ThreatSense parameters. The available options are described in Advanced setup >
Detection engine > Malware scans > On-demand scan > ThreatSense parameters.

Click Scan to execute the scan using the custom parameters that you have set.
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Scan as Administrator allows you to execute the scan under the Administrator account. Click this if the current user
doesn't have privileges to access the appropriate files to be scanned. Note that this button is not available if the
current user cannot call UAC operations as Administrator.

Note

You can view the computer scan log when a scan completes by clicking Show log.

3.9.1.4.2   Scan progress

The scan progress window shows the current status of the scan and information about the number of files found
that contain malicious code.

Note

It is normal that some files, such as password protected files or files exclusively being used by the
system (typically pagef ile.sys and certain log files), cannot be scanned.

Scan progress – The progress bar shows the status of already-scanned objects compared to objects still waiting be
scanned. The scan progress status is derived from the total number of objects included in scanning.
Target – The name of the currently scanned object and its location.
Threats found – Shows the total number of threats found during a scan.
Pause – Pauses a scan.
Resume – This option is visible when scan progress is paused. Click Resume to continue scanning.
Stop – Terminates the scan.
Scroll scan log – If enabled, the scan log will scroll down automatically as new entries are added so that the most
recent entries are visible.
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3.9.1.4.3   Computer scan log

The computer scan log gives you general information about the scan such as:

· Version of detection engine

· Date and time of scan

· Scanned disks, folders and files

· Number of scanned objects

· Number of threats found

· Time of completion

· Total scanning time

3.9.1.5   Device control

ESET Endpoint Security provides automatic device (CD/DVD/USB/...) control. This module allows you to block or
adjust extended filters/permissions and define a users ability to access and work with a given device. This may be
useful if the computer administrator wants to prevent the use of devices containing unsolicited content.

Supported external devices:

· Disk storage (HDD, USB removable disk)

· CD/DVD

· USB printer

· FireWire Storage

· Bluetooth Device

· Smart card reader

· Imaging Device

· Modem

· LPT/COM port

· Portable Device

· All device types
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Device control setup options can be modified in Advanced setup (F5) > Device control.

Turning the switch on next to Integrate into system activates the Device control feature in ESET Endpoint Security;
you will need to restart your computer for this change to take effect. Once Device control is enabled, the Rules will
become active, allowing you to open the Rules editor window.

If a device blocked by an existing rule is inserted, a notification window will be displayed and access to the device
will not be granted.

3.9.1.5.1   Device control rules editor

The Device control rules editor window displays existing rules and allows for precise control of external devices that
users connect to the computer.

Specific devices can be allowed or blocked according to their user, user group, or any of several additional
parameters that can be specified in the rule configuration. The list of rules contains several descriptions of a rule
such as name, type of external device, action to perform after connecting an external device to your computer and
log severity.

Click Add or Edit to manage a rule. Deselect the Enabled check box next to a rule to disable it until you want to use it
in the future. Select one or more rules and click Delete to delete the rule(s) permanently.

Copy – Creates a new rule with predefined options used for another selected rule.

Click Populate to auto-populate removable media device parameters for devices connected to your computer.

Rules are listed in order of priority with higher-priority rules closer to the top. Rules can be moved by clicking

 Top/Up/Down/Bottom and can be moved individually or in groups.

The Device control log records all occurrences where Device control is triggered. Log entries can be viewed from the
main program window of ESET Endpoint Security in Tools > Log files.
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3.9.1.5.2   Adding Device control rules

A Device control rule defines the action that will be taken when a device meeting the rule criteria is connected to
the computer.

Enter a description of the rule into the Name field for better identification. Click the switch next to Rule enabled to
disable or enable this rule; this can be useful if you don't want to delete the rule permanently.

Apply during – Allows you to apply created rule during the certain time. From the drop-down menu, select created
time slot. For more information click here.

Device type

Choose the external device type from the drop-down menu (Disk storage/Portable device/Bluetooth/FireWire/...).
Device type information is collected from the operating system and can be seen in the system Device manager if a
device is connected to the computer. Storage devices include external disks or conventional memory card readers
connected via USB or FireWire. Smart card readers include all readers of smart cards with an embedded integrated
circuit, such as SIM cards or authentication cards. Examples of imaging devices are scanners or cameras. Because
these devices only provide information about their actions and do not provide information about users, they can
only be blocked globally.

Note

The user list functionality is not available for the modem device type. The rule will be applied for all
users and the current user list will be deleted.

Action

Access to non-storage devices can either be allowed or blocked. In contrast, rules for storage devices allow you to
select one of the following rights settings:

· Read/Write – Full access to the device will be allowed.

· Block – Access to the device will be blocked.

· Read Only – Only read access to the device will be allowed.
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· Warn – Each time that a device is connected, the user will be notified if it is allowed/blocked, and a log entry
will be made. Devices are not remembered, a notification will still be displayed upon subsequent connections
of the same device.

Note that not all Actions (permissions) are available for all device types. If it is a device of storage type, all four
Actions are available. For non-storage devices, there are only three Actions available (for example Read Only is not
available for Bluetooth, therefore Bluetooth devices can only be allowed, blocked or warned).

Criteria type – Select Device group or Device.

Additional parameters shown below can be used to fine-tune rules and tailor them to devices. All parameters are
case-insensitive:

· Vendor – Filter by vendor name or ID.

· Model – The given name of the device.

· Serial – External devices usually have their own serial numbers. In the case of a CD/DVD, this is the serial
number of the given media, not the CD drive.

Note

If these parameters are undefined, the rule will ignore these fields while matching. Filtering
parameters in all text fields are case-insensitive and no wildcards (*, ?) are supported.

Note

To view information about a device, create a rule for that type of device, connect the device to your
computer and then check the device details in the Device control log.

Logging Severity

· Always – Logs all events.

· Diagnostic – Logs information needed to fine-tune the program.

· Information – Records informative messages, including successful update messages, plus all records above.

· Warning – Records critical errors and warning messages and sends them to ERA Server.

· None – No logs will be recorded.

Rules can be limited to certain users or user groups by adding them to the User list:

· Add – Opens the Object types: Users or Groups dialog window that allows you to select desired users.

· Remove – Removes the selected user from the filter.

Note

Not all devices can be filtered by user rules, (for example imaging devices do not provide
information about users, only about actions).
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3.9.1.6   Removable media

ESET Endpoint Security provides automatic removable media (CD/DVD/USB/...) scanning. This module allows you to
scan an inserted media. This may be useful if the computer administrator wishes to prevent the users from using
removable media with unsolicited content.

Action to take after inserting removable media – Select the default action that will be performed when a removable
media device is inserted into the computer (CD/DVD/USB). If Show scan options is selected, a notification will
display which allows you to choose a desired action:

· Do not scan – No action will be performed and the New device detected window will be closed.

· Automatic device scan – An on-demand computer scan of the inserted removable media device will be
performed.

· Show scan options – Opens the Removable media setup section.

When a removable media is inserted, following dialog will shown:

Scan now – This will trigger scan of removable media.

Scan later – Scan of removable media will be postponed.

Setup – Opens the Advanced setup.

Always use the selected option – When selected, same action will be performed when a removable media is
inserted another time.

In addition, ESET Endpoint Security features the Device control functionality, which allows you to define rules for
the use of external devices on a given computer. More details on Device control can be found in the Device control
section.

3.9.1.7   Idle-state scanning

You can enable the idle-state scanner in Advanced setup under Antivirus > Idle-state scanning > Basic. Set the switch
next to Enable Idle-state scanning to On to enable this feature. When the computer is in idle state, a silent
computer scan is performed on all local drives. See Idle state detection triggers  for a full list of conditions that must
be met in order to trigger the idle-state scanner.

By default, the idle-state scanner will not run when the computer (notebook) is operating on battery power. You
can override this setting by activating the switch next to Run even if computer is powered from battery in Advanced
setup.

Turn on the Enable logging switch in Advanced setup to record a computer scan output in the Log files section (from
the main program window click Tools > Log files and select Computer scan from the Log drop-down menu).

Idle-state detection will run when your computer is in the following states:

· Turn off screen or screen saver

· Computer lock

· User logoff

Click ThreatSense engine parameter setup to modify scan parameters (for example, detection methods) for the
Idle-state scanner.
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3.9.1.8   Host-based Intrusion Prevention System (HIPS)

Warning

Changes to HIPS settings should only be made by an experienced user. Incorrect configuration of
HIPS settings can lead to system instability.

The Host-based Intrusion Prevention System (HIPS) protects your system from malware and unwanted activity
attempting to negatively affect your computer. HIPS utilizes advanced behavioral analysis coupled with the
detection capabilities of network filtering to monitor running processes, files and registry keys. HIPS is separate
from Real-time file system protection and is not a firewall; it only monitors processes running within the operating
system.

HIPS settings can be found in Advanced setup (F5) > Antivirus > HIPS > Basic. The HIPS state (enabled/disabled) is
shown in the ESET Endpoint Security main program window, in the Setup > Computer.

ESET Endpoint Security uses the built-in Self-defense technology as a part of HIPS to prevent malicious software
from corrupting or disabling your antivirus and antispyware protection. Self-defense protects crucial system and
ESET's processes, registry keys and files from being tampered with.

Advanced memory scanner works in combination with Exploit Blocker to strengthen protection against malware that
has been designed to evade detection by antimalware products through the use of obfuscation or encryption.
Advanced memory scanner is enabled by default. Read more about this type of protection in the glossary.

Exploit Blocker is designed to fortify commonly exploited application types such as web browsers, PDF readers,
email clients and MS Office components. Exploit blocker is enabled by default. Read more about this type of
protection in the glossary.

Ransomware shield is another layer of protection that works as a part of HIPS feature. You must have the LiveGrid®
reputation system enabled for Ransomware shield to work. Read more about this type of protection here.

Filtering can be performed in one of four modes:
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Automatic mode – Operations are enabled with the exception of those blocked by pre-defined rules that protect
your system.

Smart mode – The user will only be notified about very suspicious events.

Interactive mode – User will be prompted to confirm operations.

Policy-based mode – Operations are blocked.

Learning mode – Operations are enabled and a rule is created after each operation. Rules created in this mode can
be viewed in the Rule editor, but their priority is lower than the priority of rules created manually or rules created
in the automatic mode. When you select Learning mode from the HIPS Filtering mode drop down menu, the
Learning mode will end at setting will become available. Select the duration that you want to engage learning
mode, the maximum duration is 14 days. When the specified duration has passed, you will be prompted to edit the
rules created by HIPS while it was in learning mode. You can also choose a different filtering mode, or postpone the
decision and continue using learning mode.

Mode set after learning mode expiration – Define which filtering mode the ESET Endpoint Security Firewall will
revert to after the time period for learning mode ends.

The HIPS system monitors events inside the operating system and reacts accordingly based on rules similar to the
rules used by the firewall. Click Edit to open the HIPS rule management window. Here you can select, create, edit or
delete rules.

In the following example, we will demonstrate how to restrict unwanted behaviors of applications:



60

1. Name the rule and select Block from the Action drop-down menu.
2. In the Operations affecting section, select at least one operation for  the rule. 
3. Select the Logging severity from the drop-down menu. Records with Warning verbosity can be collected by

Remote Administrator.
4. Select the slider bar next to Notify user to display a notification any time that a rule is applied. Click Next.

5. In the  Source applications window, select All applications from the drop-down menu to apply your new rule
to all applications attempting to perform any of the selected operations. Click Next.

6. In the following window, select the slider bar next to Modify state of another application and click Next (all
operations are described in product help, which can be accessed by pressing F1).

7. Select Specific applications from the drop-down menu and click Add to add one or more applications you
want to block.

8. Click Finish to save your new rule.

3.9.1.8.1   Advanced setup

The following options are useful for debugging and analyzing an application's behavior:

Drivers always allowed to load – Selected drivers are always allowed to load regardless of configured filtering
mode, unless explicitly blocked by user rule.

Log all blocked operations – All blocked operations will be written to the HIPS log.

Notify when changes occur in Startup applications – Displays a desktop notification each time an application is
added to or removed from system startup.

Please see the our Knowledgebase article for an updated version of this help page.

http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN2908
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3.9.1.8.2   HIPS interactive window

If the default action for a rule is set to Ask, a dialog window will be displayed each time that the rule is triggered.
You can choose to Deny or Allow the operation. If you do not choose an action in the given time, a new action is
selected based on the rules.

The dialog window allows you to create a rule based on any new action that HIPS detects and then define the
conditions under which to allow or deny that action. Settings for the exact parameters can be accessed by clicking
More info. Rules created like this are considered equal to rules created manually, so a rule created from a dialog
window can be less specific than the rule that triggered that dialog window. This means that after creating such a
rule, the same operation can trigger the same window.

Temporarily remember this action for this process causes the action (Allow/Deny) to be used until a change of rules
or filtering mode, a HIPS module update or a system restart. After any of these three actions, temporary rules will
be deleted.
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3.9.1.8.3   Potential ransomware behavior detected

This interactive window will appear when potential ransomware behavior is detected. You can choose to Deny or
Allow the operation.

The dialog window allows you submit the file for analysis or exclude from detection. Click Details to view specific
detection parameters.

Important

ESET Live Grid must be enabled for Ransomware protection to function properly.

3.9.1.9   Presentation mode

Presentation mode is a feature for users that demand uninterrupted usage of their software, do not want to be
disturbed by pop-up windows, and want to minimize CPU usage. Presentation mode can also be used during
presentations that cannot be interrupted by antivirus activity. When enabled, all pop-up windows are disabled and
scheduled tasks are not run. System protection still runs in the background, but does not require any user
interaction.

Click Setup > Computer and then click the switch next to Presentation mode to enable presentation mode manually.
In Advanced setup (F5), click Tools > Presentation mode, and then click the switch next to Enable Presentation mode
when running applications in full-screen mode automatically to have ESET Endpoint Security engage Presentation
mode automatically when full-screen applications are run. Enabling Presentation mode is a potential security risk,
so the protection status icon in the taskbar will turn orange and display a warning. You will also see this warning in
the main program window where you will see Presentation mode enabled in orange.

When Enable Presentation mode when running applications in full-screen automatically is engaged, Presentation
mode will start whenever you initiate a full-screen application and will automatically stop after you exit the
application. This is especially useful for starting Presentation mode immediately after starting a game, opening a
full screen application or starting a presentation.

You can also select Disable Presentation mode automatically after to define the amount of time in minutes after
which Presentation mode will automatically be disabled.
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Note

If the firewall is in Interactive mode and Presentation mode is enabled, you might have trouble
connecting to the Internet. This can be problematic if you start a game that connects to the Internet.
Normally, you would be asked to confirm such an action (if no communication rules or exceptions
have been defined), but user interaction is disabled in Presentation mode. The solution is to define
a communication rule for every application that might be in conflict with this behavior or to use a
different Filtering mode in the firewall. Keep in mind that if Presentation mode is enabled and you
go to a webpage or an application that might be a security risk, it may be blocked but you will not
see any explanation or warning because user interaction is disabled.

3.9.1.10   Startup scan

By default, the automatic startup file check will be performed on system startup and during modules updates. This
scan is dependent upon the Scheduler configuration and tasks.

Startup scan options are a part of the System startup file check scheduler task. To modify Startup scan settings,
navigate to Tools > Scheduler, click on Automatic startup file check and then click Edit. In the last step, the
Automatic startup file check window will appear (see the following chapter for more details).

For detailed instructions about Scheduler task creation and management, see Creating new tasks.

3.9.1.10.1   Automatic startup file check

When creating a System startup file check scheduled task, you have several options to adjust the following
parameters:

The Scan target drop-down menu specifies the scan depth for files run at system startup based on secret
sophisticated algorithm. Files are arranged in descending order according to the following criteria:

· All registered files (most files scanned)

· Rarely used files

· Commonly used files

· Frequently used files

· Only the most frequently used files (least files scanned)

Two specific groups are also included:

· Files run before user logon – Contains files from locations that may be accessed without the user being logged
in (includes almost all startup locations such as services, browser helper objects, winlogon notify, Windows
scheduler entries, known dll's, etc.).

· Files run after user logon - Contains files from locations that may only be accessed after a user has logged in
(includes files that are only run by a specific user, typically files in
HKEY_CURRENT_USER\SOFTWARE\Microsof t\Windows\CurrentVersion\Run).

Lists of files to be scanned are fixed for each aforementioned group.

Scan priority – The level of priority used to determine when a scan will start:

· When idle – the task will be performed only when the system is idle,

· Lowest – when the system load is the lowest possible,

· Lower – at a low system load,

· Normal – at an average system load.
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3.9.1.11   Document protection

The Document protection feature scans Microsoft Office documents before they are opened, as well as files
downloaded automatically by Internet Explorer such as Microsoft ActiveX elements. Document protection provides
a layer of protection in addition to Real-time file system protection, and can be disabled to enhance performance
on systems that are not exposed to a high volume of Microsoft Office documents.

Integrate into system activates the protection system. To modify this option, press F5 to open the Advanced setup
window and click Antivirus > Document protection in the Advanced setup tree.

This feature is activated by applications that use Microsoft Antivirus API (for example, Microsoft Office 2000 and
higher, or Microsoft Internet Explorer 5.0 and higher).

3.9.1.12   Exclusions

Exclusions enable you to exclude files and folders from scanning. To ensure that all objects are scanned for threats,
we recommend only creating exclusions when it is absolutely necessary. Situations where you may need to exclude
an object might include scanning large database entries that would slow your computer during a scan or software
that conflicts with the scan (for example, backup software).

To exclude an object from scanning:

1. Click Add,
2. Enter the path to an object or select it in the tree structure.

You can use wildcards to cover a group of files. A question mark (?) represents a single variable character whereas
an asterisk (*) represents a variable string of zero or more characters.

Examples

· If you wish to exclude all files in a folder, type the path to the folder and use the mask “*.*”. 

· To exclude an entire drive including all files and subfolders, use the mask "D:\*".

· If you want to exclude doc files only, use the mask “*.doc“. 

· If the name of an executable file has a certain number of characters (and characters vary) and you only know
the first one for sure (say “D”), use the following format: “D????.exe”. Question marks replace the missing
(unknown) characters.
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Note

A threat within a file will not be detected by the Real-time file system protection module or
Computer scan module if that file meets the criteria for exclusion from scanning.

Columns

Path – Path to excluded files and folders.

Threat – If the name of a threat is displayed next to an excluded file, it means that the file is only excluded for the
given threat. If that file becomes infected later with other malware, it will be detected by the antivirus module.
This type of exclusion can only be used for certain types of infiltrations, and can be created either in the threat
alert window reporting the infiltration (click Show advanced options and then select Exclude from detection), or
by clicking Tools > Quarantine, right-clicking the quarantined file and then selecting Restore and exclude from
detection from the context menu.

Control elements

Add – Excludes objects from detection.

Edit – Enables you to edit selected entries.

Remove – Removes selected entries.

3.9.1.13   ThreatSense parameters

ThreatSense is technology comprised of many complex threat detection methods. This technology is proactive,
which means it also provides protection during the early spread of a new threat. It uses a combination of code
analysis, code emulation, generic signatures and virus signatures which work in concert to significantly enhance
system security. The scanning engine is capable of controlling several data streams simultaneously, maximizing the
efficiency and detection rate. ThreatSense technology also successfully eliminates rootkits.

ThreatSense engine setup options allow you to specify several scan parameters:

· File types and extensions that are to be scanned,

· The combination of various detection methods,

· Levels of cleaning, etc.

To enter the setup window, click ThreatSense engine parameter setup in the Advanced setup window for any
module that uses ThreatSense technology (see below). Different security scenarios may require different
configurations. With this in mind, ThreatSense is individually configurable for the following protection modules:

· Real-time file system protection,

· Idle-state scanning,

· Startup scan,

· Document protection,

· Email client protection,

· Web access protection,

· Computer scan.

ThreatSense parameters are highly optimized for each module, and their modification can significantly influence
system operation. For example, changing parameters to always scan runtime packers, or enabling advanced
heuristics in the Real-time file system protection module could result in a system slow-down (normally, only newly-
created files are scanned using these methods). We recommend that you leave the default ThreatSense parameters
unchanged for all modules except Computer scan.

Objects to scan

This section allows you to define which computer components and files will be scanned for infiltrations.
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Operating memory – Scans for threats that attack the operating memory of the system.

Boot sectors/UEFI – Scans boot sectors and UEFI for the presence of rootkits, bootkits and other malware. For
more information click here.

Email files – The program supports the following extensions: DBX (Outlook Express) and EML.

Archives – The program supports the following extensions: ARJ, BZ2, CAB, CHM, DBX, GZIP, ISO/BIN/NRG, LHA,
MIME, NSIS, RAR, SIS, TAR, TNEF, UUE, WISE, ZIP, ACE, and many others.

Self-extracting archives – Self-extracting archives (SFX) are archives needing no specialized programs – archives –
to decompress themselves.

Runtime packers – After being executed, runtime packers (unlike standard archive types) decompress in memory.
In addition to standard static packers (UPX, yoda, ASPack, FSG, etc.), the scanner is able to recognize several
additional types of packers through the use of code emulation.

Scan options

Select the methods used when scanning the system for infiltrations. The following options are available:

Heuristics – A heuristic is an algorithm that analyzes the (malicious) activity of programs. The main advantage of
this technology is the ability to identify malicious software which did not exist, or was not known by the previous
version of detection engine. The disadvantage is a (very small) probability of false alarms.

Advanced heuristics/DNA signatures – Advanced heuristics consist of a unique heuristic algorithm developed by
ESET, optimized for detecting computer worms and trojan horses and written in high level programming
languages. The use of advanced heuristics greatly increases the threat detection capabilities of ESET products.
Signatures can reliably detect and identify viruses. Utilizing the automatic update system, new signatures are
available within a few hours of a threat discovery. The disadvantage of signatures is that they only detect viruses
they know (or slightly modified versions of these viruses).

Grayware (or PUA - a Potentially Unwanted Application) is a broad category of software, whose intent is not as
unequivocally malicious as with other types of malware, such as viruses or trojan horses. It may however install
additional unwanted software, change the behavior of the digital device, or perform activities not approved or
expected by the user.

Categories that may be considered grayware include: advertising display software, download wrappers, various
browser toolbars, software with misleading behavior, bundleware, trackware, registry cleaners or any other
borderline software, or software that uses illicit or at least unethical business practices (despite appearing
legitimate) and might be deemed undesirable by an end user who became aware of what the software would do if
allowed to install.

A Potentially Unsafe Application is one that is in itself legitimate (possibly commercial) software but which might
be misused by an attacker. Detection of these types of application can be enabled or disabled by users of ESET
software.

There are some situations where a user may feel that the benefits of a potentially unwanted application outweigh
the risks. For this reason, ESET assigns such applications a lower-risk category compared to other types of malicious
software, such as trojan horses or worms.

Warning - Potentially unwanted application found

When a potentially unwanted application is detected, you can decide which action to take:

1. Clean/Disconnect: This option ends the action and prevents the PUA from entering your system.
2. Ignore: This option allows a PUA to enter your system.
3. To allow the application to run on your computer in the future without interruption, click Advanced options

and then select the check box next to Exclude from detection and click Ignore.
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Potentially unwanted applications - Settings

While installing your ESET product, you can decide whether to enable detection of potentially unwanted
applications, as shown below:

Warning

Potentially unwanted applications may install adware, toolbars, or contain other unwanted and
unsafe program features.

These settings can be modified in your program settings at any time. To enable or disable the detection of
Potentially unwanted, unsafe or suspicious applications, follow these instructions:

1. Open your ESET product. How do I open my ESET product?
2. Press the F5 key to access Advanced setup.
3. Click Detection engine and enable or disable options Enable detection of potentially unwanted applications,

http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN3152
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Enable detection of potentially unsafe applications and Enable detection of suspicious applications according
to your preferences. Confirm by clicking OK.

Potentially unwanted applications - Software wrappers

A software wrapper is a special type of application modification that is used by some file-hosting websites. It is a
third-party tool that installs the program you intended to download but adds additional software, such as toolbars
or adware. The additional software may also make changes to your web browser’s home page and search settings.
Also, file-hosting websites often do not notify the software vendor or download recipient that modifications have
been made, and often hide options to opt out. For these reasons, ESET classifies software wrappers as a type of
potentially unwanted application to allow users to accept the download or not.

Potentially unwanted applications - Registry cleaners

Registry cleaners are programs that may suggest that the Windows registry database requires regular maintenance
or cleaning. Using a registry cleaner might introduce some risks to your computer system. Additionally, some
registry cleaners make unqualified, unverifiable or otherwise unsupportable claims about their benefits and/or
generate misleading reports about a computer system based on the results of a "free scan". These misleading claims
and reports seek to persuade you to purchase a full version or subscription, usually without allowing you to
evaluate the registry cleaner before payment. For these reasons, ESET classifies such programs as PUA and provides
you the option to allow or to block them.

Potentially unwanted content

If PUA detection is enabled in your ESET product, websites that have a reputation for promoting PUAs or that have a
reputation for misleading users into performing actions that might have negative implications on their system or
browsing experience will be blocked as potentially unwanted content. If you receive a notification that a website
you are attempting to visit is categorized as potentially unwanted content, you can click Go Back to navigate away
from the blocked web page or click Ignore and continue to allow the site to load.

Please see this ESET Knowledgebase article for an updated version of this help page.

Potentially unsafe applications – Potentially unsafe applications is the classification used for commercial,
legitimate programs such as remote access tools, password-cracking applications and keyloggers (programs that
record each keystroke typed by a user). This option is disabled by default.

http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN2629
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Cleaning

The cleaning settings determine the behavior of the scanner while cleaning infected files. There are 3 levels of
cleaning:

No cleaning – Infected files will not be cleaned automatically. The program will display a warning window and allow
the user to choose an action. This level is designed for more advanced users who know which steps to take in the
event of an infiltration.

Normal cleaning – The program will attempt to automatically clean or delete an infected file based on a predefined
action (depending on the type of infiltration). Detection and deletion of an infected file is signaled by a notification
the bottom-right corner of the screen. If it is not possible to select the correct action automatically, the program
provides other follow-up actions. The same happens when a predefined action cannot be completed.

Strict cleaning – The program will clean or delete all infected files. The only exceptions are the system files. If it is
not possible to clean them, the user is prompted to select an action by a warning window.

Warning

If an archive contains a file or files which are infected, there are two options for dealing with the
archive. In standard mode (Standard cleaning), the whole archive would be deleted if all the files it
contains are infected files. In Strict cleaning mode, the archive would be deleted if it contains at
least one infected file, regardless of the status of the other files in the archive.

Exclusions

An extension is the part of a file name delimited by a period. An extension defines the type and content of a file.
This section of the ThreatSense parameter setup lets you define the types of files to scan.

Other

When configuring ThreatSense engine parameters setup for a On-demand computer scan, the following options in
Other section are also available:

Scan alternate data streams (ADS) – Alternate data streams used by the NTFS file system are file and folder
associations which are invisible to ordinary scanning techniques. Many infiltrations try to avoid detection by
disguising themselves as alternate data streams.

Run background scans with low priority – Each scanning sequence consumes a certain amount of system resources.
If you work with programs that place a high load on system resources, you can activate low priority background
scanning and save resources for your applications.

Log all objects – If this option is selected, the log file will show all the scanned files, even those not infected. For
example, if an infiltration is found within an archive, the log will list also clean files contained within the archive.

Enable Smart optimization – With Smart Optimization enabled, the most optimal settings are used to ensure the
most efficient scanning level, while simultaneously maintaining the highest scanning speeds. The various
protection modules scan intelligently, making use of different scanning methods and applying them to specific
file types. If the Smart Optimization is disabled, only the user-defined settings in the ThreatSense core of the
particular modules are applied when performing a scan.

Preserve last access timestamp – Select this option to keep the original access time of scanned files instead of
updating them (for example, for use with data backup systems).

 Limits

The Limits section allows you to specify the maximum size of objects and levels of nested archives to be scanned:



70

Object settings

Maximum object size – Defines the maximum size of objects to be scanned. The given antivirus module will then
scan only objects smaller than the size specified. This option should only be changed by advanced users who may
have specific reasons for excluding larger objects from scanning. Default value: unlimited.

Maximum scan time for object (sec.) – Defines the maximum time value for scanning of an object. If a user-
defined value has been entered here, the antivirus module will stop scanning an object when that time has
elapsed, regardless of whether the scan has finished. Default value: unlimited.

Archive scan setup

Archive nesting level – Specifies the maximum depth of archive scanning. Default value: 10.

Maximum size of file in archive – This option allows you to specify the maximum file size for files contained in
archives (when they are extracted) that are to be scanned. Default value: unlimited.

Note

We do not recommend changing the default values; under normal circumstances, there should be
no reason to modify them.

3.9.1.13.1   Exclusions

An extension is the part of a file name delimited by a period. The extension defines the type of a file. Normally, all
files are scanned. However, if you need to exclude files with a specific extension, ThreatSense parameter setup lets
you exclude files from scanning based on their extension. Excluding may be useful if scanning certain file types
prevents an application from running properly.

Example 

To add a new extension to the list, click Add. Type the extension into the blank field (for example
tmp) and click OK. When you select Enter multiple values, you can add multiple file extensions
delimited by lines, commas or semicolons (for example, choose Semicolon from drop-down menu
as a separator, and type edb;eml;tmp).

You can use a special symbol ? (question mark). The question mark represents any symbol (for
example ?db)

Note

To display the extension (file type) for all files in a Windows operating system, deselect Hide
extensions for known file types under Control Panel > Folder Options > View.

3.9.2   Network

The firewall controls all network traffic to and from the system. This is accomplished by allowing or denying
individual network connections based on your filtering rules. It provides protection against attacks from remote
computers and blocks some potentially dangerous services. The firewall also provides IDS/IPS functionality by
inspecting the content of allowed network traffic and blocking traffic that is deemed potentially harmful. ESET
Endpoint Security will inform you when you connect to an unprotected wireless network or a network with weak
protection.

Firewall configuration can be found in the Setup pane under Network. Here you can adjust the filtering mode for

the ESET Firewall. To access more detailed settings, click the gear wheel  > Configure next to Firewall, or press F5
to access Advanced setup.
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Network attack protection (IDS) – Analyzes the content of network traffic and protects from network attacks. Any
traffic which is considered harmful will be blocked. You can disable Network attack protection for a specific period

of time by clicking .

Botnet protection – Quickly and accurately identifies malware in the system. To disable Botnet protection for a

specific period of time, click .

Connected networks – Displays the networks to which network adapters are connected. After clicking the gear
wheel, you will be prompted to select a protection type for the network you are connected to via your network
adapter. In this window you can also see Network adapters in lower right corner. You can view each network
adapter and its assigned firewall profile and trusted zone. For more detailed information, see Network adapters.

Temporary IP address blacklist – View a list of IP addresses that have been detected as the source of attacks and
added to the blacklist to block connections for a certain period of time. For more information, click this option and
press F1. 

Troubleshooting wizard – Helps you solve connectivity problems caused by ESET Firewall. For more detailed
information see Troubleshooting wizard.

Click the gear wheel  next to Firewall to access the following settings:

Configure... – Opens the firewall window in Advanced setup, where you can define how the firewall will handle
network communication.

Block all traffic – All inbound and outbound communication will be blocked by the firewall. Only use this option if
you suspect a critical security risk that requires the system to be disconnected from the network. To restore the
firewall to normal operation while Network traffic filtering is in the Block all traffic mode, click Stop blocking all
traffic.

Pause firewall (allow all traffic) – The opposite of blocking all network traffic. If selected, all firewall filtering
options are turned off and all incoming and outgoing connections are permitted. To re-enable the firewall while
Network traffic filtering is in this mode, click Enable firewall.
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Automatic mode – (when another filtering mode is enabled) – Click to change the filtering mode to automatic
filtering mode (with user-defined rules).

Interactive mode – (when another filtering mode is enabled) – Click to change the filtering mode to interactive
filtering mode.

3.9.2.1   Firewall

The firewall controls all network traffic to and from the system. This is accomplished by allowing or denying
individual network connections based on specified filtering rules. It provides protection against attacks from
remote computers and enables blocking of some services. It also provides antivirus protection for HTTP, POP3 and
IMAP protocols. This functionality represents a very important element of computer security.

 Basic

Enable Firewall – We recommend that you leave this feature enabled to ensure the security of your system. With
the firewall engaged, network traffic is scanned in both directions.

Also evaluate rules from Windows firewall – In automatic mode, allow also incoming traffic allowed by rules from
Windows Firewall, unless explicitly blocked by ESET rules.

Four filtering modes are available for the ESET Endpoint Security Firewall. Filtering mode settings can be found in
Advanced setup (F5) by clicking Network protection > Firewall > Basic. The behavior of the firewall changes based on
the filtering mode. Filtering modes also influence the level of user interaction required.

Filtering can be performed in one of four modes:

Automatic mode – The default mode. This mode is suitable for users who prefer easy and convenient use of the
firewall with no need to define rules. Custom, user-defined rules can be created, but are not required in Automatic
mode. Automatic mode allows all outbound traffic for the given system and blocks most inbound traffic (except
some traffic from the Trusted Zone, as allowed in IDS and advanced option/Allowed services and inbound traffic
responding to recent outbound communication to the same remote site).

Interactive mode – Allows you to build a custom configuration for your firewall. When a communication is detected
and no existing rules apply to that communication, a dialog window reporting an unknown connection will be
displayed. The dialog window gives the option to allow or deny the communication, and the decision to allow or
deny can be saved as a new rule for the firewall. If you choose to create a new rule, all future connections of this
type will be allowed or blocked according to that rule.

Policy-based mode – Blocks all connections that are not defined by a specific rule that allows them. This mode
allows advanced users to define rules that permit only desired and secure connections. All other unspecified
connections will be blocked by the firewall.

Learning mode – Automatically creates and saves rules; this mode is suitable for initial configuration of the firewall.
No user interaction is required, because ESET Endpoint Security saves rules according to predefined parameters.
Learning mode is not secure, and should only be used until all rules for required communications have been
created.

 Advanced

Rules – Here you can add rules and define how the firewall handles network traffic.

Zones – Here you can create zones that consist of several IP addresses.

Profiles can be used to customize the behavior of the ESET Endpoint Security Firewall by specifying different sets of
rules in different situations.
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3.9.2.1.1   Learning mode

Learning mode automatically creates and saves a rule for each communication that has been established in the
system. No user interaction is required, because ESET Endpoint Security saves rules according to the predefined
parameters.

This mode can expose your system to risk, and is only recommended for initial configuration of the firewall.

Activate Learning mode in Advanced setup (F5) > Firewall > Learning mode settings to display Learning mode
options. This section includes the following items:

Warning

While in Learning mode, the firewall does not filter communication. All outgoing and incoming
communications are allowed. In this mode, your computer is not fully protected by the firewall.
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Mode set after learning mode expiration – Define which filtering mode the ESET Endpoint Security Firewall will
revert to after the time period for learning mode ends. Read more about filtering modes.

Communication type – Select specific rule creation parameters for each type of communication. There are four
types of communication:

 Inbound traffic from the Trusted zone – An example of an incoming connection within the trusted zone would be
a remote computer from within the trusted zone attempting to establish communication with a local application
running on your computer.

 Outbound traffic to the Trusted zone – A local application attempting to establish a connection to another
computer within the local network, or within a network in the trusted zone.

 Inbound Internet traffic – A remote computer attempting to communicate with an application running on the
computer.

 Outbound Internet traffic – A local application attempting to establish a connection to another computer.

Each section allows you to define parameters to be added to newly created rules:

Add local port – Includes the local port number of the network communication. For outgoing communications,
random numbers are usually generated. For this reason, we recommend enabling this option only for incoming
communications.

Add application – Includes the name of the local application. This option is suitable for future application-level rules
(rules that define communication for an entire application). For example, you can enable communication only for a
web browser or email client.

Add remote port – Includes the remote port number of the network communication. For example you can allow or
deny a specific service associated with a standard port number (HTTP – 80, POP3 – 110, etc.).

Add remote IP address/Trusted zone – A remote IP address or zone can be used as a parameter for new rules
defining all network connections between the local system and that remote address / zone. This option is suitable if
you want to define actions for a certain computer or a group of networked computers.

Maximum number of different rules for an application – If an application communicates through different ports to
various IP addresses, etc., the firewall in learning mode creates appropriate count of rules for this application. This
option allows you to limit the number of rules that can be created for one application.

3.9.2.2   Network attack protection

Enable Network attack protection (IDS) – Analyses the content of network traffic and protects from network

attacks. Any traffic which is considered harmful will be blocked.

Enable Botnet protection – Detects and blocks communication with malicious command and control servers based
on typical patterns when the computer is infected and a bot is attempting to communicate.

IDS exceptions – This option allows you to configure advanced filtering options to detect several types of attacks
and exploits that might be used to harm your computer.

3.9.2.3   Known networks

When using a computer that frequently connects to public networks or networks outside of your normal work
network, we recommend that you verify the network credibility of new networks that you are connecting to. Once
networks are defined, ESET Endpoint Security can recognize trusted (Home/work) networks using various network
parameters configured in Network Identification. Computers often enter networks with IP addresses that are
similar to the trusted network. In such cases, ESET Endpoint Security may consider an unknown network to be
trusted (Home/work). We recommend that you use Network authentication to avoid this type of situation.

When a network adapter is connected to a network or its network settings are reconfigured, ESET Endpoint Security
will search the known network list for a record that matches the new network. If Network identification and
Network authentication (optional) match, the network will be marked connected in this interface. When no known
network is found, network identification configuration will create a new network connection to identify the
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network the next time that you connect to it. By default, the new network connection uses the Public network
protection type. The New Network Connection Detected dialog window will prompt you to choose between the
Public network, Home or office network or Use Windows setting protection type. If a network adapter is connected
to a known network and that network is marked as Home or office network, local subnets of the adapter will be
added to the Trusted zone.

Protection type of new networks – Select which of the following options: Use Windows setting, Ask user or Mark as
public is used by default for new networks.

Note

When you select Use Windows setting a dialog will not appear and the network you are connected
to will automatically be marked according to your Windows settings. This will cause certain features
(for example file sharing and remote desktop) to become accessible from new networks.

Known networks can be configured manually in the Known networks editor window.

3.9.2.3.1   Known networks editor

Known networks can be configured manually in Advanced setup > Firewall > Known Networks by clicking Edit.

Columns

Name – Name of known network.

Protection type – Shows if the network is set to Public network, Home/work network or Use Windows setting.

Firewall profile – Select a profile from the Display rules used in the profile drop-down menu to display the
profiles rules filter.

Update profile – Allows you to apply created update profile when connected to this network.

Control elements

Add – Creates a new known network.

Edit – Click to edit an existing known network.

Remove – Select a network and click Remove to remove it from the list of known networks.

 Top/Up/Down/Bottom – Allows you to adjust the priority level of known networks (networks
are evaluated from top to bottom).

Network configuration settings are broken down into the following tabs:

Network

Here you can define the Network name and select the Protection type (Public network, Home or office network or
Use Windows setting) for the network. Use the Firewall profile drop-down menu to select the profile for this
network. If the network uses the Home or office network protection type, all directly connected network subnets
are considered trusted. For example, if a network adapter is connected to this network with the IP address
192.168.1.5 and the subnet mask 255.255.255.0, the subnet 192.168.1.0/24 is added to that adapter's trusted zone. If
the adapter has more addresses/subnets, all of them will be trusted, regardless of the Network Identification
configuration of the known network.

Additionally, addresses added under Additional trusted addresses are always added to the trusted zone of adapters
connected to this network (regardless of the network's protection type).

The following conditions must be met for a network to be marked as connected in the list of connected networks:

· Network identification – All filled in parameters must match active connection parameters.

· Network authentication – if authentication server is selected, successful authentication with the ESET
Authentication Server must take place.
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· Network restrictions (Windows XP only) – all selected global restrictions must be fulfilled.

Network identification

Network identification is performed based on the local network adapter's parameters. All selected parameters are
compared against the actual parameters of active network connections. IPv4 and IPv6 addresses are allowed.

Network authentication

Network authentication searches for a specific server in the network and uses asymmetric encryption (RSA) to
authenticate that server. The name of the network being authenticated must match the zone name set in
authentication server settings. The name is case sensitive. Specify a server name, server listening port and a public
key that corresponds to the private server key (see Network authentication – Server configuration). The server
name can be entered in the form of an IP address, DNS or NetBios name and can be followed by a path specifying
the location of the key on the server (for example, server_name_/directory1/directory2/authentication). You can
specify alternate servers to use by appending them to the path, separated by semicolons.

Download the ESET Authentication Server.

The public key can be imported using any of the following file types:

· PEM encrypted public key (.pem), this key can be generated using the ESET Authentication Server (see
Network authentication – Server configuration).

· Encrypted public key

· Public key certificate (.crt)

http://download.eset.com/download/eas/authserver_enu.msi
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Click Test to test your settings. If authentication is successful, Server authentication was successf ul will be displayed.
If authentication is not configured properly, one of the following error messages will be displayed:

Server authentication f ailed. Invalid or mismatched signature.
Server signature does not match the public key entered.

Server authentication f ailed. Network name doesn't match.
The configured network name does not correspond with the authentication server zone name. Review both names
and ensure they are identical.

Server authentication f ailed. Invalid or no response f rom server.
No response is received if the server is not running or is inaccessible. An invalid response may be received if
another HTTP server runs on the specified address.

Invalid public key entered.
Verify that the public key file you have entered is not corrupted.

Network restrictions (for Windows XP only)

On modern operating systems (Windows Vista and newer), each network adapter has its own trusted zone and
active firewall profile. Unfortunately on Windows XP this layout is not supported, so all network adapters always
share the same trusted zone and active firewall profile. That imposes a potential security risk when the machine is
connected to multiple networks simultaneously. In such cases, traffic from an untrusted network may be evaluated
using the trusted zone and firewall profile configured for the other connected network. To mitigate any security
risk, you can use the following restrictions to avoid globally applying one network configuration while another
(potentially untrusted) network is connected.

On Windows XP, connected networks settings (trusted zone and firewall profile) are applied globally unless at least
one of these restrictions is enabled and not fulfilled:

a. Only one connection is active
b. No wireless connection is established
c. No unsecured wireless connection is established
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3.9.2.3.2   Network authentication - Server configuration

The authentication process can be executed by any computer/server connected to the network that is to be
authenticated. The ESET Authentication Server application needs to be installed on a computer/server that is always
accessible for authentication whenever a client attempts to connect to the network. The installation file for the
ESET Authentication Server application is available for download on ESET’s website.

After you install the ESET Authentication Server application, a dialog window will appear (you can access the
application by clicking Start > Programs > ESET > ESET Authentication Server).

To configure the authentication server, enter the authentication network name, the server listening port (default is
80) as well as the location to store the public and private key pair. Next, generate the public and private key that will
be used in the authentication process. The private key will remain on the server while the public key needs to be
imported on the client side in the Network authentication section when setting up a network in the firewall setup.

3.9.2.4   Firewall profiles

Global default profile – If there is no profile from network nor from network adapter configuration, the global
default profile is used.

List of profiles – Profiles can be used to control the behavior of the ESET Endpoint Security Firewall. When creating
or editing a firewall rule, you can assign it to a specific profile, or have it apply to every profile. When a profile is
active on a network interface, only the global rules (rules with no profile specified) and the rules that have been
assigned to that profile are applied to it. You can create multiple profiles with different rules assigned to network
adapters or assigned to networks to easily alter firewall behavior.

Profiles assigned to network adapters – A network adapter can be set up to use a profile configured for a specific
network when it is connected to that network.

You can also assign a specific profile to use when on a given network in Advanced setup (F5) > Firewall > Known
networks. Select a network from the list of Known networks and click Edit to assign a firewall profile to the specific
network from the Firewall profile drop-down menu. If that network has no assigned profile, then the adapter's
default profile will be used. If the adapter is set up not to use the network's profile, its default profile will be used
regardless of which network it is connected to. If there is no profile for a network or for adapter configuration, the
global default profile is used. To assign a profile to a network adapter, select the network adapter, click Edit next to
Profiles assigned to network adapters, select the profile from Default firewall profile drop-down menu and then
click OK.

When the firewall switches to another profile, a notification will appear in the lower right corner by the system
clock.

3.9.2.4.1   Profiles assigned to network adapters

By switching profiles you can quickly make multiple changes to firewall behavior. Custom rules can be set and
applied for particular profiles. Network adapter entries for all adapters present on the machine are added to the list
of Network adapters automatically.

Columns

Name – Name of the network adapter.

Default firewall profile – The default profile is used when the network you are connected to has no configured
profile, or your network adapter is set not to use a network profile.

Prefer network's profile – Network adapter can use firewall profile configured for the connected known network.
If that network has no configured profile, or network adapter is set up not to use the network's profile, then
adapter's default profile is used.

Control elements

Add – Adds a new network adapter.
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Edit – Allows you to edit an existing network adapter.

Delete – Select a network adapter and click Delete if you want to remove a network adapter from the list.

OK/Cancel – Click OK if you want to save changes or click Cancel to leave without any changes.

3.9.2.5   Configuring and using rules

Rules represent a set of conditions used to test all network connections and all actions assigned to these conditions.
Using a firewall rules, you can define the action that is taken when different types of network connections are
established. To access rule filtering setup, navigate to Advanced setup (F5) > Firewall > Basic. Some of predefined
rules are bound to the check boxes from allowed services (IDS and advanced options) and they can not be turned off
directly, instead you can use those related check boxes to do it.

Unlike the previous version of ESET Endpoint Security, rules are evaluated from top to bottom. The action of the first
matching rule is used for each network connection being evaluated. This is an important behavioral change from the
previous version, in which the priority of rules was automatic and more specific rules had higher priority then more
general ones.

Connections can be divided into incoming and outgoing connections. Incoming connections are initiated by a
remote computer attempting to establish a connection with the local system. Outgoing connections work  the
opposite way – the local system contacts a remote computer.

If a new unknown communication is detected, consider carefully whether to allow or deny it. Unsolicited,
unsecured or unknown connections pose a security risk to the system. If such a connection is established, we
recommend that you pay particular attention to the remote computer and the application attempting to connect to
your computer. Many infiltrations try to obtain and send private data, or download other malicious applications to
host workstations. The firewall allows you to detect and terminate such connections.

3.9.2.5.1   Firewall rules

Click Edit next to Rules in the Advanced tab section to display the Firewall rules window, where the list of all rules is
displayed. Add, Edit, and Remove allow you to add, configure or delete rules. You can adjust the priority level of a

rule by selecting a rule(s) and clicking  Top/Up/Down/Bottom.

Note

Click the icon to search for rule(s) by name, protocol or port.
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Columns

Name – Name of rule.

Enabled – Shows if rule is enabled or disabled; the corresponding check box must be selected to activate a rule.

Protocol – The protocol this rule is valid for.

Profile – Shows the firewall profile this rule is valid for.

Action – Shows the status of communication (block/allow/ask).

Direction – Direction of communication (incoming/outgoing/both).

Local – IP address and port of local computer.

Remote – IP address and port of remote computer.

Applications – The application to which the rule applies.

Control elements

Add – Creates a new rule.

Edit –  Edit an existing rule.

Remove – Remove an existing rule.

Copy - Create a copy of a selected rule.

Show built in (predefined) rules – Rules predefined by ESET Endpoint Security which allow or deny specific
communications. You can disable these rules, but you cannot delete a predefined rule.

 Top/Up/Down/Bottom – Allows you to adjust the priority level of rules (rules are executed
from top to bottom).

3.9.2.5.2   Working with rules

Modification is required each time that monitored parameters are changed. If changes are made such that a rule
cannot fulfill the conditions and the specified action cannot be applied, the given connection may be refused. This
can lead to problems with the operation of the application affected by a rule. An example is a change of network
address or port number for the remote side.

The upper part of the window contains three tabs:

· General – Specify a rule name, the direction of the connection, the action (Allow, Deny, Ask), the protocol and
the profile to which the rule will apply.

· Local – Displays information about the local side of the connection, including the number of the local port or
port range and the name of the communicating application. Also allows you to add a predefined or created
zone with a range of IP addresses here by clicking Add.

· Remote – This tab contains information about the remote port (port range). It allows you to define a list of
remote IP addresses or zones for a given rule. You can also add a predefined or created zone with range of IP
addresses here by clicking Add.

When creating a new rule, you must enter a name for the rule in the Name field. Select the direction to which the
rule applies from the Direction drop-down menu and the action to be executed when a communication meets the
rule from the Action drop-down menu.

Protocol represents the transfer protocol used for the rule. Select which protocol to use for a given rule from the
drop-down menu.

ICMP Type/Code represents an ICMP message identified by a number (for example; 0 represents "Echo Reply").

All rules are enabled for Any profile by default. Alternatively, select a custom firewall profile using the Profiles
drop-down menu.
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If you enable Log, the activity connected with the rule will be recorded in a log. Notify user displays a notification
when the rule is applied.

Note

Logs with Warning status can be collected by ESET Remote Administrator.

Below is an example in which we create a new rule to allow the web browser application to access the network. In
this example, the following must be configured:

· In the General tab, enable outgoing communication via the TCP and UDP protocol.

· Add your browser application (for Internet Explorer it is iexplore.exe) in the Local tab.

· In the Remote tab, enable port number 80 if you want to allow standard Internet browsing.

Note

Please be aware that predefined rules can be modified in limited way.

3.9.2.6   Trusted zone

The trusted zone represents a group of network addresses from which the firewall allows some inbound traffic
using default settings. Settings for features like file sharing and remote desktop inside of the trusted zone are
determined in IDS and advanced options.

The actual trusted zone is computed dynamically and separately for each network adapter based on what network
the computer is currently connected to. Addresses defined as inside of the trusted zone in the Zones editor are
always trusted. If a network adapter is connected to a known network, then the Additional trusted addresses
configured for that network are added to the adapter's trusted zone. If a network has the Home/work protection
type, all directly connected subnets are included in the trusted zone. The actual trusted zone for each network
adapter can be viewed from the Setup window under Network > Network adapters.

Note

Per-interface trusted zone is not supported on Windows XP operating systems. For these operating
systems, all adapters have the same trusted zone, and this is also visible in the Network adapters
page.

3.9.2.7   Configuring zones

Zones are groups of IP addresses, useful when you need to reuse the same set of addresses in multiple rules. These
zones can be configured in Advanced setup > Firewall > Basic, when click Edit button next to Zones. For adding a new
zone click Add enter a Name for the zone, a Description, and add a remote IP address into the Remote computer
address (IPv4/IPv6, range, mask) field.

In the  Firewall zones setup window, you can specify a zone name, description, network address list (see also
Known networks editor).
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3.9.2.8   Logging

The ESET Endpoint Security Firewall saves all important events in a log file, which can be viewed directly from the
main menu. Click Tools > Log files and then select Firewall from the Log drop-down menu. To enable firewall
logging, navigate to Advanced setup > Tools > Log files  and set the minimum logging verbosity to Diagnosic. All
denied connections will be recorded.

Log files can be used to detect errors and reveal intrusions on your system. The ESET Firewall logs contain the
following data:

· Time – Date and time of event.

· Event – Name of event.

· Source – Source network address.

· Target – Target network address.

· Protocol – Network communication protocol.

· Rule/worm name – Rule applied, or name of worm, if identified.

· Application – Application involved.

· User –  Name of the user logged in at the time the infiltration was detected.

A thorough analysis of this data can help detect attempts to compromise system security. Many other factors
indicate potential security risks and allow you to minimize their impact. Some examples of potential threat
indicators include frequent connections from unknown locations, multiple attempts to establish connections and
unknown applications communicating or unusual port numbers being used.

3.9.2.9   Establishing connection - detection

The firewall detects each newly-created network connection. The active firewall mode determines which actions
are performed for the new connection. If Automatic mode or Policy-based mode is activated, the firewall will
perform predefined actions with no user interaction.

Interactive mode displays an informational window that reports detection of a new network connection,
supplemented with detailed information about the connection. You can opt to allow the connection or refuse
(block) it. If you repeatedly allow the same connection in the dialog window, we recommend that you create a new
rule for the connection. To do this, select Remember action (create rule) and save the action as a new rule for the
firewall. If the firewall recognizes the same connection in the future, it will apply the existing rule without requiring
user interaction.

Temporarily remember action for the process causes an action (Allow/Deny) to be used until application restart, a
change of rules or filtering modes, a Firewall module update or a system restart. After any of these actions,
temporary rules will be deleted.
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Please be careful when creating new rules and only allow connections that you know are secure. If all connections
are allowed, then the firewall fails to accomplish its purpose. These are the important parameters for connections:

· Remote side – Only allow connections to trusted and known addresses.

· Local application – It is not advisable to allow connections for unknown applications and processes.

· Port number – Communication on common ports (for example, web traffic – port number 80) should be
allowed under normal circumstances.

In order to proliferate, computer infiltrations often use the Internet and hidden connections to help them infect
remote systems. If rules are configured correctly, a firewall becomes a useful tool for protection against a variety of
malicious code attacks.

3.9.2.10   Solving problems with ESET Firewall

If you experience connectivity problems with ESET Endpoint Security installed, there are several ways to tell if the
ESET Firewall is causing the issue. Moreover, ESET Firewall can help you create new rules or exceptions to resolve
connectivity problems.

See the following topics for help resolving problems with the ESET Firewall:

· Troubleshooting wizard

· Logging and creating rules or exceptions from log

· Creating exceptions from firewall notifications

· Advanced PCAP logging

· Solving problems with protocol filtering
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3.9.2.10.1   Troubleshooting wizard

The troubleshooting wizard silently monitors all blocked connections, and will guide you through the
troubleshooting process to correct firewall issues with specific applications or devices. Next, the wizard will suggest
a new set of rules to be applied if you approve them. Troubleshooting wizard can be found in the main menu under
Setup > Network.

3.9.2.10.2   Logging and creating rules or exceptions from log

By default, the ESET Firewall does not log all blocked connections. If you want to see what was blocked by the
firewall, enable Network protection advanced logging in the Diagnostics section of Advanced setup under Tools >
Diagnostics. If you see something in the log that you do not want the firewall to block, you can create a rule or an IDS
exception for it by right-clicking on that item and selecting Don't block similar events in the future. Please note that
the log of all blocked connections can contain thousands of items and it might be difficult to find a specific
connection in this log. You can turn logging off after you have resolved your issue.

For more information about the log see Log files.

Note

Use logging to see the order in which the firewall blocked specific connections. Moreover, creating
rules from the log allows you to create rules that do exactly what you want.

3.9.2.10.2.1   Create rule from log

The new version of ESET Endpoint Security allows you to create a rule from the log. From the main menu click Tools
> Log files. Choose Firewall from drop-down menu, right-click your desired log entry and select Don't block similar
events in the future from the context menu. A notification window will display your new rule.

To allow for the creation of new rules from the log, ESET Endpoint Security must be configured with the following
settings:

· set the minimum logging verbosity to Diagnostic in Advanced setup (F5) > Tools > Log files,

· enable Display notifications also for incoming attacks against security holes in Advanced setup (F5) > Network
protection > Network attack protection > Advanced options > Intrusion detection.

3.9.2.10.3   Creating exceptions from firewall notifications

When ESET Firewall detects malicious network activity, a notification window describing the event will be
displayed. This notification contains a link that will allow you to learn more about the event and set up an exception
for this event if you want.

Note

If a network application or device does not implement network standards correctly it can trigger
repetitive firewall IDS notifications. You can create an exception directly from the notification to
keep the ESET Firewall from detecting this application or device.
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3.9.2.10.4   Advanced PCAP logging

This feature is intended to provide more complex log files for ESET customer support. Use this feature only when
requested to by ESET customer support, as it might generate a huge log file and slow down your computer.

1. Navigate to Advanced setup > Tools > Diagnostics and enable Enable Protocol filtering advanced logging.

2. Attempt to reproduce the problem you are experiencing.

3. Disable advanced PCAP logging.

4. The PCAP log file can be found in the same directory where diagnostic memory dumps are generated:

· Microsoft Windows Vista or newer

C:\ProgramData\ESET\ESET Endpoint Security\Diagnostics\

· Microsoft Windows XP

C:\Documents and Settings\All Users\...

3.9.2.10.5   Solving problems with protocol filtering

If you experience problems with your browser or email client, the first step is to determine if protocol filtering is
responsible. To do that, try temporarily disabling application protocol filtering in the advanced setup (remember to
turn it back on after you're finished, otherwise your browser and email client will remain unprotected). If your
problem disappears after turning it off, here is a list of common problems and a way to solve them:

Update or secure communication problems

If your application complains about the inability to update or that a communication channel is not secure:

· If you have SSL protocol filtering enabled, try temporarily turning it off. If that helps, you can keep using SSL
filtering and make the update work by excluding the problematic communication:
Switch SSL protocol filtering mode to interactive. Rerun the update. There should be a dialog informing you about
encrypted network traffic. Make sure the application matches the one you're troubleshooting and the certificate
looks like coming from the server it is updating from. Then choose to remember action for this certificate and click
ignore. If no more relevant dialogs are show, you can switch the filtering mode back to automatic and the problem
should be solved.

· If the application in question is not a browser or email client, you can completely exclude it from protocol filtering
(doing this for browser or email client would leave you exposed). Any application that had its communication
filtered in the past should already be in the list provided to you when adding exception, so manually adding one
shouldn't be necessary.

Problem accessing a device on your network

If you are unable to use any functionality of a device on your network (this could mean opening a webpage of your
webcam or playing video on a home media player), try adding its IPv4 and IPv6 addresses to the list of excluded
addresses.

Problems with a particular website

You can exclude specific websites from protocol filtering using URL address management. For example if you can't
access https://www.gmail.com/intl/en/mail/help/about.html, try adding *gmail.com* to the list of excluded
addresses.

Error "Some of the applications capable of importing the root certificate are still running“

When you enable SSL protocol filtering, ESET Endpoint Security makes sure that installed applications trust the way
it filters SSL protocol by importing a certificate to their certificate store. For some applications this is not possible
while they are running. This includes Firefox and Opera. Make sure none of them are running (the best way to do
this is to open Task Manager and make sure there is no firefox.exe or opera.exe under Processes tab), then hit retry.

https://www.gmail.com/intl/en/mail/help/about.html
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Error about untrusted issuer or invalid signature

This most likely means that the import described above failed. First make sure that none of the mentioned
applications are running. Then disable SSL protocol filtering and enable it back on. This reruns the import.

3.9.3   Web and email

Web and email configuration can be found under Setup > Web and email. From here you can access more detailed
program settings.

The Web control module allows you to configure settings that provide administrators with automated tools to help
protect their workstations and set restrictions for internet browsing. The aim of the Web control functionality is to
prevent access to pages with inappropriate or harmful content. See Web control for more information.

Internet connectivity is a standard feature for personal computers. Unfortunately, it has also become the main
medium for transferring malicious code. Because of this, it is essential that you carefully consider your Web access
protection.

Email client protection provides control of email communications received through the POP3 and IMAP protocols.
Using the plug-in program for your email client, ESET Endpoint Security provides control of all communications from
the email client (POP3, IMAP, HTTP, MAPI).

Antispam protection filters unsolicited email messages.

When you click the gear wheel  next to Antispam protection the following options are available:

Configure... – Opens advanced settings for Email client antispam protection.

User's Whitelist/Blacklist/Exceptions list – Opens a dialog window where you can add, edit or delete email
addresses that are considered safe or unsafe. According to rules defined here, email from these addresses will
not be scanned or will be treated as spam. Click Useŕ s Exceptions list to open a dialog where you can add, edit
or delete email addresses that may be spoofed and used for sending spam. Email messages received from
addresses listed in the Exception list will always be scanned for spam.
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Anti-Phishing protection is another layer of protection that provides increased defense from illegitimate websites
that attempt to acquire passwords and other sensitive information. Anti-Phishing protection can be found in the
Setup pane under Web and email. See Anti-Phishing protection for more information.

Disable – Click the switch to disengage web/email/antispam protection for web browsers and email clients .

3.9.3.1   Protocol filtering

Antivirus protection for application protocols is provided by the ThreatSense scanning engine, which seamlessly
integrates all advanced malware scanning techniques. Protocol filtering works automatically, regardless of the
Internet browser or email client used. To edit encrypted (SSL) settings, go to Web and email > SSL.

Enable application protocol content filtering – Can be used to disable protocol filtering. Note that many ESET
Endpoint Security components (Web access protection, Email protocols protection, Anti-Phishing, Web control)
depend on this and will be non-functional without it.

Excluded applications – Allows you to exclude specific applications from protocol filtering. Useful when protocol
filtering causes compatibility issues.

Excluded IP addresses – Allows you to exclude specific remote addresses from protocol filtering. Useful when
protocol filtering causes compatibility issues.

Web and email clients – Used only on Windows XP operating systems, allows you to select applications for which all
traffic is filtered by protocol filtering, regardless of ports used.

3.9.3.1.1   Web and email clients

Note

Starting with Windows Vista Service Pack 1 and Windows Server 2008, the new Windows Filtering
Platform (WFP) architecture is used to check network communication. Since WFP technology uses
special monitoring techniques, the Web and email clients section is not available.

Because of the enormous amount of malicious code circulating the Internet, safe Internet browsing is a very
important aspect of computer protection. Web browser vulnerabilities and fraudulent links help malicious code
enter the system unnoticed which is why ESET Endpoint Security focuses on web browser security. Each application
accessing the network can be marked as an Internet browser. Applications that already used protocols for
communication or application from selected path can be entered to the list of Web and email clients.
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3.9.3.1.2   Excluded applications

To exclude communications for specific network-aware applications from protocol filtering, add them to this list.
HTTP/POP3/IMAP communication for the selected applications will not be checked for threats. We recommend that
you only use this technique in cases where applications do not function properly with protocol filtering enabled.

Applications and services that were already affected by protocol filtering will be automatically displayed after
clicking Add.

Edit – Edit selected entries from the list.

Remove – Remove selected entries from the list.
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3.9.3.1.3   Excluded IP addresses

IP addresses in this list will be excluded from protocol content filtering. HTTP/POP3/IMAP communication from/to
the selected addresses will not be checked for threats. We recommend that you only use this option for addresses
that are known to be trustworthy.

Add – Click to add an IP address/address range/subnet of a remote point to which a rule is applied.

Edit – Edit selected entries from the list.

Remove – Remove selected entries from the list.

3.9.3.1.4   SSL/TLS

ESET Endpoint Security is capable of checking for threats in communications that use the SSL protocol. You can use
various scanning modes to examine SSL protected communications with trusted certificates, unknown certificates,
or certificates that are excluded from SSL-protected communication checking.

Enable SSL/TLS protocol filtering – If protocol filtering is disabled, the program will not scan communications over
SSL.

SSL/TLS protocol filtering mode is available in following options:

Automatic mode – Select this option to scan all SSL protected communications except communications protected by
certificates excluded from checking. If a new communication using an unknown, signed certificate is established,
you will not be notified and the communication will automatically be filtered. When you access a server with an
untrusted certificate that is marked as trusted (it is on the trusted certificates list), communication to the server is
allowed and the content of the communication channel is filtered.

Interactive mode – If you enter a new SSL protected site (with an unknown certificate), an action selection dialog is
displayed. This mode allows you to create a list of SSL certificates that will be excluded from scanning.

Policy mode – All SSL/TLS protected sites are filtered, except configured exclusions. Either applications or server
certificates can be excluded.

The List of SSL/TLS filtered applications can be used to customize ESET Endpoint Security behavior for specific
applications

List of known certificates allows you to customize ESET Endpoint Security behavior for specific SSL certificates.

Exclude communication with trusted domains – Domain trustiness is determined by builtin whitelist.
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Block encrypted communication utilizing the obsolete protocol SSL v2 – Communication using the earlier version of
the SSL protocol will automatically be blocked.

Note

Addresses will not be filtered if the setting Exclude communication with trusted domains is enabled
and the domain is considered trusted.

Root certificate

Root certificate – For SSL communication to work properly in your browsers/email clients, it is essential that the
root certificate for ESET be added to the list of known root certificates (publishers). Add the root certificate to
known browsers should be enabled. Select this option to automatically add the ESET root certificate to known
browsers (for example, Opera and Firefox). For browsers using the system certification store, the certificate is
added automatically (for example, in Internet Explorer). 

To apply the certificate to unsupported browsers, click View Certificate > Details > Copy to File... and manually
import it into the browser.

Certificate validity

If the certificate cannot be verified using the TRCA certificate store – In some cases, a website certificate cannot
be verified using the Trusted Root Certification Authorities (TRCA) store. This means that the certificate is
signed by someone (for example, the administrator of a web server or a small business) and considering this
certificate as trusted is not always a risk. Most large businesses (for example banks) use a certificate signed by
the TRCA. If Ask about certificate validity is selected (selected by default), the user will be prompted to select
an action to take when encrypted communication is established. You can select Block communication that uses
the certificate to always terminate encrypted connections to sites with unverified certificates.

If the certificate is invalid or corrupt – This means that the certificate expired or was incorrectly signed. In this
case, we recommend that you leave Block communication that uses the certificate selected.

3.9.3.1.4.1   Encrypted SSL communication

If your system is configured to use SSL protocol scanning, a dialog window prompting you to choose an action will be
displayed in two situations:

First, if a website uses an unverifiable or invalid certificate, and ESET Endpoint Security is configured to ask the user
in such cases (by default yes for unverifiable certificates, no for invalid ones), a dialog box will ask you whether to
Allow or Block the connection.

Second, if SSL protocol filtering mode is set to Interactive mode, a dialog box for each website will ask whether to
Scan or Ignore the traffic. Some applications verify that their SSL traffic is not modified nor inspected by anyone, in
such cases ESET Endpoint Security must Ignore that traffic to keep the application working.

In both cases, the user can choose to remember the selected action. Saved actions are stored in the List of known
certificates.
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3.9.3.1.4.2   List of known certificates

The List of known certificates can be used to customize ESET Endpoint Security behavior for specific SSL certificates,
and to remember actions chosen if Interactive mode is selected in SSL/TLS protocol filtering mode. The list can be
viewed and edited in Advanced setup (F5) > Web and email > SSL/TLS > List of known certificates.

The List of known certificates window consists of:

Columns

Name – Name of the certificate.

Certificate issuer – Name of the certificate creator.

Certificate subject – The subject field identifies the entity associated with the public key stored in the subject
public key field.

Access – Select Allow or Block as the Access action to allow/block communication secured by this certificate
regardless of its trustworthiness. Select Auto to allow trusted certificates and ask for untrusted ones. Select Ask
to always ask user what to do.

Scan – Select Scan or Ignore as the Scan action to scan or ignore communication secured by this certificate.
Select Auto to scan in automatic mode and ask in interactive mode. Select Ask to always ask the user what to do.

Control elements

Add – A certificate can be loaded manually as a file with the extension .cer, .crt or .pem. Click File to upload a
local certificate or click URL to specify the location of a certificate online.

Edit – Select the certificate that you want to configure and click Edit.

Remove – Select the certificate that you want to delete and click Remove.

OK/Cancel – Click OK if you want to save changes or click Cancel to exit without saving.

3.9.3.1.4.3   List of SSL/TLS filtered applications

The List of SSL/TLS filtered applications can be used to customize ESET Endpoint Security behavior for specific
applications, and to remember actions chosen if Interactive mode is selected in SSL/TLS protocol filtering mode. The
list can be viewed and edited in Advanced setup (F5) > Web and email > SSL/TLS > List of SSL/TLS filtered
applications.

The List of SSL/TLS filtered applications window consists of:

Columns

Application – Name of the application.

Scan action – Select Scan or Ignore to scan or ignore communication. Select Auto to scan in automatic mode and
ask in interactive mode. Select Ask to always ask the user what to do.

Control elements

Add – Add filtered application. 

Edit – Select the certificate that you want to configure and click Edit.

Delete – Select the certificate that you want to delete and click Remove.

OK/Cancel – Click OK if you want to save changes or click Cancel if you want to exit without saving.
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3.9.3.2   Email client protection

3.9.3.2.1   Email clients

Integration of ESET Endpoint Security with email clients increases the level of active protection against malicious
code in email messages. If your email client is supported, integration can be enabled in ESET Endpoint Security.
When integration is activated, the ESET Endpoint Security toolbar is inserted directly into the email client (toolbar
for newer versions of Windows Live Mail is not inserted), allowing for more efficient email protection. Integration
settings are located under Setup > Advanced setup > Web and email > Email client protection > Email clients.

Email client integration

Email clients that are currently supported include Microsoft Outlook, Outlook Express, Windows Mail and Windows
Live Mail. Email protection works as a plug-in for these programs. The main advantage of the plug-in is that it is
independent of the protocol used. When the email client receives an encrypted message, it is decrypted and sent to
the virus scanner. For a complete list of supported email clients and their versions, refer to the following ESET
Knowledgebase article.

Even if integration is not enabled, email communication is still protected by the email client protection module
(POP3, IMAP).

Turn on Disable checking upon inbox content change if you are experiencing a system slowdown when working with
your email client (MS Outlook only). This can occur when retrieving email from the Kerio Outlook Connector Store.

Email to scan

Enable email protection by client plugins –  When email client protection by email client is disabled, checking of
email client by protocol filtering will be still enabled.
Received email – Toggles checking of received messages.
Sent email – Toggles checking of sent messages.
Read email – Toggles checking of read messages.

Action to be performed on infected email

No action – If enabled, the program will identify infected attachments, but will leave emails without taking any
action.
Delete email – The program will notify the user about infiltration(s) and delete the message.
Move email to the Deleted items folder – Infected emails will be moved automatically to the Deleted items
folder.
Move email to the folder – Infected emails will be moved automatically to the specified folder.

Folder – Specify the custom folder where you want to move infected emails when detected.

Repeat scan after update – Toggles rescanning after a detection engine update.

Accept scan results from other modules – If this is selected, the email protection module accepts scan results of
other protection modules (POP3, IMAP protocols scanning).

Note

We recommend to have option Enable email protection by client plugins and Enable email
protection by protocol filtering (Advanced setup (F5) > Web and email > Email client protection >
Email protocols) enabled.

http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN2138
http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN2138
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3.9.3.2.2   Email protocols

The IMAP and POP3 protocols are the most widespread protocols used to receive email communication in an email
client application. ESET Endpoint Security provides protection for these protocols regardless of the email client
used, and without requiring re-configuration of the email client.

You can configure IMAP/IMAPS and POP3/POP3S protocol checking in Advanced setup. To access this setting,
expand  Web and email > Email client protection > Email protocols.

Enable Email protocols protection – Enables checking of email protocols.

In Windows Vista and later, IMAP and POP3 protocols are automatically detected and scanned on all ports. In
Windows XP, only the configured Ports used by the IMAP/POP3 protocol are scanned for all applications, and all
ports are scanned for applications marked as Web and email clients.

ESET Endpoint Security also supports the scanning of IMAPS and POP3S protocols, which use an encrypted channel to
transfer information between server and client. ESET Endpoint Security checks communication utilizing the SSL
(Secure Socket Layer), and TLS (Transport Layer Security) protocols. The program will only scan traffic on ports
defined in Ports used by IMAPS/POP3S protocol, regardless of operating system version.

Encrypted communications will be not scanned when default settings are in use. To enable the scanning of
encrypted communication, navigate to SSL/TLS in Advanced setup, click Web and email > SSL/TLS and select Enable
SSL/TLS protocol filtering.
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3.9.3.2.3   Alerts and notifications

Email protection provides control of email communications received through the POP3 and IMAP protocols. Using
the plug-in for Microsoft Outlook and other e-mail clients, ESET Endpoint Security provides control of all
communications from the email client (POP3, MAPI, IMAP, HTTP). When examining incoming messages, the
program uses all the advanced scanning methods included in the ThreatSense scanning engine. This means that
detection of malicious programs takes place even before being matched against the detection engine. Scanning of
POP3 and IMAP protocol communications is independent of the email client used.

The options for this functionality are available in Advanced setup under Web and email > Email client protection >
Alerts and notifications.

After an email has been checked, a notification with the scan result can be appended to the message. You can elect
to Append tag messages to received and read mail, Append note to the subject of received and read infected email
or Append tag messages to sent mail. Be aware that on rare occasions tag messages may be omitted in problematic
HTML messages or if messages are forged by malware. The tag messages can be added to received and read email,
sent email or both. The available options are:

· Never – No tag messages will be added at all.

· To infected email only – Only messages containing malicious software will be marked as checked (default).

· To all scanned email – The program will append messages to all scanned email.

Append note to the subject of sent infected email – Disable this if you do not want email protection to include a
virus warning in the subject of an infected email. This feature allows for simple, subject-based filtering of infected
emails (if supported by your email program). It also increases the level of credibility for the recipient and if an
infiltration is detected, provides valuable information about the threat level of a given email or sender.

Template added to the subject of infected email – Edit this template if you wish to modify the subject prefix format
of an infected email. This function will replace the message subject "Hello" with a given prefix value "[virus]" to the
following format: "[virus] Hello". The variable %VIRUSNAME% represents the detected threat.
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3.9.3.2.4   Antispam protection

Unsolicited email, called spam, ranks among the greatest problems of electronic communication. Spam represents
up to 80 percent of all email communication. Antispam protection serves to protect against this problem. Combining
several email security principles, the Antispam module provides superior filtering to keep your inbox clean.

One important principle for spam detection is the ability to recognize unsolicited email based on predefined
trusted addresses (whitelist) and spam addresses (blacklist). All addresses from your contact list are automatically
added to the whitelist, as well as all other addresses you mark as safe.

The primary method used to detect spam is the scanning of email message properties. Received messages are
scanned for basic Antispam criteria (message definitions, statistical heuristics, recognizing algorithms and other
unique methods) and the resulting index value determines whether a message is spam or not.

Start email client antispam protection automatically – When enabled, antispam protection will be activated
automatically on system startup.

Allow advanced antispam scan – Additional antispam data will be downloaded periodically, increasing antispam
capabilities and producing better results.

Antispam protection in ESET Endpoint Security allows you to set different parameters to work with mailing lists.
Options are as follows:

Message processing

Add text to email subject – Enables you to add a custom prefix string to the subject line of messages that have
been classified as spam. The default is "[SPAM]".

Move messages to spam folder – When enabled, spam messages will be moved to the default junk email folder
and also messages reclassified as not spam will be moved to inbox. When you right-click an email message and
select ESET Endpoint Security from the context menu, you can choose from applicable options.

Use the folder – This option moves spam to a user-defined folder.

Mark spam messages as read – Enable this to automatically mark spam as read. It will help you to focus your
attention on "clean" messages.
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Mark reclassified messages as unread – Messages originally classified as spam, but later marked as “clean" will be
displayed as unread.

Spam score logging – The ESET Endpoint Security Antispam engine assigns a spam score to every scanned

message. The message will be recorded in the antispam log (ESET Endpoint Security > Tools > Log files > Antispam
protection).

· None – The score from antispam scanning will not be logged.

· Reclassified and marked as spam – Select this if you want to record a spam score for messages marked as SPAM.

· All – All messages will be recorded to the log with a spam score.

Note

When you click a message in junk email folder, you can choose Reclassify selected messages as NOT
spam and the message will be moved to inbox. When you click a message you consider spam in
inbox, select Reclassify messages as spam and the message will be moved to junk email folder. You
can select multiple messages and perform the action on all of them at the same time.

Note

ESET Endpoint Security supports Antispam protection for Microsoft Outlook, Outlook Express,
Windows Mail and Windows Live Mail.

3.9.3.2.4.1   Blacklist/Whitelist/Exceptions list

To provide protection against unsolicited emails, ESET Endpoint Security allows you to classify email addresses using
specialized lists. The Whitelist contains email addresses you consider to be safe. Messages from users on the
Whitelist are always available in the incoming mail folder. The Blacklist contains email addresses classified as spam,
and all messages from senders on the Blacklist are marked accordingly. The exception list contains email addresses
that are always checked for spam but may also contain addresses from unsolicited email messages that might not be
recognized as spam initially.

All lists can be edited from main program window of ESET Endpoint Security in Advanced Setup > Web and email >
Email client protection > Antispam address books using the Add, Edit and Remove buttons in each list's dialog

window, or from Setup > Web and email after you click the gear wheel  next to Antispam protection.
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By default, ESET Endpoint Security adds all addresses from the address book of supported email clients to the
Whitelist. The Blacklist is empty by default. The Exception list only contains user's own email addresses by default.

3.9.3.2.4.2   Adding addresses to whitelist and blacklist

Email addresses belonging to people you communicate with frequently can be added to the whitelist to ensure that
no message originating from a whitelist address is ever classified as spam. Known spam addresses can be added to
the blacklist and always be classified as spam. To add a new address to the whitelist or blacklist, right-click the email
and select ESET Endpoint Security > Add to Whitelist or Add to Blacklist, or click the Trusted address or Spam address
button in the ESET Endpoint Security Antispam toolbar in your email client.

Similarly, the same process applies to spam addresses. If an email address is listed on the blacklist, each email
message which arrives from that address is classified as spam.

3.9.3.2.4.3   Marking messages as spam or not spam

Any message viewed in your email client can be marked as spam. To do so, right-click the message and click ESET
Endpoint Security > Reclassify selected messages as spam, or click Spam in the ESET Endpoint Security Antispam
toolbar located in the upper section of your email client.

Reclassified messages are automatically moved to the SPAM folder, but the sender's email address is not added to
the Blacklist. Similarly, messages can be classified as “not spam” by clicking ESET Endpoint Security > Reclassify
selected messages as not spam or click Not spam in the ESET Endpoint Security Antispam toolbar located in the
upper section of your email client. If messages from the Junk E-mail folder are classified as not spam, they are
moved to the Inbox folder. Marking a message as not spam automatically adds the sender's address to the Whitelist.

3.9.3.3   Web access protection

Internet connectivity is a standard feature on most personal computers. Unfortunately, it has also become the main
medium for transferring malicious code. Web access protection works by monitoring communication between web
browsers and remote servers, and complies with HTTP (Hypertext Transfer Protocol) and HTTPS (encrypted
communication) rules.

Access to web pages known to contain malicious content is blocked before content is downloaded. All other
webpages are scanned by the ThreatSense scanning engine when they are loaded and blocked if malicious content
is detected. Web access protection offers two level of protection, blocking by blacklist and blocking by content.

We strongly recommend that you leave Web access protection enabled. This option can be accessed from the main
program window of ESET Endpoint Security by navigating to Setup > Web and email > Web access protection.

The following options are available in Advanced setup (F5) > Web and email > Web access protection:
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· Web protocols – enables you to configure monitoring for these standard protocols which are used by most
Internet browsers.

· URL address management – enables you to specify HTTP addresses to block, allow or exclude from checking.

· ThreatSense parameters – Advanced virus scanner setup – enables you to configure settings such as types of
objects to scan (emails, archives, etc.), detection methods for Web access protection etc.

3.9.3.3.1   Basic

Enable Web access protection – When disabled, Web access protection and Anti-Phishing protection will not run.

Enable advanced scanning of browser scripts – When enabled, all JavaScript programs executed by internet
browsers will be checked by antivirus scanner.

Note

We strongly recommend you leave Web access protection enabled.

3.9.3.3.2   Web protocols

By default, ESET Endpoint Security is configured to monitor the HTTP protocol used by most Internet browsers.

In Windows Vista and later, HTTP traffic is always monitored on all ports for all applications. In Windows XP, you can
modify the Ports used by HTTP protocol in Advanced setup (F5) > Web and email > Web access protection > Web
protocols > HTTP scanner setup. HTTP traffic is monitored on the specified ports for all applications, and on all ports
for applications marked as Web and email clients.

ESET Endpoint Security also supports HTTPS protocol checking. HTTPS communication uses an encrypted channel to
transfer information between server and client. ESET Endpoint Security checks communication utilizing the SSL
(Secure Socket Layer), and TLS (Transport Layer Security) protocols. The program will only scan traffic on ports
defined in Ports used by HTTPS protocol, regardless of operating system version.

Encrypted communication will be not scanned when default settings are in use. To enable the scanning of encrypted
communication, navigate to SSL/TLS in Advanced setup, click Web and email > SSL/TLS and select Enable SSL/TLS
protocol filtering.

3.9.3.3.3   URL address management

The URL address management section allows you to specify HTTP addresses to block, allow or exclude from
checking.

Websites in the List of blocked addresses will not be accessible unless they are also included in the List of allowed
addresses. Websites in the List of addresses excluded from checking are not scanned for malicious code when
accessed.

Enable SSL protocol filtering must be selected if you want to filter HTTPS addresses in addition to HTTP web pages.
Otherwise only the domains of HTTPS sites that you have visited will be added, the full URL will not be.

In all lists, the special symbols * (asterisk) and ? (question mark) can be used. The asterisk represents any number or
character, while the question mark represents any one character. Particular care should be taken when specifying
excluded addresses because the list should only contain trusted and safe addresses. Similarly, it is necessary to
ensure that the symbols * and ? are used correctly in this list. See Add HTTP address / domain mask for how a whole
domain including all subdomains can be matched safely. To activate a list, enable the List active option. If you want
to be notified when entering an address from the current list, enable Notify when applying.

If you want to block all HTTP addresses except addresses present in the active List of allowed addresses, add * to the
active List of blocked addresses.
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Note

Addresses will not be filtered if the setting Exclude communication with trusted domains is enabled
and the domain is considered trusted.

Add – Creates a new list in addition to the predefined ones. This can be useful if you want to logically split different
groups of addresses. For example, one list of blocked addresses may contain addresses from some external public
blacklist, and a second one may contain your own blacklist, which makes it easier to update the external list while
keeping yours intact.

Edit – Modifies existing lists. Use this to add or remove addresses from the lists.

Remove – Deletes existing list. Only possible for lists created with Add, not for the default ones.

3.9.3.4   Anti-Phishing protection

The term phishing defines a criminal activity that uses social engineering (the manipulation of users in order to
obtain confidential information). Phishing is often used to gain access to sensitive data such as bank account
numbers, PIN numbers and more. Read more about this activity in the glossary. ESET Endpoint Security includes
anti-phishing protection, which blocks web pages known to distribute this type of content.

We strongly recommend that you enable Anti-Phishing in ESET Endpoint Security. To do so, open Advanced setup
(F5) and navigate to Web and email > Anti-Phishing protection.

Visit our Knowledgebase article for more information on Anti-Phishing protection in ESET Endpoint Security.

Accessing a phishing website

When you access a recognized phishing website, the following dialog will be displayed in your web browser. If you
still want to access the website, click Proceed to the site (not recommended).

http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN3100
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Note

Potential phishing websites that have been whitelisted will expire after several hours by default. To
allow a website permanently, use the URL address management tool. From Advanced setup (F5)
expand Web and email > Web access protection > URL address management > Address list, click Edit
and then add the website that you want to edit to the list.

Phishing site reporting

The Report link enables you to report a phishing/malicious website to ESET for analysis.

Note

Before submitting a website to ESET, make sure it meets one or more of the following criteria:

· the website is not detected at all,

· the website is incorrectly detected as a threat. In this case, you can Report a false-positive
phishing site.

Alternatively, you can submit the website by email. Send your email to samples@eset.com. Remember to use a
descriptive subject and enclose as much information about the website as possible (for example, the website that
referred you there, how you learned of this website, etc.).

http://phishing.eset.com/report/enu
http://phishing.eset.com/remove/enu
http://phishing.eset.com/remove/enu
mailto:samples@eset.com
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3.9.4   Web control

The Web control section allows you to configure settings that protect your company from risk of legal liability. Web
control can regulate access to websites that violate intellectual property rights. The goal is to prevent employees
from accessing pages with inappropriate or harmful content, or pages that may have a negative impact on
productivity.

Web control lets you block webpages that may contain potentially offensive material. In addition, employers or
system administrators can prohibit access to more than 27 pre-defined website categories and over 140
subcategories.

By default, Web control is disabled. To activate web control, press F5 to enter Advanced setup, and expand Web and
email > Web control. Select Integrate into system to activate Web control in ESET Endpoint Security.  Click Edit next
to Rules, to access the Web control rules editor window.

Blocked webpage message and Block webpage graphic fields allow you to easily customize the displayed message
when a website is blocked.

Example 

An example of a blocked webpage message would be The webpage was blocked because it is
considered inappropriate or with harmf ul content. Please contact your administrator f or details and
you can enter a web address or network path with custom image for example
http://test.com/test.j pg. The custom image size is set automatically to 90 x 30; images will
automatically be scaled to this size if they are not already.

Note

In case you want to block all webpages and leave only certain available click here.

3.9.4.1   Rules

The Rules editor window displays existing URL-based or Category-based rules.

The list of rules contains several descriptions of rules such as name, type of blocking, action to perform after
matching a Web control rule and log severity.
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Click Add or Edit to manage a rule. Click Copy to create a new rule with predefined options used for another
selected rule. By pressing Ctrl and clicking, you can select multiple rules and delete all selected rules. The Enabled
check box disables or enables a rule; this can be useful if you don't want to delete a rule permanently because it
might be used in the future.

Rules are sorted in the order determining their priority, with higher priority rules on top. Evaluation of rules based
on URL always has higher priority than evaluation based on category. For example, if a rule based on a URL is under a
rule based on category in the list of rules, the URL-based rule has higher priority and will be evaluated first.

For more information on creating rules click here.

3.9.4.1.1   Adding Web control rules

The Web control rules window allows you to manually create or modify an existing Web control filtering rule.

Enter a description of the rule into the Name field for better identification. Click the Enabled  switch to disable or
enable the rule; this can be useful if you don't want to delete the rule permanently.

Action type

· URL-based action – For rules that control access to a given website, enter the URL in the URL field.

· Category-based action – When this is selected, set the category for your action using the drop-down menu.

The special symbols * (asterisk) and ? (question mark) cannot be used in the URL address list. When creating a URL
group that contains a website with multiple top-level-domains (TLDs), each TLD must be added separately. If you
add a domain to the group, all content located on this domain and all subdomains (for example,
sub.examplepage.com) will be blocked or allowed based on your choice of URL-based action.

Access rights

· Allow – Access to the URL address/category will be granted.

· Warn – Warns the user about the URL address/category.

· Block – Blocks the URL address/category.

Apply during – Allows you to apply created rule during the certain time. From the drop-down menu, select created
time slot. For more information about Time slots click here.

URL or Use URL group - Uses the URL link or group of links to allow, block or warn the user when one of these URLs is
detected.

Logging severity:

· Always  – Logs all online communications.
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· Diagnostic – Logs information needed to fine-tune the program.

· Information – Records informative messages, including successful update messages, plus all records above.

· Warning – Records critical errors and warning messages.

· None – No logs will be created.

Note

The Logging severity can be configured separately for each list. Logs with Warning status can be
collected by ESET Remote Administrator.

User list

· Add – Opens the Select Users or Groups dialog window, which allows you to select desired users. When no user
is entered the rule is applied for all users.

· Remove – Removes the selected user from the filter.

3.9.4.2   Category groups

The Category groups window is divided into two parts. The right part of the window contains a list of categories and
subcategories. Select a category in the Category list to display its subcategories. 

Each group contains adult and/or generally inappropriate subcategories as well as categories considered generally
acceptable. When you open the Category groups window and click on first group, you can add or remove
categories/subcategories from the list of appropriate groups (for example Violence or Weapons). Web pages with
inappropriate content can be blocked, or users can be informed after a rule with predefined actions is created.

Select the check box to add or remove a subcategory to a particular group.

Here are some examples of categories that users might not be familiar with:
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Miscellaneous – Usually private (local) IP addresses such as intranet, 192.168.0.0/16, etc. When you get a 403 or
404 error code, the website will also match this category.
Not resolved – This category includes web pages that are not resolved because of an error when connecting to
the Web control database engine.
Not categorized – Unknown web pages that are not yet in the Web control database.
Proxies – Web pages such as anonymizers, redirectors or public proxy servers can be used to obtain (anonymous)
access to web pages that are usually prohibited by the Web control filter.

File sharing – These web pages contain large amounts of data such as photos, videos or e-books. There is a risk that
these sites contain potentially offensive material or adult content.

Note

A subcategory can belong to any group. There are some subcategories that are not included in
predefined groups (for example, Games). In order to match a desired subcategory using Web control
filter, add it to your desired group.

3.9.4.3   URL groups

URL groups allow you to create a group that contains several URL links for which you want to create a rule
(allow/disallow a particular website).

To create a new URL group click Add. Select a URL group and click Add in the bottom right of the window to add a
new URL address to the list, or click Import to import a file with a list of URL addresses (separate values with a line
break, for example *.txt using encoding UTF-8). If you want to set an action to be performed for a specific URL group,
open the Web control rules editor, select your URL group using the drop-down menu, adjust other parameters and
then click OK.

Note

Blocking or allowing a specific web page can be more accurate than blocking or allowing a whole
category of web pages. Be careful when changing these settings and adding a category/web page to
the list.

3.9.5   Updating the program

Regularly updating ESET Endpoint Security is the best method to obtain the maximum level of security on your
computer. The Update module ensures that the program is always up to date in two ways, by updating the detection
engine and by updating system components.

By clicking Update in the main program window, you can find the current update status including the date and time
of the last successful update and if an update is needed. You can also click the Show all modules link to open the list
of installed modules and check the version and the last update of a module.

In addition, the option to manually begin the update process, Check the updates is available. Updating the
detection engine and updating program components are important parts of maintaining complete protection
against malicious code. Please pay attention to their configuration and operation. If you did not enter your License
details during installation, you can enter your license key by clicking Activate product when updating to access
ESET’s update servers.

If you activate  ESET Endpoint Security with Offline license file without Username and Password and try to update,
the red information Detection engine update ended with an error signals you can download updates from the
mirror only.

Note
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Your license key is provided by ESET after purchasing ESET Endpoint Security.

Current version – The ESET Endpoint Security build number.

Last update – The date and time of the last update. Make sure it refers to a recent date, which means that the
detection engine is current.

Last check for updates – The date and time of the last attempt to update modules.

Show all modules – Click the link to open the list of installed modules and check the version and the last update of a
module.
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Update process

After clicking Check for updates, the download process begins. A download progress bar and remaining time to
download will be displayed. To interrupt the update, click Cancel update.

Important

Under normal circumstances the detection engine updates several times a day. If this is not the case,
the program is out of date and more vulnerable to infection. Please update the detection engine as
soon as possible.

Detection engine out of date – This error will appear after several unsuccessful attempts to update the detection
engine. We recommend that you check the update settings. The most common reason for this error is incorrectly
entered authentication data or incorrectly configured connection settings.
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The previous notification is related to the following two Detection engine update failed messages about
unsuccessful updates:

1. Invalid license – The license key has been incorrectly entered in update setup. We recommend that you check
your authentication data. The Advanced setup window (click Setup from the main menu and then click Advanced
setup, or press F5 on your keyboard) contains additional update options. Click Help and support > Manage
license from the main menu to enter a new license key.
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2. An error occurred while downloading update files – A possible cause of the error is incorrect Internet connection
settings. We recommend that you check your Internet connectivity (by opening any website in your web
browser). If the website does not open, it is likely that an Internet connection is not established or there are
connectivity problems with your computer. Please check with your Internet Service Provider (ISP) if you do not
have an active Internet connection.

Note

For more information please visit this ESET Knowledgebase article. 

3.9.5.1   Update setup

Update setup options are available in the Advanced setup tree (F5) under Update. This section specifies update
source information like the update servers being used and authentication data for these servers.

 General

The update profile that is currently in use is displayed in the Update profile drop-down menu. To create a new
profile, navigate to Profiles tab and click Edit next to List of profiles, enter your own Profile name and then click
Add.

If you are experiencing difficulty when attempting to download modules updates, click Clear to clear the temporary
update files/cache.

Outdated detection engine alerts

Set maximum database age automatically – Allows to set maximum time (in days) after which the detection engine
will be reported as out of date. Default value is 7.

http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN2850
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Rollback

If you suspect that a new update of the detection engine and/or program modules may be unstable or corrupt, you
can roll back to the previous version and disable updates for a set period of time. Alternatively, you can enable
previously disabled updates if you had postponed them indefinitely.

ESET Endpoint Security records snapshots of detection engine and program modules for use with the rollback
feature. In order to create virus database snapshots, leave the Create snapshots of update files switch enabled. The
Number of locally stored snapshots field defines the number of previous virus database snapshots stored.

If you click Rollback (Advanced setup (F5) > Update > General), you have to select a time interval from the drop-
down menu that represents the period of time that the detection engine and program module updates will be
paused.

For updates to be downloaded properly, it is essential that you fill in all update parameters correctly. If you use a
firewall, please make sure that your ESET program is allowed to communicate with the Internet (for example, HTTP
communication).

 Profiles

To create a new profile, click Edit next to List of profiles, enter your own Profile name and then click Add. To edit
created profile, select created profile and click Edit next to List of profiles.

 Basic

By default, the Update type is set to Regular update to ensure that update files will automatically be download from
the ESET server with the least network traffic. Pre-release updates (the Pre-release update option) are updates that
have gone through thorough internal testing and will be available to the general public soon. You can benefit from
enabling pre-release updates by having access to the most recent detection methods and fixes. However, pre-
release updates might not be stable enough at all times and SHOULD NOT be used on production servers and
workstations where maximum availability and stability is required. Delayed update allows updating from special
update servers providing new versions of virus databases with a delay of at least X hours (i.e. databases tested in a
real environment and therefore considered as stable).
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Disable notification about successful update – Turns off the system tray notification at the bottom right corner of
the screen. It is useful to select this option if a full screen application or a game is running. Please note that
Presentation mode will turn off all notifications.

Update from removable media – Allows you to update from removable media if contains created mirror. When
Automatic selected, update will run on background. If you want to show update dialogs select Always ask.

The Update server menu is set to Choose automatically by default. The Update server is the location where updates
are stored. If you use an ESET server, we recommend that you leave the default option selected.

When using a local HTTP server – also known as a Mirror – the update server should be set as follows:
http://computer_name_or_its_IP_address:2221

When using a local HTTP server with SSL – the update server should be set as follows:
https://computer_name_or_its_IP_address:2221

When using a local shared folder – the update server should be set as follows:
\\computer_name_or_its_IP_address\shared_f older

Updating from Mirror

Authentication for update servers is based on the License key generated and sent to you after purchase. When using
a local Mirror server, you can define credentials for clients to log in to the Mirror server before receiving updates. By
default, no verification is required and the Username and Password fields are left empty.

3.9.5.1.1   Update profiles

Update profiles can be created for various update configurations and tasks. Creating update profiles is especially
useful for mobile users who need an alternative profile for Internet connection properties that regularly change.

The Update profile drop-down menu displays the currently selected profile and is set to My profile by default. To
create a new profile, click Edit next to List of profiles, enter your own Profile name and then click Add.

3.9.5.1.2   Update rollback

If you click Rollback (Advanced setup (F5) > Update > Profile), you have to select a time interval from the drop-down
menu that represents the period of time that the detection engine and program module updates will be paused.

Select Until revoked to postpone regular updates indefinitely until you restore update functionality manually.
Because it represents a potential security risk, we do not recommend selecting this option.

The detection engine version is downgraded to the oldest available and stored as a snapshot in the local computer
file system.

Note

Let the number 10646 be the most recent version of detection engine. 10645 and 10643 are stored as
a detection engine snapshots. Note that 10644 is not available because, for example, the computer

https://computer_name_or_its_IP_address:2221
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was turned off and a more recent update was made available before 10644 was downloaded. If the
Number of locally stored snapshots field is set to 2 and you click Rollback, the detection engine
(including program modules) will be restored to version number 10643. This process may take some
time. Check whether the detection engine version has downgraded from the main program window
of ESET Endpoint Security in the Update section.

3.9.5.1.3   Update mode

The Update mode tab contains options related to the program component update. The program enables you to
predefine its behavior when a new program component upgrade is available.

Program component updates brings new features or makes changes to those that already exist from previous
versions. It can be performed automatically without user intervention, or you can choose to be notified. After a
program component update has been installed, a computer restart may be required. In the Program component
update section, three options are available:

· Ask before downloading program components – The default option. You will be prompted to confirm or refuse
program component updates when they are available.

· Always update program components – A program component update will be downloaded and installed
automatically. Please remember that a computer restart may be required.

· Never update program components – Program component updates will not be performed at all. This option is
suitable for server installations, since servers can usually be restarted only when they are undergoing
maintenance.

Note

Selecting the most appropriate option depends on the workstation where the settings will be
applied. Please be aware that there are differences between workstations and servers – for
example, restarting the server automatically after a program update could cause serious damage.

Enable manual program component update – By default disabled. When enabled and newer version of ESET
Endpoint Security is available, you can check for updates in Update pane and install the newer version.

If the Ask before downloading update option is active, a notification will display when a new update is available.

If the update file size is greater than the value specified in the Ask if an update file is greater than (kB) field, the
program will display a notification.

3.9.5.1.4   HTTP Server

Server port – By default, the Server port is set to 2221.

Authentication – Defines the method of authentication used for accessing update files. The following options are
available: None, Basic and NTLM. Select Basic to use base64 encoding with basic username and password
authentication. The NTLM option provides encoding using a safe encoding method. For authentication, the user
created on the workstation sharing the update files is used. The default setting is None, which grants access to the
update files with no need for authentication.

Append your Certificate chain file, or generate a self-signed certificate if you want to run HTTP server with HTTPS
(SSL) support. The following certificate types are available: ASN, PEM and PFX. For additional security, you can use
HTTPS protocol to download update files. It is almost impossible to track data transfers and login credentials using
this protocol. The Private key type option is set to Integrated by default (and therefore the Private key file option is
disabled by default). This means that the private key is a part of the selected certificate chain file.

Note
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Authentication data such as Username and Password is intended for accessing the proxy server.
Complete these fields only if a username and password are required. Please note that these fields
are not for your Username/Password for ESET Endpoint Security, and should only be completed if
you know you need a password to access the internet via a proxy server.

3.9.5.1.5   Connection options

When updating from a local server with a version of the Windows NT operating system, authentication for each
network connection is required by default. 

To configure such an account, select from the Connect to LAN as drop-down menu:

· System account (default),

· Current user,

· Specified user.

Select System account (default) to use the system account for authentication. Normally, no authentication process
takes place if there is no authentication data supplied in the main update setup section.

To ensure that the program authenticates using a currently logged-in user account, select Current user. The
drawback of this solution is that the program is not able to connect to the update server if no user is currently
logged in.

Select Specified user if you want the program to use a specific user account for authentication. Use this method
when the default system account connection fails. Please be aware that the specified user account must have access
to the update files directory on the local server. Otherwise the program will not be able to establish a connection
and download updates.

Username and Password settings are optional.

Warning

When either Current user or Specified user is selected, an error may occur when changing the
identity of the program to the desired user. We recommend entering the LAN authentication data in
the main update setup section. In this update setup section, the authentication data should be
entered as follows: domain_name\user (if it is a workgroup, enter workgroup_name\name) and
password. When updating from the HTTP version of the local server, no authentication is required.

Select Disconnect from server after update to force a disconnection if a connection to the server remains active
even after updates have been downloaded.
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3.9.5.1.6   Update mirror

ESET Endpoint Security allows you to create copies of update files that can be used to update other workstations on
the network. The use of a "mirror" – a copy of the update files in the LAN environment is convenient because the
update files do not need to be downloaded from the vendor update server repeatedly by each workstation.
Updates are downloaded to the local mirror server and then distributed to all workstations to avoid the risk of
network traffic overload. Updating client workstations from a Mirror optimizes network load balance and saves
Internet connection bandwidth.

Configuration options for the local Mirror server are located in Advanced setup under Update. To access this section
press F5 to access Advanced setup, click Update > Profiles and select the Mirror tab.

To create a mirror on a client workstation, enable Create update mirror. Enabling this option activates other Mirror
configuration options such as the way update files will be accessed and the update path to the mirrored files.

Access to update files

Provide update files via the internal HTTP server – If enabled, update files can be accessed through HTTP, no
credentials are required.

Note

Windows XP requires Service Pack 2 or later to use the HTTP server.

Methods to access the Mirror server are described in detail in Updating from the Mirror. There are two basic
methods for accessing the Mirror – the folder with update files can be presented as a shared network folder, or
clients can access the mirror located on an HTTP server.

The folder dedicated to storing update files for the Mirror is defined under Folder to store mirrored files. To choose
a different folder click Clear to delete predefined folder C:\ProgramData\ESET\ESET Endpoint Security\mirror and
click Edit to browse for a folder on the local computer or shared network folder. If authorization for the specified
folder is required, authentication data must be entered in the Username and Password fields. If the selected
destination folder is located on a network disk running the Windows NT/2000/XP operating system, the username
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and password specified must have write privileges for the selected folder. The username and password should be
entered in the format Domain/User or Workgroup/User. Please remember to supply the corresponding passwords.

Files – When configuring the Mirror you can specify the language versions of updates you want to download.
Languages selected must be supported by the mirror server configured by the user.

Program component update

Update components automatically – Allows for the installation of new features and updates to existing features. An
update can be performed automatically without user intervention, or you can choose to be notified. After a program
component update has been installed, a computer restart may be required.

Update components now – Updates your program components to the latest version.

3.9.5.1.6.1   Updating from the Mirror

There are two basic methods to configure a Mirror, which is essentially a repository where clients can download
update files. The folder with update files can be presented as a shared network folder or as an HTTP server.

Accessing the Mirror using an internal HTTP server

This is the default configuration specified in the predefined program configuration. To allow access to the Mirror
using the HTTP server, navigate to Advanced setup > Update > Profiles > Mirror and select Create update mirror.

In the HTTP Server section of the Mirror tab you can specify the Server port where the HTTP server will listen as well
as the type of Authentication used by the HTTP server. By default, the Server port is set to 2221. The Authentication
option defines the method of authentication used for accessing the update files. The following options are
available: None, Basic, and NTLM. Select Basic to use base64 encoding with basic username and password
authentication. The NTLM option provides encoding using a safe encoding method. For authentication, the user
created on the workstation sharing the update files is used. The default setting is None, which grants access to the
update files with no need for authentication.
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Warning

If you want to allow access to the update files via the HTTP server, the Mirror folder must be located
on the same computer as the ESET Endpoint Security instance creating it.

SSL for HTTP Server

Append your Certificate chain file, or generate a self-signed certificate if you want to run HTTP server with HTTPS
(SSL) support. The following certificate types are available: PEM, PFX and ASN. For additional security, you can use
HTTPS protocol to download update files. It is almost impossible to track data transfers and login credentials using
this protocol. Private key type is set to Integrated by default, which means that the private key is a part of the
selected certificate chain file.

Note

An error Invalid Username and/or Password will appear in the Update pane from the main menu
after several unsuccessful attempts to update the detection engine from the Mirror. We
recommend that you navigate to Advanced setup > Update > Profiles > Mirror and check the
Username and Password. The most common reason for this error is incorrectly entered
authentication data.

After your Mirror server is configured, you must add the new update server on client workstations. To do this,
follow the steps below:

· Access Advanced setup (F5) and click Update > Profiles > Basic.

· Disengage Choose automatically and add a new server to the Update server field using one of the following
formats:
http://IP_address_of _your_server:2221
https://IP_address_of _your_server:2221 (if SSL is used)
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Accessing the Mirror via system shares

First, a shared folder should be created on a local or network device. When creating the folder for the Mirror, you
must provide “write” access for the user who will save update files to the folder and “read” access for all users who
will update ESET Endpoint Security from the Mirror folder.

Next, configure access to the Mirror in Advanced setup > Update > Profiles > Mirror tab by disabling Provide update
files via internal HTTP server. This option is enabled by default in the program install package.

If the shared folder is located on another computer in the network, you must enter authentication data to access the
other computer. To enter authentication data, open ESET Endpoint Security Advanced setup (F5) and click Update >
Profiles > Connect to LAN as. This is the same setting used for updating, as described in the Connect to LAN as
section.

To access the mirror folder, this needs to be done under the same account as the one used for logging into the
computer the mirror is created on. In case the computer is in a domain, "domain\user" username should be used. In
case the computer is not in a domain, "IP_address_of_your_server\user" or "hostname\user" should be used.

After the Mirror configuration is complete, on client workstations set \\UNC\PATH as the update server using the
steps below:

1. Open ESET Endpoint Security Advanced setup and click Update > Profiles > Basic.
2. Disengage Choose automatically and a new server to the Update server field using the \\UNC\PATH format.

Note

For updates to function properly, the path to the Mirror folder must be specified as a UNC path.
Updates from mapped drives may not work.

The last section controls program components (PCUs). By default, downloaded program components are prepared
to copy to the local mirror. If Program component update is activated, there is no need to click Update, because files
are copied to the local mirror automatically when they are available. See Update mode for more information about
program component updates.

3.9.5.1.6.2   Troubleshooting Mirror update problems

In most cases, problems during an update from a Mirror server are caused by one or more of the following: incorrect
specification of the Mirror folder options, incorrect authentication data to the Mirror folder, incorrect configuration
on local workstations attempting to download update files from the Mirror, or by a combination of the reasons
above. Below is an overview of the most frequent problems which may occur during an update from the Mirror:

ESET Endpoint Security reports an error connecting to Mirror server – Likely caused by incorrect specification of the
update server (network path to the Mirror folder) from which local workstations download updates. To verify the
folder, click the Windows Start menu, click Run, enter the folder name and click OK. The contents of the folder
should be displayed.

ESET Endpoint Security requires a username and password – Likely caused by incorrect authentication data
(username and password) in the update section. The username and password are used to grant access to the update
server, from which the program will update itself. Make sure that the authentication data is correct and entered in
the correct format. For example, Domain/Username, or Workgroup/Username, plus the corresponding Passwords. If
the Mirror server is accessible to “Everyone”, please be aware that this does not mean that any user is granted
access. “Everyone” does not mean any unauthorized user, it just means that the folder is accessible for all domain
users. As a result, if the folder is accessible to “Everyone”, a domain username and password will still need to be
entered in the update setup section.

ESET Endpoint Security reports an error connecting to the Mirror server – Communication on the port defined for
accessing the HTTP version of the Mirror is blocked.

ESET Endpoint Security reports an error while downloading update files – Likely caused by incorrect specification of
the update server (network path to the Mirror folder) from which local workstations download updates.
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3.9.5.2   How to create update tasks

Updates can be triggered manually by clicking Check for updates in the primary window displayed after clicking
Update from the main menu.

Updates can also be run as scheduled tasks. To configure a scheduled task, click Tools > Scheduler. By default, the
following tasks are activated in ESET Endpoint Security:

· Regular automatic update

· Automatic update after dial-up connection

· Automatic update after user logon

Each update task can be modified to meet your needs. In addition to the default update tasks, you can create new
update tasks with a user-defined configuration. For more details about creating and configuring update tasks, see
Scheduler.

3.9.6   Tools

The Tools menu includes modules that help simplify program administration and offers additional options for
advanced users.
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This menu includes the following tools:

· Log files

· Protection statistics

· Watch activity

· Running processes (if ESET LiveGrid® is enabled in ESET Endpoint Security)

· Scheduler

· Quarantine

· Network connections (if firewall is enabled in ESET Endpoint Security)

· ESET SysInspector

Submit sample for analysis – Allows you to submit a suspicious file for analysis to the ESET Research Lab. The dialog
window displayed after clicking this option is described in the Submission of samples for analysis section.

ESET SysRescue – Redirects you to the ESET SysRescue Live page, where you can download the ESET SysRescue Live
image or Live CD/USB Creator for Microsoft Windows operating systems.

3.9.6.1   Log files

Log files contain information about all important program events that have occurred and provide an overview of
detected threats. Logs are an essential tool in system analysis, threat detection and troubleshooting. Logging is
performed actively in the background with no user interaction. Information is recorded based on the current log
verbosity settings. It is possible to view text messages and logs directly from the ESET Endpoint Security
environment. It is also possible to archive log files.

Log files are accessible from the main program window by clicking Tools > Log files. Select the desired log type from
the Log drop-down menu. The following logs are available:

· Detected threats – The threat log offers detailed information about infiltrations detected by ESET Endpoint
Security modules. The information includes the time of detection, name of infiltration, location, the performed
action and the name of the user logged in at the time the infiltration was detected. Double-click any log entry to
display its details in a separate window.

· Events – All important actions performed by ESET Endpoint Security are recorded in the event log. The event log
contains information about events and errors that have occurred in the program. It is designed to help system
administrators and users resolve problems. Often the information found here can help you find a solution for a
problem occurring in the program.

· Computer scan – All scan results are displayed in this window. Each line corresponds to a single computer control.
Double-click any entry to view the details of the respective scan.

· Blocked files – Contains records of files that were blocked and could not be accessible. The protocol shows the
reason and the source module that blocked the file, as well as the application and user that executed the file.

· HIPS – Contains records of specific rules that are marked for recording. The protocol shows the application that
called the operation, the result (whether the rule was permitted or prohibited) and the name of the rule created.

· Firewall – The firewall log displays all remote attacks detected by the firewall. Here you will find information
about any attacks on your computer. The Event column lists the detected attacks. The Source column tells you
more about the attacker. The Protocol column reveals the communication protocol used for the attack. Analysis of
the firewall log may help you to detect system infiltration attempts in time to prevent unauthorized access to
your system. For more details on particular network attacks, see IDS and advanced options.

· Filtered websites – This list is useful if you want to view a list of websites that were blocked by Web access
protection or Web control. In these logs you can see the time, URL, user and application that opened a connection
to the particular website.

· Antispam protection – Contains records related to email messages that were marked as spam.

· Web control – Shows blocked or allowed URL addresses and details about how they are categorized. The Action
perf ormed column tells you how filtering rules were applied.
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· Device control – Contains records of removable media or devices that were connected to the computer. Only
devices with a Device control rule will be recorded to the log file. If the rule does not match a connected device, a
log entry for a connected device will not be created. Here you can also see details such as device type, serial
number, vendor name and media size (if available).

In each section, the displayed information can be copied to the clipboard (keyboard shortcut Ctrl + C) by selecting
the entry and clicking Copy. The Ctrl and Shift keys can be used to select multiple entries.

Click  Filtering to open the Log filtering window where you can define the filtering criteria.

You can bring up the context menu by right-clicking a specific record. The following options are available in the
context menu:

· Show – Shows more detailed information about the selected log in a new window.

· Filter same records – After activating this filter, you will only see records of the same type (diagnostics,
warnings, ...).

· Filter.../Find... – After clicking this option, the Search in log window will allow you to define filtering criteria
for specific log entries.

· Enable filter – Activates filter settings.

· Disable filter – Clears all filter settings (as described above).

· Copy/Copy all – Copies information about all the records in the window.

· Delete/Delete all – Deletes the selected record(s) or all the records displayed – this action requires
administrator privileges.

· Export... – Exports information about the record(s) in XML format.

· Export all... – Export information about all records in XML format.

· Scroll log – Leave this option enabled to auto scroll old logs and view active logs in the Log files window.

3.9.6.1.1   Search in log

Logs store information about important system events. The log filtering feature allows you to display records about
a specific type of event.

Enter the search keyword into the Find text field. If you wish to search the keyword in specific columns, change the
filter in the Search in columns drop-down menu.

Record types – Choose one or more record log types from the drop-down menu:

· Diagnostic – Logs information needed to fine-tune the program and all records above.

· Informative – Records informative messages, including successful update messages, plus all records above.

· Warnings – Records critical errors and warning messages.

· Errors – Errors such as "Error downloading file" and critical errors will be recorded.

· Critical – Logs only critical errors (error starting antivirus protection, built-in firewall, etc...).
Time period – Define the time period from which you want the results to be displayed.

Match whole words only – Select this check box if you want to search for specific whole words for more precise
results.

Case sensitive – Enable this option if it is important for you to use capital or lower case letters while filtering.

Search upwards – Search results that appear higher in the document will be displayed first.
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3.9.6.2   Proxy server setup

In large LAN networks, communication between your computer and the internet can be mediated by a proxy server.
Using this configuration, the following settings need to be defined. Otherwise the program will not be able to
update itself automatically. In ESET Endpoint Security, proxy server setup is available from two different sections of
the Advanced setup tree.

First, proxy server settings can be configured in Advanced setup under Tools > Proxy server. Specifying the proxy
server at this level defines global proxy server settings for all of ESET Endpoint Security. Parameters here will be
used by all modules that require a connection to the Internet.

To specify proxy server settings for this level, select Use proxy server and enter the address of the proxy server into
the Proxy server field along with the Port number of the proxy server.

If communication with the proxy server requires authentication, select Proxy server requires authentication and
enter a valid Username and Password into the respective fields. Click Detect to automatically detect and populate
proxy server settings. The parameters specified in Internet Explorer will be copied.

Note

You must manually enter your Username and Password in Proxy server settings.

Use direct connection if proxy is not available – If a product is configured to utilize HTTP Proxy and the proxy is
unreachable, the product will bypass the proxy and communicate directly with ESET servers.

Proxy server settings can also be established from Advanced update setup (Advanced setup > Update > Profiles >
Updates > Connection options by selecting Connection through a proxy server from the Proxy mode drop-down
menu). This setting applies for the given update profile and is recommended for laptops that often receive
detection engine updates from remote locations. For more information about this setting, see Advanced update
setup.

3.9.6.3   Scheduler

Scheduler manages and launches scheduled tasks with predefined configuration and properties.

The Scheduler can be accessed from the ESET Endpoint Security main program window by clicking Tools > Scheduler.
The Scheduler contains a list of all scheduled tasks and configuration properties such as the predefined date, time
and scanning profile used.

The Scheduler serves to schedule the following tasks: detection engine update, scanning task, system startup file
check and log maintenance. You can add or delete tasks directly from the main Scheduler window (click Add task or
Delete at the bottom). Right click anywhere in the Scheduler window to perform the following actions: display
detailed information, perform the task immediately, add a new task, and delete an existing task. Use the
checkboxes at the beginning of each entry to activate/deactivate the tasks.

By default, the following scheduled tasks are displayed in Scheduler:

· Log maintenance

· Regular automatic update

· Automatic update after dial-up connection

· Automatic update after user logon

· Automatic startup file check (after user logon)

· Automatic startup file check (after successful module update)

To edit the configuration of an existing scheduled task (both default and user-defined), right-click the task and click
Edit... or select the task you wish to modify and click the Edit button.

Add a new task

1. Click Add task at the bottom of the window.
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2. Enter a name of the task.

3. Select the desired task from the pull-down menu:

· Run external application – Schedules the execution of an external application.

· Log maintenance –  Log files also contains leftovers from deleted records. This task optimizes records in log files
on a regular basis to work effectively.

· System startup file check – Checks files that are allowed to run at system startup or logon.

· Create a computer scan – Creates an ESET SysInspector computer snapshot – gathers detailed information about
system components (for example, drivers, applications) and assesses the risk level of each component.

· On-demand computer scan – Performs a computer scan of files and folders on your computer.

· Update – Schedules an Update task by updating the detection engine and program modules.

4. Turn on the Enabled switch if you want to activate the task (you can do this later by selecting/deselecting
checkbox in the list of scheduled tasks), click Next and select one of the timing options:

· Once – The task will be performed at the predefined date and time.

· Repeatedly – The task will be performed at the specified time interval.

· Daily – The task will run repeatedly each day at the specified time.

· Weekly – The task will be run on the selected day and time.

· Event triggered – The task will be performed on a specified event.

5. Select Skip task when running on battery power to minimize system resources while a laptop is running on
battery power. The task will be run on the specified date and time in Task execution fields. If the task could not
be run at the predefined time, you can specify when it will be performed again:

· At the next scheduled time

· As soon as possible

· Immediately, if the time since the last run exceeds a specified value (the interval can be defined using the
Time since last run scroll box)

You can review scheduled task when right click and click Show task details.
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3.9.6.4   Protection statistics

To view a graph of statistical data related to ESET Endpoint Security's protection modules, click Tools > Protection
statistics. Select the desired protection module from the Statistics drop-down menu to see the corresponding graph
and legend. If you mouse over an item in the legend, only the data for that item will display in the graph.

The following statistic graphs are available:

· Antivirus and Antispyware protection – Displays the number of infected and cleaned objects.

· File system protection – Only displays objects that were read or written to the file system.

· Email client protection – Only displays objects that were sent or received by email clients.

· Web access and Anti-Phishing protection – Only displays objects downloaded by web browsers.

· Email client antispam protection – Displays the history of antispam statistics since the last startup.

Next to the statistics graphs, you can see the number of all scanned objects, number of infected objects, number of
cleaned objects and the number of clean objects. Click Reset to clear statistics information or click Reset all to clear
and remove all the existing data.

3.9.6.5   Watch activity

To see the current File system activity in graph form, click Tools > Watch activity. At the bottom of the graph is a
timeline that records file system activity in real-time based on the selected time span. To change the time span,
select from Refresh rate drop-down menu.

The following options are available:

· Step: 1 second – The graph refreshes every second and the timeline covers the last 10 minutes.

· Step: 1 minute (last 24 hours) – The graph is refreshed every minute and the timeline covers the last 24 hours.

· Step: 1 hour (last month) – The graph is refreshed every hour and the timeline covers the last month.

· Step: 1 hour (selected month) – The graph is refreshed every hour and the timeline covers the last X selected
months.
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The vertical axis of the File system activity graph represents the amount of read data (blue) and the amount of
written data (red). Both values are given in kB (kilobytes)/MB/GB. If you mouse over either read data or written data
in the legend below the graph, the graph will only display data for that activity type.

You can also select Network activity from the drop-down menu. The graph display and options for File system
activity and Network activity are the same except that the latter displays the amount of received data (blue) and
amount of sent data (red).

3.9.6.6   ESET SysInspector

ESET SysInspector is an application that thoroughly inspects your computer and gathers detailed information about
system components such as drivers and applications, network connections or important registry entries and
assesses the risk level of each component. This information can help determine the cause of suspicious system
behavior that may be due to software or hardware incompatibility or malware infection.

The SysInspector window displays the following information about created logs:

· Time – The time of log creation.

· Comment – A short comment.

· User – The name of the user who created the log.

· Status – The status of log creation.

The following actions are available:

· Open – Opens created log. You can also right-click a given log file and select Show from the context menu.

· Compare – Compares two existing logs.

· Create... – Creates a new log. Please wait until ESET SysInspector is finished (log status will display as Created)
before attempting to access the log.

· Delete – Removes the selected log(s) from the list.

The following items are available from the context menu when one or more log files are selected:

· Show – Opens the selected log in ESET SysInspector (same function as double-clicking a log).

· Compare – Compares two existing logs.

· Create... – Creates a new log. Please wait until ESET SysInspector is finished (log status will display as Created)
before attempting to access the log.

· Delete all – Deletes all logs.

· Export... – Exports the log to an .xml file or zipped .xml.

3.9.6.7   ESET LiveGrid®

ESET LiveGrid® is an advanced early warning system comprised of several cloud-based technologies. It helps detect
emerging threats based on reputation and improves scanning performance by means of whitelisting. New threat
information is streamed in real-time to the cloud, which enables the ESET Malware Research Lab to provide timely
response and consistent protection at all times. Users can check the reputation of running processes and files
directly from the program's interface or contextual menu with additional information available from ESET LiveGrid®.
When installing ESET Endpoint Security, select one of the following options:

1. You can decide not to enable ESET LiveGrid®. Your software will not lose any functionality, but in some cases
ESET Endpoint Security may respond slower to new threats than detection engine update.

2. You can configure ESET LiveGrid® to submit anonymous information about new threats and where the new
threatening code was detected. This file can be sent to ESET for detailed analysis. Studying these threats will
help ESET update its threat detection capabilities.

ESET LiveGrid® will collect information about your computer related to newly-detected threats. This information
may include a sample or copy of the file in which the threat appeared, the path to that file, the filename, the date
and time, the process by which the threat appeared on your computer and information about your computer‘s
operating system.
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By default, ESET Endpoint Security is configured to submit suspicious files for detailed analysis to the ESET Virus Lab.
Files with certain extensions such as .doc or .xls are always excluded. You can also add other extensions if there are
particular files that you or your organization want to avoid sending.

The ESET LiveGrid® reputation system provides cloud-based whitelisting and blacklisting. To access settings for ESET
LiveGrid®, press F5 to enter Advanced setup and expand Tools > ESET LiveGrid®.

Enable ESET LiveGrid® reputation system (recommended) – The ESET LiveGrid® reputation system improves the
efficiency of ESET anti-malware solutions by comparing scanned files to a database of whitelisted and blacklisted
items in the cloud.

Enable ESET LiveGrid® feedback system – Data will be sent to the ESET Research Lab for further analysis.

Submit crash reports and diagnostics data – Submit data such as crash reports, modules memory dumps.

Submit anonymous statistics – Allow ESET to collect information about newly detected threats such as the threat
name, date and time of detection, detection method and associated metadata, product version, and configuration
including information about your system.

Contact email (optional) – Your contact email can be included with any suspicious files and may be used to contact
you if further information is required for analysis. Please note that you will not receive a response from ESET unless
more information is needed.

Submission of samples

Submit infected samples – This will submit all infected samples to ESET for analysis and to improve future detection.
The following options are available:

· All infected samples

· All samples except documents

· Do not submit

Submit suspicious samples

Executables –  Includes files like .exe, .dll, .sys.
Archives –  Includes filetypes like  .zip, .rar, .7z, .arch, .arj, .bzip, .gzip, .ace, .arc, .cab.
Scripts –  Includes filetypes like .bat, .cmd, .hta, .js, .vbs, .ps1.
Other –  Includes filetypes like .jar, .reg, .msi, .sfw, .lnk.
Possible Spam emails – This will allow sending possible spam parts or whole possible spam emails with
attachment to ESET for further analysis. Enabling this option improve Global detection of spam including
improvements to future spam detection for you.

Documents – Include Microsoft Office documents or PDFs with active content.

Exclusions – The Exclusion filter allows you to exclude certain files/folders from submission (for example, it may be
useful to exclude files that may carry confidential information, such as documents or spreadsheets). The files listed
will never be sent to ESET labs for analysis, even if they contain suspicious code. The most common file types are
excluded by default (.doc, etc.). You can add to the list of excluded files if desired.

If you have used ESET LiveGrid® before and have disabled it, there may still be data packages to send. Even after
deactivating, such packages will be sent to ESET. Once all current information is sent, no further packages will be
created.
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3.9.6.8   Running processes

Running processes displays the running programs or processes on your computer and keeps ESET immediately and
continuously informed about new infiltrations. ESET Endpoint Security provides detailed information on running
processes to protect users with ESET LiveGrid® technology enabled.

Reputation – In most cases, ESET Endpoint Security and ESET LiveGrid® technology assign risk levels to objects (files,
processes, registry keys, etc.) using a series of heuristic rules that examine the characteristics of each object and
then weigh their potential for malicious activity. Based on these heuristics, objects are assigned a reputation level
from 9 – Best reputation (green) to 0 – Worst reputation (red).

Process – Image name of the program or process that is currently running on your computer. You can also use the
Windows Task Manager to see all running processes on your computer. You can open Task Manager by right-clicking
an empty area on the taskbar and then clicking Task Manager, or by pressing Ctrl+Shift+Esc on your keyboard.

PID – Is an ID of processes running in Windows operating systems.

Note

Known applications marked green are definitely clean (white-listed) and will be excluded from
scanning, as this will improve the scanning speed of on-demand computer scan or Real-time file
system protection on your computer.

Number of users – The number of users that use a given application. This information is gathered by ESET LiveGrid®
technology.

Time of discovery – Period of time since the application was discovered by ESET LiveGrid® technology.

Note
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When an application is marked as Unknown (orange) security level, it is not necessarily malicious
software. Usually it is just a newer application. If you are not sure about the file, use the submit file
for analysis feature to send the file to the ESET Virus Lab. If the file turns out to be a malicious
application, its detection will be added to one of the upcoming detection engine updates.

Application name – The given name of a program or process.

By clicking a given application at the bottom, the following information will appear at the bottom of the window:

· Path – Location of an application on your computer.

· Size – File size either in kB (kilobytes) or MB (megabytes).

· Description – File characteristics based on the description from the operating system.

· Company – Name of the vendor or application process.

· Version – Information from the application publisher.

· Product – Application name and/or business name.

· Created on – Date and time when an application was created.

· Modified on – Last date and time when an application was modified.

Note

Reputation can also be checked on files that do not act as running programs/processes - mark files
you want to check, right-click on them and from the context menu select Advanced options > Check
File Reputation using ESET LiveGrid®.
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3.9.6.9   Network connections

In the Network connections section, you can see a list of active and pending connections. This helps you control all
applications establishing outgoing connections.

The first line displays the name of the application and its data transfer speed. To see the list of connections made by
the application (and also more detailed information), click +.

Columns

Application/Local IP – Name of application, local IP addresses and communication ports.

Remote IP – IP address and port number of the particular remote computer.

Protocol – Transfer protocol used.

Up-Speed/Down-Speed – The current speed of outgoing and incoming data.

Sent/Received – Amount of data exchanged within the connection.

Show details – Choose this option to display detailed information about the selected connection.

Select an application or IP address in the Network connections screen and right-click on it will show context menu
with following structure:

Resolve host names – If possible, all network addresses are displayed in DNS format, not in the numeral IP
address format.

Show only TCP connections – The list only displays connections which belong to the TCP protocol suite.

Show listening connections – Select this option to only display connections, where no communication is currently
established, but the system has opened a port and is waiting for a connection.

Show connections within the computer – Select this option to only show connections, where the remote side is a
local system – so-called localhost connections.
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Right-click on a connection to see additional options that include:

Deny communication for the connection – Terminates the established communication. This option is available
only after clicking on an active connection.

Refresh speed – Choose the frequency to refresh the active connections.

Refresh now – Reloads the Network connections window.

The following options are available only after clicking on an application or process, not an active connection:

Temporarily deny communication for the process – Rejects current connections for the given application. If a new
connection is established, the firewall uses a predefined rule. A description of the settings can be found in the
Rules and zones section.

Temporarily allow communication for the process – Permits current connections for the given application. If a new
connection is established, the firewall uses a predefined rule. A description of the settings can be found in the
Rules and zones section.

3.9.6.10   Submission of samples for analysis

The sample submission dialog enables you to send a file or a site to ESET for analysis and can be found in Tools >
Submit sample for analysis. If you find a suspiciously behaving file on your computer or suspicious site on the
Internet, you can submit it to the ESET Virus Lab for analysis. If the file turns out to be a malicious application or
website, its detection will be added to an upcoming update.

Alternatively, you can submit the file by email. If you prefer this option, pack the file(s) using WinRAR/ZIP, protect
the archive with the password "infected" and send it to samples@eset.com. Please remember to use a descriptive
subject and enclose as much information about the file as possible (for example, the website you downloaded it
from).

Note

Before submitting a sample to ESET, make sure it meets one or more of the following criteria:

· the file or website is not detected at all

· the file or website is incorrectly detected as a threat

You will not receive a response unless further information is required for analysis.

Select the description from the Reason for submitting the sample drop-down menu that best fits your message:

· Suspicious file

· Suspicious site (a website that is infected by any malware),

· False positive file (file that is detected as an infection but are not infected),

· False positive site

· Other

File/Site – The path to the file or website you intend to submit.

Contact email – This contact email is sent along with suspicious files to ESET and may be used to contact you if
further information is required for analysis. Entering a contact email is optional. You will not get a response from
ESET unless more information is required, since each day our servers receive tens of thousands of files, making it
impossible to reply to all submissions.

mailto:samples@eset.com
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3.9.6.11   Email notifications

ESET Endpoint Security can automatically send notification emails if an event with the selected verbosity level
occurs. Enable Send event notifications by email to activate email notifications.

SMTP server

SMTP server – The SMTP server used for sending notifications (e.g. smtp.provider.com:587, predefined port is 25).

Note

SMTP servers with TLS encryption are supported by ESET Endpoint Security.

Username and password – If the SMTP server requires authentication, these fields should be filled in with a valid
username and password to access the SMTP server.

Sender address – This field specifies the sender address that will be displayed in the header of notification
emails.

Recipient addresses – This field specifies the recipient addresses that will be displayed in the header of
notification emails. Use a semi-collon ";" to separate multiple email addresses.
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From the Minimum verbosity for notifications drop-down menu, you can select the starting severity level of
notifications to be sent.

· Diagnostic – Logs information needed to fine-tune the program and all records above.

· Informative – Records informative messages such as non-standard network events, including successful update
messages, plus all records above.

· Warnings – Records critical errors and warning messages (Antistealth is not running properly or update failed).

· Errors – Errors (document protection not started) and critical errors will be recorded.

· Critical – Logs only critical errors error starting antivirus protection or infected system.

Enable TLS – Enable sending alert and notification messages supported by TLS encryption.

Interval after which new notification emails will be sent (min) – Interval in minutes after which new notifications
will be sent to email. If you set this value to 0, the notifications will be sent immediately.

Sent each notification in a separate email – When enabled, the recipient will receive a new email for each
individual notification. This may result in large number of emails being received in a short period of time.

Message format

Communications between the program and a remote user or system administrator are done via emails or LAN
messages (using the Windows messaging service). The default format of the alert messages and notifications will
be optimal for most situations. In some circumstances, you may need to change the message format of event
messages.

Format of event messages – Format of event messages that are displayed on remote computers.

Format of threat warning messages – Threat alert and notification messages have a predefined default format. We
advise against changing this format. However, in some circumstances (for example, if you have an automated
email processing system), you may need to change the message format.

Charset – Converts an email message to the ANSI character encoding based upon Windows Regional settings (for
example, windows-1250), Unicode (UTF-8), ACSII 7-bit (for example "á" will be changed to "a" and an unknown
symbol to "?") or Japanese (ISO-2022-JP).

Use Quoted-printable encoding – The email message source will be encoded to Quoted-printable (QP) format
which uses ASCII characters and can correctly transmit special national characters by email in 8-bit format (áéíóú).

Keywords (strings separated by % signs) are replaced in the message by the actual information as specified. The
following keywords are available:

· %ComputerName% - Name of the computer where the alert occurred.

· %ProgramName% - Program that generated the alert.

· %TimeStamp% - Date and time of the event.

· %UserName% - Name of the logged user where the alert occurred.

· %InfectedObject% - Name of infected file, message, etc.

· %VirusName% - Identification of the infection.

· %ErrorDescription% - Description of a non-virus event.

· %Scanner% - Module concerned.

· %Action% - Action taken over infiltration.

The keywords %InfectedObject% and %VirusName% are only used in threat warning messages, and %
ErrorDescription% is only used in event messages.
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3.9.6.12   Quarantine

The main function of the quarantine is to safely store infected files. Files should be quarantined if they cannot be
cleaned, if it is not safe or advisable to delete them or if they are being falsely detected by ESET Endpoint Security.

You can choose to quarantine any file. This is advisable if a file behaves suspiciously but is not detected by the
antivirus scanner. Quarantined files can be submitted for analysis to the ESET Virus Lab.

Files stored in the quarantine folder can be viewed in a table that displays the date and time of quarantine, the path
to the original location of the infected file, its size in bytes, reason (for example, object added by user), and number
of threats (for example, if it is an archive containing multiple infiltrations).

Quarantining files

ESET Endpoint Security automatically quarantines deleted files (if you have not disabled this option in the alert
window). If desired, you can quarantine any suspicious file manually by clicking Quarantine. The original file will be
removed from its original location. The context menu can also be used for this purpose; right-click in the Quarantine
window and select Quarantine.

Restoring from Quarantine

Quarantined files can also be restored to their original location. To restore a quarantined file, right-click it in the
Quarantine window and select Restore from the context menu. If a file is marked as a potentially unwanted
application, Restore and exclude from scanning will also be available. The context menu also contains the Restore
to... option, which allows you to restore a file to a location other than the one from which it was deleted.

Deleting from Quarantine – Right-click on a given item and select Delete from Quarantine, or select the item you
want to delete and press Delete on your keyboard. You can also select multiple items and delete them together.

Note
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If the program has quarantined a harmless file by mistake, exclude the file from scanning after
restoring it and send the file to ESET Customer Care.

Submitting a file from the Quarantine

If you have quarantined a suspicious file that was not detected by the program, or if a file was incorrectly detected
as a threat and subsequently quarantined, please send the file to the ESET Virus Lab. To submit a file from
quarantine, right-click the file and select Submit for analysis from the context menu.

3.9.6.13   Time slots

Time slots can be created and then assigned to rules for Device control and Web control. The Time slots setting can
be found in Advanced setup > Tools. This lets you define commonly used time slots (e.g. work time, weekend, etc.)
and reuse them easily without redefining the time ranges for every rule. Time slot is applicable to any relevant type
of rule that supports time-based control.

To create a time slot, complete the following:

1. Click Edit > Add.
2. Type the name and description of the time slot and click Add.
3. Specify the day and start/end time for the time slot or select All day.
4. Click OK to confirm.

A single time slot can be defined with one or more time ranges based on days and times. When the time slot is
created, it will show in the Apply during drop-down menu in the Device control rules editor window or Web control
rules editor window.
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3.9.6.14   Microsoft Windows update

The Windows update feature is an important component of protecting users from malicious software. For this
reason, it is vital that you install Microsoft Windows updates as soon as they become available. ESET Endpoint
Security notifies you about missing updates according to the level you specify. The following levels are available:

· No updates – No system updates will be offered for download.

· Optional updates – Updates marked as low priority and higher will be offered for download.

· Recommended updates – Updates marked as common and higher will be offered for download.

· Important updates – Updates marked as important and higher will be offered for download.

· Critical updates – Only critical updates will be offered for download.

Click OK to save changes. The System updates window will be displayed after status verification with the update
server. Accordingly, the system update information may not be immediately available after saving changes.

3.9.6.15   ESET CMD

This is a feature that enables advanced ecmd commands. It gives you the possibility to export and import settings
using command line (ecmd.exe). Until now, it was possible to export and import settings using GUI only. ESET
Endpoint Security configuration can be exported to .xml file.

When you have enabled ESET CMD, there are two authorization methods available:

· None - no authorization. We do not recommend you this method because it allows import of any unsigned
configuration which is a potential risk.

· Advanced setup password - uses password protection. When importing configuration from an .xml file, this file
must be signed (see singing .xml configuration file further down). This authorization method verifies password
during configuration import to make sure it matches the password specified in Access Setup. If you do not have
access setup enabled, password does not match or .xml configuration file is not signed, configuration will not be
imported.

Once ESET CMD is enabled, you can start using command line for exporting/importing ESET Endpoint Security
configuration. You can do it manually or create a script for the purpose of automation.

Important

To use advanced ecmd commands, you need to run them with administrator privileges, or open
Windows Command Prompt (cmd) using Run as administrator. Otherwise, you'll get Error executing
command. message. Also, when exporting configuration, destination folder must exist.

Note

Advanced ecmd commands can only be run locally. Executing a client task Run command using ERA
will not work.

Example 

Export settings command:
ecmd /getcfg c:\config\settings.xml

Import settings command:
ecmd /setcfg c:\config\settings.xml

Signing .xml configuration file:
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1. Download XmlSignTool from ESET Tools and Utilities download page and extract it. This tool was developed
specifically for signing eset .xml configuration files.

2. Open Windows Command Prompt (cmd) using Run as administrator.

3. Navigate to a location with XmlSignTool.exe.

4. Execute a command to sign .xml configuration file, usage: XmlSignTool <xml_file_path>

5. Enter and Re-enter Advanced Setup Password as asked by the XmlSignTool. Your .xml configuration file is now
signed and can be used for import on another instance of ESET Endpoint Security with ESET CMD using Advanced
setup password authorization method.

Warning

Enabling ESET CMD without an authorization is not recommended, since this will allow the import of
any unsigned configuration. Set the password in Advanced setup > User interface > Access setup to
prevent from unauthorized modification by users.

3.9.7   User interface

The User interface section allows you to configure the behavior of the program's Graphical user interface (GUI).

Using the User Interface elements tool, you can adjust the program's visual appearance and effects used.

To provide maximum security of your security software, you can prevent any unauthorized changes using the Access
setup tool.

By configuring Alerts and notifications, you can change the behavior of detected threat alerts and system
notifications. These can be customized to fit your needs.

If you choose not to display some notifications, they will be displayed in User interface elements > Application
statuses. Here you can check their status or alternatively prevent to display these notifications.

The Context menu integration is displayed after right-clicking on the selected object. Use this tool to integrate the
ESET Endpoint Security control elements into the context menu.

Presentation mode is useful for users, who want to work with an application and not be interrupted by pop-up
windows, scheduled tasks and any components that could load the processor and RAM.

3.9.7.1   User interface elements

User interface configuration options in ESET Endpoint Security allow you to adjust the working environment to fit
your needs. These configuration options are accessible in the User interface > User interface elements branch of the
ESET Endpoint Security Advanced setup tree.

In the User interface elements section, you can adjust the working environment. Use the Start mode drop-down
menu to select from the following Graphical user interface (GUI) start modes:

Full – The complete GUI will be displayed.

Minimal – The GUI is not available, only notifications are displayed to the user.

Manual – No notifications, or alerts will be displayed.

Silent – Neither the GUI, nor notifications and alerts will be displayed. This mode can be useful in situations where
you need to preserve system resources. Silent mode can only be started by the Administrator.

Note

https://www.eset.com/int/download-utilities/
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Once the Minimal GUI start mode is selected and your computer is restarted, notifications will be
displayed but the graphical interface will not. To revert to full graphical user interface mode, run the
GUI  from the Start menu under All Programs > ESET > ESET Endpoint Security as an administrator, or
you can do this via ESET Security Management Center using a policy.

If you want to deactivate the ESET Endpoint Security splash-screen, deselect Show splash-screen at startup.

To have ESET Endpoint Security play a sound when important events occur during a scan, for example when a threat
is discovered or when the scan has finished, select Use sound signal.

Integrate into the context menu – Integrate the ESET Endpoint Security control elements into the context menu.

Statuses

Application statuses – Click Edit button to manage (disable) statuses that are displayed in the Protection status
pane in main menu.

License information

Show license information – When disabled, the license information on Protection status and Help and support
screen will not be displayed.

Show license messages and notifications – When disabled, the notifications and messages will only be
displayed when license expired.

Note

License information settings are applied but not accessible for ESET Endpoint Security activated with
MSP license.
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3.9.7.2   Access setup

In order to provide maximum security for your system, it is essential that ESET Endpoint Security is correctly
configured. Any unqualified change may result in a loss of important data. To avoid unauthorized modifications, the
setup parameters of ESET Endpoint Security can be password protected. Configuration settings for password
protection are located in Advanced setup (F5) under User interface > Access setup. 

Password protect settings – Indicate password settings. Click to open the Password setup window.

To set or change a password to protect setup parameters, click Set.

Require full administrator rights for limited administrator accounts – Leave this option active to prompt the current
user (if he or she does not have administrator rights) to enter the administrator username and password when
modifying certain system parameters (similar to the UAC in Windows Vista). The modifications include disabling
protection modules or turning off the firewall.

For Windows XP only:

Require administrator rights (system without UAC support) – Enable this option to have ESET Endpoint Security
prompt for administrator credentials.
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3.9.7.3   Alerts and notifications

The Alerts and notifications section under User interface allows you to configure how threat alerts and system
notifications (for example, successful update messages) are handled by ESET Endpoint Security. You can also set the
display time and transparency of system tray notifications (this applies only on systems that support system tray
notifications).

Alert windows

Disabling Display alerts will cancel all alert windows, and is only suitable for a limited amount of specific situations.
For most users, we recommend that this option be left in its default setting (enabled).

Desktop notifications

Notifications on the Desktop and balloon tips are informative only, and do not require user interaction. They are
displayed in the notification area at the bottom right corner of the screen. To activate Desktop notifications, select
Display notifications on desktop. Turn the Do not display notifications when running applications in full-screen
mode switch on to suppress all non-interactive notifications. More detailed options, such as notification display
time and window transparency can be modified below.

The Minimum verbosity of events to display drop-down menu allows you to select the severity level of alerts and
notifications to be displayed. The following options are available:

· Diagnostic – Logs information needed to fine-tune the program and all records above.

· Informative – Records informative messages, including successful update messages, plus all records above.

· Warnings – Records critical errors and warning messages.

· Errors – Errors such as "Error downloading file" and critical errors will be recorded.

· Critical – Logs only critical errors (error starting antivirus protection , built-in firewall, etc...).

The last feature in this section allows you to configure the destination of notifications in a multi-user environment.
The On multi-user systems, display notifications on the screen of this user field specifies which user will receive
system and other notifications on systems allowing multiple users to connect at the same time. Normally, this
would be a system or network administrator. This option is especially useful for terminal servers, provided that all
system notifications are sent to the administrator.
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Message boxes

To close pop-up windows automatically after a certain period of time, select Close message boxes automatically. If
they are not closed manually, alert windows are automatically closed after the specified time period elapses.

Confirmation messages – Shows you a list of confirmation messages that you can select to display or not to display.

3.9.7.3.1   Advanced settings conflict error

This error may occur if some component (e.g. HIPS or Firewall) and user create the rules in interactive or learning
mode at the same time.

ImportantWe recommend to change the filtering mode into the default Automatic mode if you

want to create your own rules. Read more about Learning mode.

3.9.7.4   System tray icon

Some of the most important setup options and features are available by right-clicking the system tray icon .

Pause protection – Displays the confirmation dialog box that disables Antivirus and antispyware protection, which
guards against attacks by controlling file, web and email communication.

The Time interval drop-down menu represents the period of time that Antivirus and antispyware protection will be
disabled for.

Pause firewall (allow all traffic) – Switches the firewall to an inactive state. See Network for more information.
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Block all network traffic – Firewall will block all outgoing / incoming network and internet traffic. You can re-enable
it by clicking Stop blocking all network traffic.

Advanced setup – Select this option to enter the Advanced setup tree. You can also access Advanced setup by
pressing the F5 key or navigating to Setup > Advanced setup.

Log files – Log files contain information about all important program events that have occurred and provide an
overview of detected threats.

Hide ESET Endpoint Security – Hide the ESET Endpoint Security window from the screen.

Reset window layout – Resets the ESET Endpoint Security window to its default size and position on the screen.

Check for updates... – Starts updating the program modules to ensure your level of protection against malicious
code.

About – Provides system information, details about the installed version of ESET Endpoint Security and the installed
program modules as well as your license expiration date. Information about your operating system and system
resources can be found at the bottom of the page.

3.9.7.5   Context menu

The context menu is displayed after right-clicking an object (file). The menu lists all of the actions that you can
perform on an object.

It is possible to integrate ESET Endpoint Security control elements into the context menu. Setup option for this
functionality are available in the Advanced setup tree under User Interface > User interface elements.

Integrate into the context menu – Integrate the ESET Endpoint Security control elements into the context menu.

3.10   Advanced user

3.10.1   Profile manager

Profile manager is used in two places within ESET Endpoint Security – in the On-demand computer scan section and
in the Update section.

On-demand computer scan

Your preferred scan parameters can be saved for future scanning. We recommend that you create a different profile
(with various scan targets, scan methods and other parameters) for each regularly used scan.

To create a new profile, open the Advanced setup window (F5) and click Antivirus > On-demand computer scan and
then Edit next to List of profiles. The Update profile drop-down menu that lists existing scan profiles. To help you
create a scan profile to fit your needs, see the ThreatSense engine parameters setup section for a description of
each parameter of the scan setup.

EXAMPLE: Suppose that you want to create your own scan profile and the Smart scan configuration is partially
suitable, but you don’t want to scan runtime packers or potentially unsafe applications and you also want to apply
Strict cleaning. Enter the name of your new profile in the Profile manager window and click Add.  Select your new
profile from the Update profile drop-down menu and adjust the remaining parameters to meet your requirements
and click OK to save your new profile.
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Update

The profile editor in the Update setup section allows users to create new update profiles. Create and use your own
custom profiles (other than the default My profile) only if your computer uses multiple means to connect to update
servers.

For example, a laptop that normally connects to a local server (Mirror) in the local network but downloads updates
directly from ESET update servers when disconnected from the local network (business trip) might use two profiles:
the first one for connecting to the local server; the other one for connecting to ESET servers. Once these profiles are
configured, navigate to Tools > Scheduler and edit the update task parameters. Designate one profile as primary and
the other as secondary.

Update profile – The currently used update profile. To change it, choose a profile from the drop-down menu.

List of profiles – Create new or remove existing update profiles.

3.10.2   Diagnostics

Diagnostics provides application crash dumps of ESET processes (for example, ekrn). If an application crashes, a
dump will be generated. This can help developers debug and fix various ESET Endpoint Security problems. Click the
drop-down menu next to Dump type and select one of three available options:

· Select Disable (default) to disable this feature.

· Mini – Records the smallest set of useful information that may help identify why the application crashed
unexpectedly. This kind of dump file can be useful when space is limited, however because of the limited
information included, errors that were not directly caused by the thread that was running at the time of the
problem may not be discovered by an analysis of this file.

· Full – Records all the contents of system memory when the application stops unexpectedly. A complete
memory dump may contain data from processes that were running when the memory dump was collected.

Enable Network protection advanced logging – Record all network data passing through Firewall in PCAP format in
order to help developers diagnose and fix problems related to Firewall.

Enable Protocol filtering advanced logging – Record all data passing through the Protocol filtering engine in PCAP
format in order to help the developers diagnose and fix the problems related to Protocol filtering.

Enable Update engine advanced logging – Record all events that occur during update process. This can help
developers diagnose and fix problems related to the Update engine.

Enable Web control advanced logging – Record all events that occur in Parental control. This can help developers
diagnose and fix problems related to Parental control.

Enable Licensing advanced  logging – Record all product communication with license server.

Enable Antispam engine advanced logging – Record all events that occur during antispam scanning. This can help
developers to diagnose and fix problems related to ESET Antispam engine.

Enable Operating System advanced logging – Additional information about Operating system such as running
processes, CPU activity, disc operations will be gathered. This can help developers to diagnose and fix problems
related to ESET product running on your operating system (available for Windows 10).

Log files can be found in:
C:\ProgramData\ESET\ESET Security\Diagnostics\ in Windows Vista and later or C:\Documents and Settings\All
Users\... in earlier versions of Windows.

Target directory – Directory where the dump during the crash will be generated.

Open diagnostics folder – Click Open to open this directory in a new Windows explorer window.

Create diagnostic dump – Click Create to create diagnostic dump files in the Target directory.
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3.10.3   Import and export settings

You can import or export your customized ESET Endpoint Security .xml configuration file from the Setup menu.

Importing and exporting of configuration files is useful if you need to backup your current configuration of ESET
Endpoint Security for use at a later time. The export settings option is also convenient for users who want to use
their preferred configuration on multiple systems, they can easily import an .xml file to transfer these settings.

Importing a configuration is very easy. In the main program window click Setup > Import/Export settings, and then
select Import settings. Enter the file name of the configuration file or click the ... button to browse for the
configuration file you want to import.

The steps to export a configuration are very similar. In the main program window, click Setup > Import/Export
settings. Select Export settings and enter the file name of the configuration file (i.e. export.xml). Use the browser to
select a location on your computer to save the configuration file.

Note

You may encounter an error while exporting settings if you do not have enough rights to write the
exported file to specified directory.

3.10.4   Command Line

ESET Endpoint Security's antivirus module can be launched via the command line – manually (with the “ecls”
command) or with a batch (“bat”) file. ESET Command-line scanner usage:

ecls [OPTIONS..] FILES..

The following parameters and switches can be used while running the on-demand scanner from the command line:

Options

/base-dir=FOLDER load modules from FOLDER
/quar-dir=FOLDER quarantine FOLDER
/exclude=MASK exclude files matching MASK from scanning
/subdir scan subfolders (default)
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/no-subdir do not scan subfolders
/max-subdir-level=LEVEL maximum sub-level of folders within folders to scan
/symlink follow symbolic links (default)
/no-symlink skip symbolic links
/ads scan ADS (default)
/no-ads do not scan ADS
/log-file=FILE log output to FILE
/log-rewrite overwrite output file (default – append)
/log-console log output to console (default)
/no-log-console do not log output to console
/log-all also log clean files
/no-log-all do not log clean files (default)
/aind show activity indicator
/auto scan and automatically clean all local disks

Scanner options

/files scan files (default)
/no-files do not scan files
/memory scan memory
/boots scan boot sectors
/no-boots do not scan boot sectors (default)
/arch scan archives (default)
/no-arch do not scan archives
/max-obj-size=SIZE only scan files smaller than SIZE megabytes (default 0 = unlimited)
/max-arch-level=LEVEL maximum sub-level of archives within archives (nested archives) to scan
/scan-timeout=LIMIT scan archives for LIMIT seconds at maximum
/max-arch-size=SIZE only scan the files in an archive if they are smaller than SIZE (default 0 = unlimited)
/max-sfx-size=SIZE only scan the files in a self-extracting archive if they are smaller than SIZE

megabytes (default 0 = unlimited)
/mail scan email files (default)
/no-mail do not scan email files
/mailbox scan mailboxes (default)
/no-mailbox do not scan mailboxes
/sfx scan self-extracting archives (default)
/no-sfx do not scan self-extracting archives
/rtp scan runtime packers (default)
/no-rtp do not scan runtime packers
/unsafe scan for potentially unsafe applications
/no-unsafe do not scan for potentially unsafe applications (default)
/unwanted scan for potentially unwanted applications
/no-unwanted do not scan for potentially unwanted applications (default)
/suspicious scan for suspicious applications (default)
/no-suspicious do not scan for suspicious applications
/pattern use signatures (default)
/no-pattern do not use signatures
/heur enable heuristics (default)
/no-heur disable heuristics
/adv-heur enable Advanced heuristics (default)
/no-adv-heur disable Advanced heuristics
/ext=EXTENSIONS scan only EXTENSIONS delimited by colon
/ext-exclude=EXTENSIONS exclude EXTENSIONS delimited by colon from scanning
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/clean-mode=MODE use cleaning MODE for infected objects

The following options are available:

· none – No automatic cleaning will occur.

· standard (default) – ecls.exe will attempt to automatically clean or delete
infected files.

· strict – ecls.exe will attempt to automatically clean or delete infected files
without user intervention (you will not be prompted before files are deleted).

· rigorous – ecls.exe will delete files without attempting to clean regardless of
what the file is.

· delete – ecls.exe will delete files without attempting to clean, but will refrain
from deleting sensitive files such as Windows system files.

/quarantine copy infected files (if cleaned) to Quarantine
(supplements the action carried out while cleaning)

/no-quarantine do not copy infected files to Quarantine

General options

/help show help and quit
/version show version information and quit
/preserve-time preserve last access timestamp

Exit codes

0 no threat found
 1 threat found and cleaned
 10 some files could not be scanned (may be threats)
 50 threat found
 100 error

Note

Exit codes greater than 100 mean that the file was not scanned and thus can be infected.

3.10.5   Idle-state detection

Idle state detection settings can be configured in Advanced setup under Antivirus > Idle-state scanning > Idle state
detection. These settings specify a trigger for Idle-state scanning, when:

· the screen saver is running,

· the computer is locked,

· a user logs off.

Use the switches for each respective state to enable or disable the different idle state detection triggers.
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3.10.6   ESET SysInspector

3.10.6.1   Introduction to ESET SysInspector

ESET SysInspector is an application that thoroughly inspects your computer and displays gathered data in a
comprehensive way. Information like installed drivers and applications, network connections or important registry
entries can help you to investigate suspicious system behavior be it due to software or hardware incompatibility or
malware infection.

You can access ESET SysInspector two ways: From the integrated version in ESET Security solutions or by
downloading the standalone version (SysInspector.exe) for free from ESET’s website. Both versions are identical in
function and have the same program controls. The only difference is how outputs are managed. The standalone and
integrated versions each allow you to export system snapshots to an .xml file and save them to disk. However, the
integrated version also allows you to store your system snapshots directly in Tools > ESET SysInspector (except ESET
Security Management Center). For more information see section ESET SysInspector as part of ESET Endpoint
Security.

Please allow some time while ESET SysInspector scans your computer. It may take anywhere from 10 seconds up to a
few minutes depending on your hardware configuration, operating system and the number of applications installed
on your computer.

3.10.6.1.1   Starting ESET SysInspector

To start ESET SysInspector, simply run the SysInspector.exe executable you downloaded from ESET's website. If you
already have one of the ESET Security solutions installed, you can run ESET SysInspector directly from the Start Menu
(click Programs > ESET > ESET Endpoint Security).

Please wait while the application inspects your system, which could take up to several minutes.
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3.10.6.2   User Interface and application usage

For clarity the main program window is divided into four major sections – Program Controls located on the top of the
main program window, Navigation window to the left, the Description window to the right and the Details window
at the bottom of the main program window. The Log Status section lists the basic parameters of a log (filter used,
filter type, is the log a result of a comparison etc.).

3.10.6.2.1   Program Controls

This section contains the description of all program controls available in ESET SysInspector.

File

By clicking File you can store your current system status for later investigation or open a previously stored log. For
publishing purposes we recommend that you generate a log Suitable for sending. In this form, the log omits
sensitive information (current user name, computer name, domain name, current user privileges, environment
variables, etc.).

 NOTE
You may open previously stored ESET SysInspector reports by dragging and dropping them into the main program
window. This functionality is not available in Windows Vista operating system for security reasons.

Tree

Enables you to expand or close all nodes and export selected sections to Service script.

List

Contains functions for easier navigation within the program and various other functions like finding information
online.
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Help

Contains information about the application and its functions.

Detail

This setting influences the information displayed in the main program window to make the information easier to
work with. In "Basic" mode, you have access to information used to find solutions for common problems in your
system. In the "Medium" mode, the program displays less used details. In "Full" mode, ESET SysInspector displays
all the information needed to solve very specific problems.

Filtering

Item filtering is best used to find suspicious files or registry entries in your system. By adjusting the slider, you can
filter items by their Risk Level. If the slider is set all the way to the left (Risk Level 1), then all items are displayed. By
moving the slider to the right, the program filters out all items less risky than current risk level and only display
items which are more suspicious than the displayed level. With the slider all the way to the right, the program
displays only known harmful items.

All items labeled as risk 6 to 9 can pose a security risk. If you are not using a security solution from ESET, we
recommend that you scan your system with ESET Online Scanner if ESET SysInspector has found any such item. ESET
Online Scanner is a free service.

 NOTE
The Risk level of an item can be quickly determined by comparing the color of the item with the color on the Risk
Level slider.

Compare

When comparing two logs, you can choose to display all items, display only added items, display only removed
items or to display only replaced items.

Find

Search can be used to quickly find a specific item by its name or part of its name. The results of the search request
are displayed in the Description window.

Return

By clicking the back or forward arrows, you can return to previously displayed information in the Description
window. You can use the backspace and space keys instead of clicking back and forward.

Status section

Displays the current node in Navigation window.

 IMPORTANT
Items highlighted in red are unknown, which is why the program marks them as potentially dangerous. If an item
is in red, it does not automatically mean that you can delete the file. Before deleting, please make sure that files
are really dangerous or unnecessary.

http://go.eset.eu/onlinescanner?lng=1033
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3.10.6.2.2   Navigating in ESET SysInspector

ESET SysInspector divides various types of information into several basic sections called nodes. If available, you may
find additional details by expanding each node into its subnodes. To open or collapse a node, double-click the name
of the node or click  or  next to the name of the node. As you browse through the tree structure of nodes and
subnodes in the Navigation window you may find various details for each node shown in the Description window. If
you browse through items in the Description window, additional details for each item may be displayed in the
Details window.

The following are the descriptions of the main nodes in the Navigation window and related information in the
Description and Details windows.

Running processes

This node contains information about applications and processes running at the time of generating the log. In the
Description window you may find additional details for each process such as dynamic libraries used by the process
and their location in the system, the name of the application's vendor and the risk level of the file.

The Detail window contains additional information for items selected in the Description window such as the file
size or its hash.

 NOTE
An operating system is comprised of several important kernel components running constantly that provide basic
and vital functions for other user applications. In certain cases, such processes are displayed in the tool ESET
SysInspector with file path beginning with \??\. Those symbols provide pre-launch optimization for those
processes; they are safe for the system.

Network connections

The Description window contains a list of processes and applications communicating over the network using the
protocol selected in the Navigation window (TCP or UDP) along with the remote address where to which the
application is connected to. You can also check the IP addresses of DNS servers.

The Detail window contains additional information for items selected in the Description window such as the file
size or its hash.

Important Registry Entries

Contains a list of selected registry entries which are often related to various problems with your system like those
specifying startup programs, browser helper objects (BHO), etc.

In the Description window you may find which files are related to specific registry entries. You may see additional
details in the Details window.

Services

The Description window Contains a list of files registered as windows Services. You may check the way the service is
set to start along with specific details of the file in the Details window.

Drivers

A list of drivers installed in the system.

Critical files

The Description window displays content of critical files related to the Microsoft windows operating system.

System Scheduler Tasks

Contains a list of tasks triggered by Windows Task Scheduler at a specified time/interval.
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System information

Contains detailed information about hardware and software along with information about set environmental
variables,  user rights and system event logs.

File details

A list of important system files and files in the Program Files folder. Additional information specific for the files can
be found in the Description and Details windows.

About

Information about version of ESET SysInspector and the list of program modules.

3.10.6.2.2.1   Keyboard shortcuts

Key shortcuts that can be used when working with the ESET SysInspector include:

File

Ctrl+O opens existing log
Ctrl+S saves created logs

Generate

Ctrl+G generates a standard computer status snapshot
Ctrl+H generates a computer status snapshot that may also log sensitive information

Item Filtering

1, O fine, risk level 1-9 items are displayed
2 fine, risk level 2-9 items are displayed
3 fine, risk level 3-9 items are displayed
4, U unknown, risk level 4-9 items are displayed
5 unknown, risk level 5-9 items are displayed
6 unknown, risk level 6-9 items are displayed
7, B risky, risk level 7-9 items are displayed
8 risky, risk level 8-9 items are displayed
9 risky, risk level 9 items are displayed
- decreases risk level
+ increases risk level
Ctrl+9 filtering mode, equal level or higher
Ctrl+0 filtering mode, equal level only

View

Ctrl+5 view by vendor, all vendors
Ctrl+6 view by vendor, only Microsoft
Ctrl+7 view by vendor, all other vendors
Ctrl+3 displays full detail
Ctrl+2 displays medium detail
Ctrl+1 basic display
BackSpace moves one step back
Space moves one step forward
Ctrl+W expands tree
Ctrl+Q collapses tree

Other controls

Ctrl+T goes to the original location of item after selecting in search results
Ctrl+P displays basic information about an item
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Ctrl+A displays full information about an item
Ctrl+C copies the current item's tree
Ctrl+X copies items
Ctrl+B finds information about selected files on the Internet
Ctrl+L opens the folder where the selected file is located
Ctrl+R opens the corresponding entry in the registry editor
Ctrl+Z copies a path to a file (if the item is related to a file)
Ctrl+F switches to the search field
Ctrl+D closes search results
Ctrl+E run service script

Comparing

Ctrl+Alt+O opens original / comparative log
Ctrl+Alt+R cancels comparison
Ctrl+Alt+1 displays all items
Ctrl+Alt+2 displays only added items, log will show items present in current log
Ctrl+Alt+3 displays only removed items, log will show items present in previous log
Ctrl+Alt+4 displays only replaced items (files inclusive)
Ctrl+Alt+5 displays only differences between logs
Ctrl+Alt+C displays comparison
Ctrl+Alt+N displays current log
Ctrl+Alt+P opens previous log

Miscellaneous

F1 view help
Alt+F4 close program
Alt+Shift+F4 close program without asking
Ctrl+I log statistics

3.10.6.2.3   Compare

The Compare feature allows the user to compare two existing logs. The outcome of this feature is a set of items not
common to both logs. It is suitable if you want to keep track of changes in the system, a helpful tool for detecting
malicious code.

After it is launched, the application creates a new log which is displayed in a new window. Click File > Save log to
save a log to a file. Log files can be opened and viewed at a later time. To open an existing log, click File > Open log.
In the main program window, ESET SysInspector always displays one log at a time.

The benefit of comparing two logs is that you can view a currently active log and a log saved in a file. To compare
logs, click File > Compare log and choose Select file. The selected log will be compared to the active one in the main
program windows. The comparative log will display only the differences between those two logs.

 NOTE
If you compare two log files, click File > Save log to save it as a ZIP file; both files will be saved. If you open this
file later, the contained logs are automatically compared.

Next to the displayed items, ESET SysInspector shows symbols identifying differences between the compared logs.
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Description of all symbols that can be displayed next to items:

·  new value, not present in the previous log

·  tree structure section contains new values

·  removed value, present in the previous log only

·  tree structure section contains removed values

·  value / file has been changed

·  tree structure section contains modified values / files

·  the risk level has decreased / it was higher in the previous log

·  the risk level has increased / it was lower in the previous log

The explanation section displayed in the left bottom corner describes all symbols and also displays the names of
logs which are being compared.

Any comparative log can be saved to a file and opened at a later time.

Example

Generate and save a log, recording original information about the system, to a file named previous.xml. After
changes to the system have been made, open ESET SysInspector and allow it to generate a new log. Save it to a file
named current.xml.

In order to track changes between those two logs, click File > Compare logs. The program will create a comparative
log showing differences between the logs.

The same result can be achieved if you use the following command line option: 

SysIsnpector.exe current.xml previous.xml

3.10.6.3   Command line parameters

ESET SysInspector supports generating reports from the command line using these parameters:

/gen generate log directly from the command line without running GUI
/privacy generate log with sensitive information omitted
/zip save outcome log in compressed zip archive
/silent suppress progress window when generating log from the command line
/blank launch ESET SysInspector without generating/loading log

Examples

Usage:
Sysinspector.exe [load.xml] [/gen=save.xml] [/privacy] [/zip] [compareto.xml]

To load specific log directly into the browser, use: SysInspector.exe .\clientlog.xml
To generate log from the command line, use: SysInspector.exe /gen=.\mynewlog.xml
To generate log excluding sensitive information directly in a compressed file, use: SysInspector.exe /gen=.
\mynewlog.zip /privacy /zip

To compare two log files and browse differences, use: SysInspector.exe new.xml old.xml
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 NOTE
If the name of the file/folder contains a gap, then should be taken into inverted commas.

3.10.6.4   Service Script

Service script is a tool that provides help to customers that use ESET SysInspector by easily removing unwanted
objects from the system.

Service script enables the user to export the entire ESET SysInspector log, or its selected parts. After exporting, you
can mark unwanted objects for deletion. You can then run the modified log to delete marked objects.

Service Script is suited for advanced users with previous experience in diagnosing system issues. Unqualified
modifications may lead to operating system damage.

Example

If you suspect that your computer is infected by a virus which is not detected by your antivirus program, follow the
step-by-step instructions below:

1. Run ESET SysInspector to generate a new system snapshot.
2. Select the first item in the section on the left (in the tree structure), press Shift and select the last item to

mark all items.
3. Right click the selected objects and select Export Selected Sections To Service Script.
4. The selected objects will be exported to a new log.
5. This is the most crucial step of the entire procedure: open the new log and change the – attribute to + for all

objects you want to remove. Please make sure you do not mark any important operating system files/objects.
6. Open ESET SysInspector, click File > Run Service Script and enter the path to your script.
7. Click OK to run the script.

3.10.6.4.1   Generating Service script

To generate a script, right-click any item from the menu tree (in the left pane) in the ESET SysInspector main
window. From the context menu, select either Export All Sections To Service Script or Export Selected Sections To
Service Script.

 NOTE
It is not possible to export the service script when two logs are being compared.

3.10.6.4.2   Structure of the Service script

In the first line of the script’s header, you can find information about the Engine version (ev), GUI version (gv) and
the Log version (lv). You can use this data to track possible changes in the .xml file that generates the script and
prevent any inconsistencies during execution. This part of the script should not be altered.

The remainder of the file is divided into sections in which items can be edited (denote those that will be processed
by the script). You mark items for processing by replacing the “-” character in front of an item with a “+” character.
Sections in the script are separated from each other by an empty line. Each section has a number and title.

01) Running processes

This section contains a list of all processes running in the system. Each process is identified by its UNC path and,
subsequently, its CRC16 hash code in asterisks (*).
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Example:

01) Running processes:
- \SystemRoot\System32\smss.exe *4725*
- C:\Windows\system32\svchost.exe *FD08*
+ C:\Windows\system32\module32.exe *CF8A*
[...]

In this example a process, module32.exe, was selected (marked by a “+” character); the process will end upon
execution of the script.

02) Loaded modules

This section lists currently used system modules.

Example:

02) Loaded modules:
- c:\windows\system32\svchost.exe
- c:\windows\system32\kernel32.dll
+ c:\windows\system32\khbekhb.dll
- c:\windows\system32\advapi32.dll
[...]

In this example the module khbekhb.dll was marked by a “+”. When the script runs, it will recognize the processes
using that specific module and end them. 

03) TCP connections

This section contains information about existing TCP connections.

Example:

03) TCP connections:
- Active connection: 127.0.0.1:30606 -> 127.0.0.1:55320, owner: ekrn.exe
- Active connection: 127.0.0.1:50007 -> 127.0.0.1:50006,
- Active connection: 127.0.0.1:55320 -> 127.0.0.1:30606, owner: OUTLOOK.EXE
- Listening on *, port 135 (epmap), owner: svchost.exe
+ Listening on *, port 2401, owner: fservice.exe Listening on *, port 445
(microsoft-ds), owner: System
[...]

When the script runs, it will locate the owner of the socket in the marked TCP connections and stop the socket,
freeing system resources.

04) UDP endpoints

This section contains information about existing UDP endpoints.

Example:

04) UDP endpoints:
- 0.0.0.0, port 123 (ntp)
+ 0.0.0.0, port 3702
- 0.0.0.0, port 4500 (ipsec-msft)
- 0.0.0.0, port 500 (isakmp)
[...]

When the script runs, it will isolate the owner of the socket at the marked UDP endpoints and stop the socket.

05) DNS server entries

This section contains information about the current DNS server configuration.
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Example:

05) DNS server entries:
+ 204.74.105.85
- 172.16.152.2
[...]

Marked DNS server entries will be removed when you run the script.

06) Important registry entries

This section contains information about important registry entries.

Example:

06) Important registry entries:
* Category: Standard Autostart (3 items)
 HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
- HotKeysCmds = C:\Windows\system32\hkcmd.exe
- IgfxTray = C:\Windows\system32\igfxtray.exe
 HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
- Google Update = “C:
\Users\antoniak\AppData\Local\Google\Update\GoogleUpdate.exe” /c
* Category: Internet Explorer (7 items)
 HKLM\Software\Microsoft\Internet Explorer\Main
+ Default_Page_URL = http://thatcrack.com/
[...]

The marked entries will be deleted, reduced to 0-byte values or reset to their default values upon script execution.
The action to be applied to a particular entry depends on the entry category and key value in the specific registry.

07) Services

This section lists services registered within the system.

Example:

07) Services:
- Name: Andrea ADI Filters Service, exe path: c:\windows\system32\aeadisrv.exe,
state: Running, startup: Automatic
- Name: Application Experience Service, exe path: c:
\windows\system32\aelupsvc.dll, state: Running, startup: Automatic
- Name: Application Layer Gateway Service, exe path: c:
\windows\system32\alg.exe, state: Stopped, startup: Manual
[...]

The services marked and their dependent services will be stopped and uninstalled when the script is executed.

08) Drivers

This section lists installed drivers.

Example:

08) Drivers:
- Name: Microsoft ACPI Driver, exe path: c:\windows\system32\drivers\acpi.sys,
state: Running, startup: Boot
- Name: ADI UAA Function Driver for High Definition Audio Service, exe path: c:
\windows\system32\drivers\adihdaud.sys, state: Running, startup: Manual
[...]

When you execute the script, the drivers selected will be stopped. Note that some drivers won't allow themselves
to be stopped.
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09) Critical files

This section contains information about files that are critical to proper function of the operating system.

Example:

09) Critical files:
* File: win.ini
- [fonts]
- [extensions]
- [files]
- MAPI=1
[...]
* File: system.ini
- [386Enh]
- woafont=dosapp.fon
- EGA80WOA.FON=EGA80WOA.FON
[...]
* File: hosts
- 127.0.0.1 localhost
- ::1 localhost
[...]

The selected items will either be deleted or reset to their original values.

3.10.6.4.3   Executing Service scripts

Mark all desired items, then save and close the script. Run the edited script directly from the ESET SysInspector main
window by selecting the Run Service Script option from the File menu. When you open a script, the program will
prompt you with the following message: Are you sure you want to run the service script “%Scriptname%”? After you
confirm your selection, another warning may appear, informing you that the service script you are trying to run has
not been signed. Click Run to start the script.

A dialog window will confirm that the script was successfully executed.

If the script could only be partially processed, a dialog window with the following message will appear: The service
script was run partially. Do you want to view the error report? Select Yes to view a complex error report listing the
operations that were not executed.

If the script was not recognized, a dialog window with the following message will appear: The selected service script
is not signed. Running unsigned and unknown scripts may seriously harm your computer data. Are you sure you
want to run the script and carry out the actions? This may be caused by inconsistencies within the script (damaged
heading, corrupted section title, empty line missing between sections etc.). You can either reopen the script file
and correct the errors within the script or create a new service script.

3.10.6.5   FAQ

Does ESET SysInspector require Administrator privileges to run?

While ESET SysInspector does not require Administrator privileges to run, some of the information it collects can
only be accessed from an Administrator account. Running it as a Standard User or a Restricted User will result in it
collecting less information about your operating environment.

Does ESET SysInspector create a log file?

ESET SysInspector can create a log file of your computer's configuration. To save one, click File > Save Log in the main
program window. Logs are saved in XML format. By default, files are saved to the %USERPROFILE%\My Documents\
directory, with a file naming convention of "SysInpsector-%COMPUTERNAME%-YYMMDD-HHMM.XML". You may
change the location and name of the log file to something else before saving if you prefer.
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How do I view the ESET SysInspector log file?

To view a log file created by ESET SysInspector, run the program and click File > Open Log in the main program
window. You can also drag and drop log files onto the ESET SysInspector application. If you need to frequently view
ESET SysInspector log files, we recommend creating a shortcut to the SYSINSPECTOR.EXE file on your Desktop; you
can then drag and drop log files onto it for viewing. For security reasons Windows Vista/7 may not allow drag and
drop between windows that have different security permissions.

Is a specification available for the log file format? What about an SDK?

At the current time, neither a specification for the log file or an SDK are available since the program is still in
development. After the program has been released, we may provide these based on customer feedback and
demand.

How does ESET SysInspector evaluate the risk posed by a particular object?

In most cases, ESET SysInspector assigns risk levels to objects (files, processes, registry keys and so forth) using a
series of heuristic rules that examine the characteristics of each object and then weight the potential for malicious
activity. Based on these heuristics, objects are assigned a risk level from 1 - Fine (green) to 9 - Risky (red). In the left
navigation pane, sections are colored based on the highest risk level of an object inside them.

Does a risk level of "6 - Unknown (red)" mean an object is dangerous?

ESET SysInspector's assessments do not guarantee that an object is malicious – that determination should be made
by a security expert. What ESET SysInspector is designed for is to provide a quick assessment for security experts so
that they know what objects on a system they may want to further examine for unusual behavior.

Why does ESET SysInspector connect to the Internet when run?

Like many applications, ESET SysInspector is signed with a digital signature "certificate" to help ensure the software
was published by ESET and has not been altered. In order to verify the certificate, the operating system contacts a
certificate authority to verify the identity of the software publisher. This is normal behavior for all digitally-signed
programs under Microsoft Windows.

What is Anti-Stealth technology?

Anti-Stealth technology provides effective rootkit detection.

If the system is attacked by malicious code that behaves as a rootkit, the user may be exposed to data loss or theft.
Without a special anti-rootkit tool, it is almost impossible to detect rootkits.

Why are there sometimes files marked as "Signed by MS", having a different "Company Name" entry
at the same time?

When trying to identify the digital signature of an executable, ESET SysInspector first checks for a digital signature
embedded in the file. If a digital signature is found, the file will be validated using that information. If a digital
signature is not found, the ESI starts looking for the corresponding CAT file (Security Catalog - %systemroot%
\system32\catroot) that contains information about the executable file processed. If the relevant CAT file is found,
the digital signature of that CAT file will be applied in the validation process of the executable.

This is why there are sometimes files marked as "Signed by MS", but having a different "CompanyName" entry.
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3.10.6.6   ESET SysInspector as part of ESET Endpoint Security

To open the ESET SysInspector section in ESET Endpoint Security, click Tools > ESET SysInspector. The management
system in the ESET SysInspector window is similar to that of computer scan logs, or scheduled tasks. All operations
with system snapshots – create, view, compare, remove and export – are accessible within one or two clicks.

The ESET SysInspector window contains basic information about the created snapshots such as create time, a short
comment, name of the user that created the snapshot and snapshot status.

To compare, create, or delete snapshots, use the corresponding buttons located below the list of snapshots in the
ESET SysInspector window. Those options are also available from the context menu. To view the selected system
snapshot, select Show from the context menu. To export the selected snapshot to a file, right-click it and select
Export....

Below is a detailed description of the available options:

· Compare – Allows you to compare two existing logs. It is suitable if you want to track changes between the
current log and an older log. For this option to take effect, you must select two snapshots to be compared.

· Create... – Creates a new record. Before that, you must enter a short comment about the record. To find out
the snapshot creation progress (of the currently generated snapshot), see the Status column. All completed
snapshots are marked by the Created status.

· Delete/Delete all – Removes entries from the list.

· Export... – Saves the selected entry in an XML file (also in a zipped version).

3.10.7   Remote monitoring and management

Remote Monitoring and Management (RMM) is the process of supervising and controlling software systems using a
locally installed agent that can be accessed by a management service provider. The default ESET Endpoint Security 
installation contains the file ermm.exe located in the Endpoint application within the directory c:\Program
Files\ESET\ESET Security. ermm.exe is a command line utility designed to facilitate the management of endpoint
products and communications with any RMM Plugin. ermm.exe exchanges data with the RMM Plugin, which
communicates with the RMM Agent linked to an RMM Server. By default, the ESET RMM tool is disabled. For more
information, see How to activate Remote monitoring and management.

The default ESET Endpoint Security installation contains file ermm.exe located in the Endpoint application directory
(default path c:\Program Files\ESET\ESET Security ). ermm.exe exchanges data with the RMM Plugin, which
communicates with the RMM Agent that is linked to an RMM Server.

· ermm.exe – command line utility developed by ESET that allows managing of Endpoint products and
communication with any RMM Plugin.
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3.10.7.1   RMM Command Line

Remote monitoring management is run using the command line interface. The default ESET Endpoint Security
installation contains the file ermm.exe located in the Endpoint application within the directory c:\Program
Files\ESET\ESET Security. 

Run the Command Prompt (cmd.exe) as an Administrator and navigate to the mentioned path. (To open Command
Prompt, press Windows button + R on your keyboard, type a cmd.exe into the Run window and press Enter.)

The command syntax is: ermm context command [options] 

Also note that the log parameters are case sensitive.

ermm.exe uses three basic contexts: Get, Start and Set. In the table below you can find examples of commands
syntax. Click the link in the Command column to see the further options, parameters, and usage examples. After
successful execution of command, the output part (result) will be displayed. To see an input part, add parameter --
debug at the of the command.
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Context Command Description

get Get information about products

application-info Get information about product

license-info Get information about license

protection-status Get protection status

logs Get logs

scan-info Get information about running scan

configuration Get product configuration

update-status Get information about update

activation-status Get information about last activation

start Start task

scan Start on demand scan

activation Start activation of product

deactivation Start deactivation of product

update Start update of product

set Set options for product

configuration Set configuration to product

In the output result of every command, the first information displayed is result ID. To understand better the result
information, check the table of IDs below.

Error ID Error Description

0 Success

1 Command node not present "Command" node not present in input
json

2 Command not supported Particular command is not supported

3 General error executing the command Error during execution of command

4 Task already running Requested task is already running and
has not been started

5 Invalid parameter for command Bad user input

6 Command not executed because it's
disabled

RMM isn't enabled in advanced
settings or isn't started as an
administrator
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3.10.7.2   List of JSON commands

· get protection-status

· get application-info

· get license-info

· get logs 

· get activation-status

· get scan-info

· get configuration

· get update-status

· start scan

· start activation

· start deactivation

· start update

· set configuration

3.10.7.2.1   get protection-status

Get the list of application statuses and the global application status

Command line

ermm.exe get protection-status

Parameters

None

Example

call

{ 

 "command":"get_protection_status", 

 "id":1, 

 "version":"1" 

}

result

{ 

 "id":1, 

 "result":{ 

  "statuses":[{ 

    "id":"EkrnNotActivated", 

    "status":2, 

    "priority":768, 



160

    "description":"Product not activated" 

   }], 

  "status":2, 

  "description":"Security alert" 

 }, 

 "error":null 

}

3.10.7.2.2   get application-info

Get information about the installed application

Command line

ermm.exe get application-info

Parameters

None

Example

call

{ 

 "command":"get_application_info", 

 "id":1, 

 "version":"1" 

}

result

{

  "id":1,

  "result":{

   "description":"ESET Endpoint Antivirus",

   "version":"6.6.2018.0",

   "product":"eea",

   "lang_id":1033,

   "modules":[{

    "id":"SCANNER32",

    "description":"Detection engine",
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    "version":"15117",

    "date":"2017-03-20"

   },{

    "id":"PEGASUS32",

    "description":"Rapid Response module",

    "version":"9734",

    "date":"2017-03-20"

   },{

    "id":"LOADER32",

    "description":"Update module",

    "version":"1009",

    "date":"2016-12-05"

   },{

    "id":"PERSEUS32",

    "description":"Antivirus and antispyware scanner module",

    "version":"1513",

    "date":"2017-03-06"

   },{

    "id":"ADVHEUR32",

    "description":"Advanced heuristics module",

    "version":"1176",

    "date":"2017-01-16"

   },{

    "id":"ARCHIVER32",

    "description":"Archive support module",

    "version":"1261",

    "date":"2017-02-22"

   },{

    "id":"CLEANER32",

    "description":"Cleaner module",

    "version":"1132",

    "date":"2017-03-15"

   },{

    "id":"ANTISTEALTH32",

    "description":"Anti-Stealth support module",

    "version":"1106",

    "date":"2016-10-17"



162

   },{

    "id":"SYSTEMSTATUS32",

    "description":"ESET SysInspector module",

    "version":"1266",

    "date":"2016-12-22"

   },{

    "id":"TRANSLATOR32",

    "description":"Translation support module",

    "version":"1588B",

    "date":"2017-03-01"

   },{

    "id":"HIPS32",

    "description":"HIPS support module",

    "version":"1267",

    "date":"2017-02-16"

   },{

    "id":"PROTOSCAN32",

    "description":"Internet protection module",

    "version":"1300",

    "date":"2017-03-03"

   },{

    "id":"DBLITE32",

    "description":"Database module",

    "version":"1088",

    "date":"2017-01-05"

   },{

    "id":"CONFENG32",

    "description":"Configuration module (33)",

    "version":"1496B",

    "date":"2017-03-17"

   },{

    "id":"IRIS32",

    "description":"LiveGrid communication module",

    "version":"1022",

    "date":"2016-04-01"

   },{

    "id":"SAURON32",
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    "description":"Rootkit detection and cleaning module",

    "version":"1006",

    "date":"2016-07-15"

   },{

    "id":"SSL32",

    "description":"Cryptographic protocol support module",

    "version":"1009",

    "date":"2016-12-02"

   }

  },

  "error":null

 }

}

3.10.7.2.3   get license-info

Get information about the license of the product

Command line

ermm.exe get license-info

Parameters

None

Example

call

{ 

 "command":"get_license_info", 

 "id":1, 

 "version":"1" 

}

result

{ 

 "id":1, 

 "result":{ 

  "type":"NFR", 
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  "expiration_date":"2020-12-31", 

  "expiration_state":"ok", 

  "public_id":"3XX-7ED-7XF", 

  "seat_id":"6f726793-ae95-4e04-8ac3-e6a20bc620bf", 

  "seat_name":"M" 

 }, 

 "error":null 

}

3.10.7.2.4   get logs

Get logs of the product

Command line

ermm.exe get logs --name warnlog --start-date "2017-04-04 06-00-00" --end-date "2017-04-04 12-00-00"

Parameters

Name Value

name { all, virlog, warnlog, scanlog, blocked, hipslog, urllog,
devctrllog } : log to retrieve

start-date start date from which logs should be retrieved (YYYY-
MM-DD [HH-mm-SS])

end-date end time until which logs should be retrieved (YYYY-
MM-DD [HH-mm-SS])

Example

call

{ 

 "command":"get_logs", 

 "id":1, 

 "version":"1", 

 "params":{ 

  "name":"warnlog", 

  "start_date":"2017-04-04 06-00-00", 

  "end_date":"2017-04-04 12-00-00" 

 } 

}
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result

{ 

 "id":1, 

 "result":{ 

  "warnlog":{ 

   "display_name":"Events", 

   "logs":[{ 

    "Time":"2017-04-04 06-05-59", 

    "Severity":"Info", 

    "PluginId":"ESET Kernel", 

    "Code":"Malware database was successfully updated to version 15198 (20170404).", 

    "UserData":"" 

   },{ 

    "Time":"2017-04-04 11-12-59", 

    "Severity":"Info", 

    "PluginId":"ESET Kernel", 

    "Code":"Malware database was successfully updated to version 15199 (20170404).", 

    "UserData":"" 

   }] 

  } 

 }, 

 "error":null 

}

3.10.7.2.5   get activation-status

Get information about the last activation. Result of status can be { success, error }

Command line

ermm.exe get activation-status

Parameters

None

Example

call

{ 
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 "command":"get_activation_status", 

 "id":1, 

 "version":"1" 

}

result

{

 "id":1,

 "result":{

  "status":"success"

 },

 "error":null

}

3.10.7.2.6   get scan-info

Get information about running scan.

Command line

ermm.exe get scan-info

Parameters

None

Example

call

{ 

 "command":"get_scan_info", 

 "id":1, 

 "version":"1" 

}

result

{ 

 "id":1, 

 "result":{ 

  "scan-info":{ 
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 "scans":[{

  "scan_id":65536, 

  "timestamp":272, 

  "state":"finished", 

  "pause_scheduled_allowed":false, 

  "pause_time_remain":0, 

  "start_time":"2017-06-20T12:20:33Z", 

  "elapsed_tickcount":328, 

  "exit_code":0, 

  "progress_filename":"Operating memory", 

  "progress_arch_filename":"", 

  "total_object_count":268, 

  "infected_object_count":0, 

  "cleaned_object_count":0, 

  "log_timestamp":268, 

  "log_count":0, 

  "log_path":"C:\\ProgramData\\ESET\\ESET Security\\Logs\\eScan\\ndl31494.dat", 

  "username":"test-PC\\test", 

  "process_id":3616, 

  "thread_id":3992, 

  "task_type":2 

 }], 

 "pause_scheduled_active":false 

} 

 }, 

 "error":null 

}

3.10.7.2.7   get configuration

Get the product configuration. Result of status may be { success, error }

Command line

ermm.exe get configuration --file C:\tmp\conf.xml --format xml

Parameters

Name Value

file the path where the configuration file will be saved
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format format of configuration: json, xml. Default format is
xml

Example

call

{ 

 "command":"get_configuration", 

 "id":1, 

 "version":"1", 

 "params":{ 

  "format":"xml", 

  "file":"C:\\tmp\\conf.xml" 

 } 

}

result

{ 

 "id":1, 

 "result":{ 

  "configuration":"PD94bWwgdmVyc2lvbj0iMS4w==" 

 }, 

 "error":null 

}

3.10.7.2.8   get update-status

Get information about the update. Result of status may be { success, error }

Command line

ermm.exe get update-status

Parameters

None

Example

call

{ 
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 "command":"get_update_status", 

 "id":1, 

 "version":"1" 

}

result

{ 

 "id":1, 

 "result":{ 

  "last_update_time":"2017-06-20 13-21-37", 

  "last_update_result":"error", 

  "last_successful_update_time":"2017-06-20 11-21-45" 

 }, 

 "error":null 

}

3.10.7.2.9   start scan

Start scan with the product

Command line

ermm.exe start scan --profile "profile name" --target "path"

Parameters

Name Value

profile Profile name of On-demand computer scan defined in
product

target Path to be scanned

Example

call

{ 

 "command":"start_scan", 

 "id":1, 

 "version":"1", 

 "params":{ 
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  "profile":"Smart scan", 

  "target":"c:\\" 

 } 

}

result

{ 

 "id":1, 

 "result":{ 

  "task_id":458752 

 }, 

 "error":null 

}

3.10.7.2.10   start activation

Start activation of product

Command line

ermm.exe start activation --key "activation key" | --offline "path to offline file" | --token "activation token"

Parameters

Name Value

key Activation key

offline Path to offline file

token Activation token

Example

call

{ 

 "command":"start_activation", 

 "id":1, 

 "version":"1", 

 "params":{ 

  "key":"XXXX-XXXX-XXXX-XXXX-XXXX" 

 } 
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}

result

{

 "id":1,

 "result":{

 },

 "error":null

}

3.10.7.2.11   start deactivation

Start deactivation of the product

Command line

ermm.exe start deactivation

Parameters

None

Example

call

{ 

 "command":"start_deactivation", 

 "id":1, 

 "version":"1" 

}

result

{ 

 "id":1, 

 "result":{ 

 }, 

 "error":null 

}
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3.10.7.2.12   start update

Start update of the product. Only one update may be running in the product so in case the update is already running,
"Task already running" error code is returned

Command line

ermm.exe start update

Parameters

None

Example

call

{ 

 "command":"start_update", 

 "id":1, 

 "version":"1" 

}

result

{ 

 "id":1, 

 "result":{ 

 }, 

  "error":{ 

   "id":4, 

   "text":"Task already running." 

  } 

}
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3.10.7.2.13   set configuration

Set configuration to the product. Result of status may be { success, error }

Command line

ermm.exe set configuration --file C:\tmp\conf.xml --format xml --password pass

Parameters

Name Value

file the path where the configuration file will be saved

password password for configuration

value configuration data from the argument (encoded in
base64)

Example

call

{ 

 "command":"set_configuration", 

 "id":1, 

 "version":"1", 

 "params":{ 

  "format":"xml", 

  "file":"C:\\tmp\\conf.xml", 

  "password": "pass" 

 } 

}

result

{ 

 "id":1, 

 "result":{ 

 }, 

 "error":null 

}
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3.11   Glossary

3.11.1   Types of threats

An Infiltration is a piece of malicious software trying to enter and/or damage a user’s computer.

3.11.1.1   Viruses

A computer virus is a piece of malicious code that is pre-pended or appended to existing files on your computer.
Viruses are named after biological viruses because they use similar techniques to spread from one computer to
another. As for the term “virus”, it is often used incorrectly to mean any type of a threat. This usage is gradually
being overcome and replaced with a more accurate term “malware” (malicious software).

Computer viruses mainly attack executable files and documents. In short, this is how a computer virus works: after
execution of an infected file, the malicious code is called and executed prior to the execution of the original
application. A virus can infect any files that the current user has write permissions for.

Computer viruses can range in purpose and severity. Some of them are extremely dangerous because of their ability
to purposely delete files from a hard drive. On the other hand, some viruses do not cause any damage – they only
serve to annoy the user and demonstrate the technical skills of their authors.

If your computer is infected with a virus and cleaning is not possible, submit it to the ESET lab for perusal. In certain
cases infected files can be modified to such an extent that cleaning is not possible and the files must be replaced
with a clean copy.

3.11.1.2   Worms

A computer worm is a program containing malicious code that attacks host computers and spreads via network. The
basic difference between a virus and a worm is that worms have the ability to propagate by themselves; they are
not dependant on host files (or boot sectors). Worms spread to email addresses in your contact list or exploit
security vulnerabilities in network applications.

Worms are therefore much more viable than computer viruses. Due to the wide availability of the Internet, they can
spread across the globe within hours or even minutes after their release. This ability to replicate independently and
rapidly makes them more dangerous than other types of malware.

A worm activated in a system can cause a number of inconveniences: It can delete files, degrade system
performance, or even deactivate programs. The nature of a computer worm qualifies it as a “means of transport“ for
other types of infiltrations.

If your computer is infected with a worm, we recommend you delete the infected files because they likely contain
malicious code.

3.11.1.3   Trojans

Historically, computer Trojans (Trojan horses) have been defined as a class of threats which attempt to present
themselves as useful programs and thus trick users into running them.

Since Trojans are a very broad category, it is often divided into several subcategories:

· Downloader – Malicious programs with the ability to download other threats from the Internet.

· Dropper – Malicious programs with the ability to drop other types of malware onto compromised computers.

· Backdoor – Malicious programs which communicate with remote attackers, allowing them to gain access to

the computer and take control over it.

· Keylogger – (keystroke logger) – A program which records each keystroke that a user types and sends the

information to remote attackers.

· Dialer – Malicious programs designed to connect via premium-rate numbers instead of the user's Internet

service provider. It is almost impossible for a user to notice that a new connection was created. Dialers can
only cause damage to users with dial-up modems, which are no longer regularly used.
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If a file on your computer is detected as a Trojan, it is advisable to delete it, since it most likely contains nothing but
malicious code.

3.11.1.4   Rootkits

Rootkits are malicious programs that grant Internet attackers unlimited access to a system, while concealing their
presence. Rootkits, after accessing a system (usually exploiting a system vulnerability), use functions in the
operating system to avoid detection by antivirus software: they conceal processes, files and Windows registry data.
For this reason, it is almost impossible to detect them using ordinary testing techniques.

There are two levels of detection to prevent rootkits:

1. When they try to access a system: They are still not present, and are therefore inactive. Most antivirus systems
are able to eliminate rootkits at this level (assuming that they actually detect such files as being infected).

2. When they are hidden from the usual testing: ESET Endpoint Security users have the advantage of Anti-Stealth
technology, which is also able to detect and eliminate active rootkits.

3.11.1.5   Adware

Adware is a short for advertising-supported software. Programs displaying advertising material fall under this
category. Adware applications often automatically open a new pop-up window containing advertisements in an
Internet browser, or change the browser’s home page. Adware is frequently bundled with freeware programs,
allowing their creators to cover development costs of their (usually useful) applications.

Adware itself is not dangerous – users will only be bothered with advertisements. Its danger lies in the fact that
adware may also perform tracking functions (as spyware does).

If you decide to use a freeware product, please pay particular attention to the installation program. The installer will
most likely notify you of the installation of an extra adware program. Often you will be allowed to cancel it and
install the program without adware. 

Some programs will not install without adware, or their functionality will be limited. This means that adware may
often access the system in a “legal” way, because users have agreed to it. In this case, it is better to be safe than
sorry.If there is a file detected as adware on your computer, it is advisable to delete it, since there is a high
probability that it contains malicious code.

3.11.1.6   Spyware

This category covers all applications which send private information without user consent/awareness. Spyware uses
tracking functions to send various statistical data such as a list of visited websites, email addresses from the user‘s
contact list, or a list of recorded keystrokes.

The authors of spyware claim that these techniques aim to find out more about users’ needs and interests and allow
better-targeted advertisement. The problem is that there is no clear distinction between useful and malicious
applications and no one can be sure that the retrieved information will not be misused. The data obtained by
spyware applications may contain security codes, PINs, bank account numbers, etc. Spyware is often bundled with
free versions of a program by its author in order to generate revenue or to offer an incentive for purchasing the
software. Often, users are informed of the presence of spyware during a program‘s installation to give them an
incentive to upgrade to a paid version without it.

Examples of well-known freeware products which come bundled with spyware are client applications of P2P (peer-
to-peer) networks. Spyfalcon or Spy Sheriff (and many more) belong to a specific spyware subcategory – they
appear to be antispyware programs, but in fact they are spyware programs themselves.

If a file is detected as spyware on your computer, it is advisable to delete it, since there is a high probability that it
contains malicious code.
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3.11.1.7   Packers

Packer is a runtime self-extracting executable that rolls up several kinds of malware into a single package.

The most common packers are UPX, PE_Compact, PKLite and ASPack. The same malware may be detected
differently when compressed using a different packer. Packers also have the ability to make their "signatures"
mutate over time, making malware more difficult to detect and remove.

3.11.1.8   Potentially unsafe applications

There are many legitimate programs whose function is to simplify the administration of networked computers.
However, in the wrong hands, they may be misused for malicious purposes. ESET Endpoint Security provides the
option to detect such threats.

Potentially unsafe applications is the classification used for commercial, legitimate software. This classification
includes programs such as remote access tools, password-cracking applications, and keyloggers (a program that
records each keystroke a user types).

If you find that there is a potentially unsafe application present and running on your computer (and you did not
install it), please consult your network administrator or remove the application.

3.11.1.9   Potentially unwanted applications

Grayware (or PUA - a Potentially Unwanted Application) is a broad category of software, whose intent is not as
unequivocally malicious as with other types of malware, such as viruses or trojan horses. It may however install
additional unwanted software, change the behavior of the digital device, or perform activities not approved or
expected by the user.

Categories that may be considered grayware include: advertising display software, download wrappers, various
browser toolbars, software with misleading behavior, bundleware, trackware, registry cleaners or any other
borderline software, or software that uses illicit or at least unethical business practices (despite appearing
legitimate) and might be deemed undesirable by an end user who became aware of what the software would do if
allowed to install.

A Potentially Unsafe Application is one that is in itself legitimate (possibly commercial) software but which might
be misused by an attacker. Detection of these types of application can be enabled or disabled by users of ESET
software.

There are some situations where a user may feel that the benefits of a potentially unwanted application outweigh
the risks. For this reason, ESET assigns such applications a lower-risk category compared to other types of malicious
software, such as trojan horses or worms.

Warning - Potentially unwanted application found

When a potentially unwanted application is detected, you can decide which action to take:

1. Clean/Disconnect: This option ends the action and prevents the PUA from entering your system.
2. Ignore: This option allows a PUA to enter your system.
3. To allow the application to run on your computer in the future without interruption, click Advanced options

and then select the check box next to Exclude from detection and click Ignore.
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Potentially unwanted applications - Settings

While installing your ESET product, you can decide whether to enable detection of potentially unwanted
applications, as shown below:

Warning

Potentially unwanted applications may install adware, toolbars, or contain other unwanted and
unsafe program features.

These settings can be modified in your program settings at any time. To enable or disable the detection of
Potentially unwanted, unsafe or suspicious applications, follow these instructions:
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1. Open your ESET product. How do I open my ESET product?
2. Press the F5 key to access Advanced setup.
3. Click Detection engine and enable or disable options Enable detection of potentially unwanted applications,

Enable detection of potentially unsafe applications and Enable detection of suspicious applications according
to your preferences. Confirm by clicking OK.

Potentially unwanted applications - Software wrappers

A software wrapper is a special type of application modification that is used by some file-hosting websites. It is a
third-party tool that installs the program you intended to download but adds additional software, such as toolbars
or adware. The additional software may also make changes to your web browser’s home page and search settings.
Also, file-hosting websites often do not notify the software vendor or download recipient that modifications have
been made, and often hide options to opt out. For these reasons, ESET classifies software wrappers as a type of
potentially unwanted application to allow users to accept the download or not.

Potentially unwanted applications - Registry cleaners

Registry cleaners are programs that may suggest that the Windows registry database requires regular maintenance
or cleaning. Using a registry cleaner might introduce some risks to your computer system. Additionally, some
registry cleaners make unqualified, unverifiable or otherwise unsupportable claims about their benefits and/or
generate misleading reports about a computer system based on the results of a "free scan". These misleading claims
and reports seek to persuade you to purchase a full version or subscription, usually without allowing you to
evaluate the registry cleaner before payment. For these reasons, ESET classifies such programs as PUA and provides
you the option to allow or to block them.

Potentially unwanted content

If PUA detection is enabled in your ESET product, websites that have a reputation for promoting PUAs or that have a
reputation for misleading users into performing actions that might have negative implications on their system or
browsing experience will be blocked as potentially unwanted content. If you receive a notification that a website
you are attempting to visit is categorized as potentially unwanted content, you can click Go Back to navigate away
from the blocked web page or click Ignore and continue to allow the site to load.

Please see this ESET Knowledgebase article for an updated version of this help page.

http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN3152
http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=SOLN2629
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3.11.1.10   Botnet

A bot or web robot is an automated malware program that scans blocks of network addresses and infects vulnerable
computers. This type of program allows hackers to take control of many computers at the same time and turn them
into bots (also known as a zombies). Hackers typically use bots to infect large numbers of computers. This large
group of infected computers is referred to as a botnet. If your computer is infected and becomes a member of a
botnet, it can be used in distributed denial of service (DDoS) attacks, and can also be used to perform automated
tasks over the Internet unbeknownst to you (for example sending spam, viruses or stealing personal and private
information such as bank credentials or credit card numbers).

3.11.2   Types of remote attacks

There are many special techniques which allow attackers to compromise remote systems. These are divided into
several categories.

3.11.2.1   Worm attacks

A computer worm is a program containing malicious code that attacks host computers and spreads via a network.
Network worms exploit security vulnerabilities in various applications. Due to the availability of the Internet, they
can spread all over the world within a few hours of their release.

Most worm attacks can be avoided by using default security settings in the firewall. Also, it is important to choose
Public network protection type in public networks and to keep your operating system and programs up to date with
the most recent security patches.

3.11.2.2   DoS attacks

DoS, or Denial of  Service, is an attempt to make a computer or network unavailable for its intended users. The
communication between afflicted users is obstructed and can no longer continue in a functional way. Computers
exposed to DoS attacks usually need to be restarted in order to work properly.

In most cases, the targets are web servers and the aim is to make them unavailable to users for a certain period of
time.

3.11.2.3   Port scanning

Port scanning is used to determine which computer ports are open on a network host. A port scanner is software
designed to find such ports.

A computer port is a virtual point which handles incoming and outgoing data – this is crucial from a security point of
view. In a large network, the information gathered by port scanners may help to identify potential vulnerabilities.
Such use is legitimate.

Still, port scanning is often used by hackers attempting to compromise security. Their first step is to send packets to
each port. Depending on the response type, it is possible to determine which ports are in use. The scanning itself
causes no damage, but be aware that this activity can reveal potential vulnerabilities and allow attackers to take
control of remote computers.

Network administrators are advised to block all unused ports and protect those that are in use from unauthorized
access.
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3.11.2.4   DNS Poisoning

Using DNS (Domain Name Server) poisoning, hackers can trick the DNS server of any computer into believing that
the fake data they supplied is legitimate and authentic. The fake information is cached for a certain period of time,
allowing attackers to rewrite DNS replies of IP addresses. As a result, users trying to access Internet websites will
download computer viruses or worms instead of their original content.

3.11.3   Email

Email, or electronic mail, is a modern form of communication with many advantages. It is flexible, fast and direct,
and played a crucial role in the proliferation of the Internet in the early 1990‘s.

Unfortunately, with a high level of anonymity, email and the Internet leave room for illegal activities such as
spamming. Spam includes unsolicited advertisements, hoaxes and proliferation of malicious software – malware.
The inconvenience and danger to you is increased by the fact that the cost of sending spam is minimal, and authors
of spam have many tools to acquire new email addresses. In addition, the volume and variety of spam makes it very
difficult to regulate. The longer you use your email address, the more likely it will end up in a spam engine
database. Some hints for prevention:

· If possible, don’t publish your email address on the Internet

· Only give your email address to trusted individuals

· If possible, don’t use common aliases – with more complicated aliases, the probability of tracking is lower

· Don’t reply to spam that has already arrived in your inbox

· Be careful when filling out Internet forms – be especially cautious of options such as “Yes, I want to receive
information”.

· Use “specialized” email addresses – for example, one for business, one for communication with your friends,
etc.

· From time to time, change your email address

· Use an Antispam solution

3.11.3.1   Advertisements

Internet advertising is one of the most rapidly growing forms of advertising. Its main marketing advantages are
minimal costs and a high level of directness; what’s more, messages are delivered almost immediately. Many
companies use email marketing tools to effectively communicate with current and prospective customers.

This type of advertising is legitimate, since you may be interested in receiving commercial information about some
products. But many companies send unsolicited bulk commercial messages. In such cases, email advertising crosses
the line and becomes spam.

The amount of unsolicited email has become a problem and it shows no signs of slowing. Authors of unsolicited
email often attempt to disguise spam as legitimate messages.

3.11.3.2   Hoaxes

A hoax is misinformation which is spread across the Internet. Hoaxes are usually sent via email or communication
tools like ICQ and Skype. The message itself is often a joke or Urban Legend.

Computer Virus hoaxes try to generate fear, uncertainty and doubt (FUD) in the recipients, bringing them to believe
that there is an “undetectable virus“ deleting files and retrieving passwords, or performing some other harmful
activity on their system.

Some hoaxes work by asking recipients to forward messages to their contacts, perpetuating the hoax. There are
mobile phone hoaxes, pleas for help, people offering to send you money from abroad, etc. It is often impossible to
determine the intent of the creator.

If you see a message prompting you to forward it to everyone you know, it may very well be a hoax. There are many
websites on the Internet that can verify if an email is legitimate. Before forwarding, perform an Internet search on
any message you suspect is a hoax.
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3.11.3.3   Phishing

The term phishing defines a criminal activity which uses techniques of social engineering (manipulating users in
order to obtain confidential information). Its aim is to gain access to sensitive data such as bank account numbers,
PIN codes, etc.

Access is usually achieved by sending email masquerading as a trustworthy person or business (for example,
financial institution, insurance company). The email can look very genuine, and will contain graphics and content
which may have originally come from the source it is impersonating. You will be asked to enter, under various
pretenses (data verification, financial operations), some of your personal data – bank account numbers or
usernames and passwords. All such data, if submitted, can easily be stolen and misused.

Banks, insurance companies, and other legitimate companies will never request usernames and passwords in an
unsolicited email.

3.11.3.4   Recognizing spam scams

Generally, there are a few indicators which can help you identify spam (unsolicited emails) in your mailbox. If a
message fulfills at least some of the following criteria, it is most likely a spam message.

· Sender address does not belong to someone on your contact list.

· You are offered a large sum of money, but you have to provide a small sum first.

· You are asked to enter, under various pretenses (data verification, Financial operations), some of your
personal data – bank account numbers, usernames and passwords, etc.

· It is written in a foreign language.

· You are asked to buy a product you are not interested in. If you decide to purchase anyway, please verify that
the message sender is a reliable vendor (consult the original product manufacturer).

· Some of the words are misspelled in an attempt to trick your spam filter. For example “vaigra” instead of
“viagra”, etc.

3.11.3.4.1   Rules

In the context of Antispam solutions and email clients, rules are tools for manipulating email functions. They consist
of two logical parts:

1. Condition (for example, an incoming message from a certain address)

2. Action (e.g., deletion of the message, moving it to a specified folder)

The number and combination of rules varies with the Antispam solution. These rules serve as measures against
spam (unsolicited email). Typical examples:

· 1. Condition: An incoming email message contains some of the words typically seen in spam messages
2. Action: Delete the message

· 1. Condition: An incoming email message contains an attachment with an .exe extension
2. Action: Delete the attachment and deliver the message to the mailbox

· 1. Condition: An incoming email message arrives from your employer
2. Action: Move the message to the “Work” folder

We recommend that you use a combination of rules in Antispam programs in order to facilitate administration and
to more effectively filter spam.
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3.11.3.4.2   Whitelist

In general, a whitelist is a list of items or persons who are accepted, or have been granted permission. The term
“email whitelist“ defines a list of contacts from whom the user wishes to receive messages. Such whitelists are
based on keywords searched for in email addresses, domain names, or IP addresses.

If a whitelist works in “exclusivity mode“, then messages from any other address, domain, or IP address will not be
received. If a whitelist is not exclusive, such messages will not be deleted, but filtered in some other way.

A whitelist is based on the opposite principle to that of a blacklist. Whitelists are relatively easy to maintain, more
so than blacklists. We recommend that you use both the Whitelist and Blacklist to filter spam more effectively.

3.11.3.4.3   Blacklist

Generally, a blacklist is a list of unaccepted or forbidden items or persons. In the virtual world, it is a technique
enabling acceptance of messages from all users not present on such a list.

There are two types of blacklist: Those created by users within their Antispam application, and professional,
regularly updated blacklists which are created by specialized institutions and can be found on the Internet.

It is essential to use blacklists to successfully block spam, but they are difficult to maintain, since new items to be
blocked appear every day. We recommended you use both a whitelist and a blacklist to most effectively filter spam.

3.11.3.4.4   Exception list

The Exception list usually contains email addresses that may be spoofed and used for sending spam. Email messages
received from addresses listed in the Exception list will always be scanned for spam. By default, the Exception list
contains all email addresses from existing email client accounts.

3.11.3.4.5   Server-side control

Server-side control is a technique for identifying mass spam based on the number of received messages and the
reactions of users. Each message leaves a unique digital “footprint” based on the content of the message. The
unique ID number tells nothing about the content of the email. Two identical messages will have identical
footprints, while different messages will have different footprints.

If a message is marked as spam, its footprint is sent to the server. If the server receives more identical footprints
(corresponding to a certain spam message), the footprint is stored in the spam footprints database. When scanning
incoming messages, the program sends the footprints of the messages to the server. The server returns information
on which footprints correspond to messages already marked by users as spam.

3.11.4   ESET Technology

3.11.4.1   Exploit Blocker

Exploit Blocker monitors typically exploitable applications (browsers, document readers, email clients, Flash, Java,
and more) and instead of just aiming at particular CVE identifiers it focuses on exploitation techniques. When
triggered, the behavior of the process is analyzed and, if it is considered suspicious, the threat may be blocked
immediately on the machine.

While ESET’s scanning engine covers exploits that appear in malformed document files and Network Attack
Protection targets the communication level, the Exploit Blocker technology blocks the exploitation process itself
and record data about the threat, which is then sent to the ESET LiveGrid® cloud system. This data is processed by
the ESET Threat Lab and used to better protect all users from unknown threats and zero-day attacks (newly released
malware for which there is no pre-configured remedy).
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3.11.4.2   Advanced Memory Scanner

Advanced Memory Scanner works in combination with Exploit Blocker to provide better protection against malware
that has been designed to evade detection by antimalware products through the use of obfuscation and/or
encryption. In cases where ordinary emulation or heuristics might not detect a threat, the Advanced Memory
Scanner is able to identify suspicious behavior and scan threats when they reveal themselves in system memory.
This solution is effective against even heavily obfuscated malware. Unlike Exploit Blocker, this is a post-execution
method, which means that there is a risk that some malicious activity could have been performed prior to its
detecting a threat. However in the case that other detection techniques have failed, it offers an additional layer of
security.

Whenever a process makes a system call from a new executable page, Advanced Memory Scanner performs a
behavioral code analysis using ESET DNA Detections. Thanks to implementation of smart caching, Advanced Memory
Scanner doesn't cause any noticeable deterioration in processing speeds.

Moreover, there is a new trend in advanced malware: some malicious code now operates "in-memory only",
without needing persistent components in the file system (in other words file-less malware) that can be detected
conventionally. Only memory scanning can successfully discover such malicious attacks and ESET is ready for this
new trend with its Advanced Memory Scanner.

3.11.4.3   ESET LiveGrid®

Built on ThreatSense.Net® advanced early warning system, ESET LiveGrid® utilizes data that ESET users have
submitted worldwide and sends it to the ESET Virus Lab. By providing suspicious samples and metadata from the
wild, ESET LiveGrid® enables us to react immediately to the needs of our customers and keep ESET responsive to the
latest threats. ESET malware researchers use the information to build an accurate snapshot of the nature and scope
of global threats, which helps us focus on the right targets. ESET LiveGrid® data plays an important role in setting
priorities in our automated processing.

Additionally, it implements a reputation system that helps to improve the overall efficiency of our anti-malware
solutions. When an executable file or archive is being inspected on a user’s system, its hash tag is first compared
against a database of white- and blacklisted items. If it is found on the whitelist, the inspected file is considered
clean and also flagged to be excluded from future scans. If it is on the blacklist, appropriate actions are taken based
on the nature of the threat. If no match is found, the file is scanned thoroughly. Based on the results of this scan,
files are categorized as threats or non-threats. This approach has a significant positive impact on scanning
performance.

This reputation system allows for effective detection of malware samples even before their signatures are
distributed to users via detection engine updates several times a day.

3.11.4.4   Botnet protection

Botnet protection discovers malware by analyzing its network communication protocols. Botnet malware changes
frequently in contrast to network protocols, which have not changed in recent years. This new technology helps
ESET defeat malware that tries to connect your computer to botnet networks.

3.11.4.5   Java Exploit Blocker

Java Exploit Blocker is an extension to existing ESET Exploit Blocker protection. It monitors Java for exploit-like
behavior. Blocked samples can be reported to malware analysts so they can create signatures to block attempted
Java exploits on different layers (URL blocking, file downloads, etc.).
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3.11.4.6   Script-Based Attacks Protection

Script-Based Attacks Protection consists of protection against javascript in web browsers and Antimalware Scan
Interface (AMSI) protection against scripts in Powershell (wscript.exe and also cscript.exe).

Warning

HIPS must be enabled for this feature to work.

Script-Based Attacks Protection supports the following web browsers:

· Mozilla Firefox

· Google Chrome

· Internet Explorer

· Microsoft Edge

Note

The minimum supported versions of web browsers may vary because the file signature of browsers
change often. The latest version of web browser is always supported.

3.11.4.7   Ransomware Shield

Ransomware is a type of malware that blocks users from accessing their system by locking the system's screen or by
encrypting files. Ransomware Shield monitors the behavior of applications and processes that try to modify your
personal data. If an application's behavior is considered malicious or reputation-based scanning shows an
application to be suspicious, the application is blocked or the user will be asked to block or allow it.

Important

ESET LiveGrid® must be enabled for Ransomware Shield to function properly.

3.11.4.8   DNA Detections

Detection types range from very specific hashes to ESET DNA Detections, which are complex definitions of malicious
behavior and malware characteristics. While the malicious code can be easily modified or obfuscated by attackers,
the behavior of objects cannot be changed so easily and ESET DNA Detections are designed to take advantage of this
principle.

We perform deep analysis of the code and extract “genes” that are responsible for its behavior and construct ESET
DNA Detections, which are used to assess potentially suspect code, whether found on the disk or in the running
process memory. DNA Detections can identify specific known malware samples, new variants of a known malware
family or even previously unseen or unknown malware which contains genes that indicate malicious behavior.
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3.11.4.9   UEFI Scanner

Unified Extensible Firmware Interface (UEFI) Scanner is part of the Host-based Intrusion Prevention System (HIPS)
that protects UEFI on your computer. UEFI is a firmware which loads into memory at the beginning of the boot
process. The code is on a flash memory chip soldered onto the mainboard. By infecting it, attackers can deploy
malware that survives system reinstallations and reboots. The malware can also easily remain unnoticed by
antimalware solutions as most of them are not scanning this layer.

UEFI Scanner is enabled automatically. You can also start a computer scan manually from the main program window
by clicking Computer scan > Advanced Scans > Custom Scan and selecting the Boot sectors/UEFI target. For more
information about computer scans, see the section Computer scan.

If your computer has already been infected by UEFI malware, read the following ESET Knowledgebase article:
My computer is infected with UEFI malware, what should I do?

http://go.eset.eu/knowledgebase?lng=1033&segment=business&KBID=kb6567
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